Phone won't stay off

I’m having the same problem right now. I have not rebooted my FP2 for a while, but it obviously must have worked before the update to lineage-15.1-20180917-nightly-FP2-signed.
I say so because the update to lineage-15.1-20180925-nightly-FP2-signed did not work. Upon hitting install, the phone does not reboot into recovery to finish the update, but instead reboots to system and tells me the update failed.
After I forced recovery with holding volume-up manually, the installation process finished. Now I am on lineage-15.1-20180925-nightly-FP2-signed, but the problem persists.

The only other thing that changed is that I received and installed my “Camera Module v2” yesterday, for the first time. Now I just installed the original camera and shutdown works properly. Install v2 back again and shutdown does not work. So I guess for me the cause of the issue is 100% clear and now I have to decide between the improved camera and the ability to shutdown. But I think I can live with the TWRP workaround.

Yes, the effects of the new camera module are known behaviour for some time already.
But as of now it is still not known how exactly the new camera module causes this and how it can be fixed, and that’s what it is about here now.


This new camera bug preventing shutdown is known for a long time on LineageOS and is also present in FairphoneOS-Android7-beta. So the FP team should be working on it, follow this bugreport to get informed of the progress :slight_smile:


Just to point out that the original problem on this thread (I’m the OP) is with a FP2 with the original camera. Also, the problem does not affect TWRP’s ability to choose where to reboot to. So I do not think it is the same bug. (Also, I had the same bug on a Xioami Mi 4 LTE.)

I’m 90% certain that the correct value is not getting set in the PMIC on shutdown, or that value is not surviving the reboot from Lineage. I have found good evidence that the boot up side of things is just fine.


I think you may have looked into the wrong files, as your link refers to the android 5.1.0 revision 6 branch of AOSP. (LineageOS 15.1 is based on AOSP 8.1.0, probably the latest revision.)

If you really want to dig down into the code, you can do so directly at the LineageOS github repo specifically for the FP2’s kernel:

Have fun!


@chrmhoffmann … any chance this could be put into the FP2 LineageOS code so that long-pressing the power button first activates the flashlight and then the shutdown menu?

This is one of the ugliest work-arounds ever and I’d prefer to get any thechnical information, WHY this helps and perhaps then find the real cause and solution :).


Of course this would have to be looked at, and ideally quickly … but this is not an ideal world we live in, and LineageOS is a spare-time community effort.

From the LineageOS point of view the most time-saving approach should be to hope for Fairphone staff to figure it out for good in their Android 7 and then analyze or ask what they did.

In the meantime … whatever hack works :slight_smile: .


I just installed LOS15.1 (14nov2018 nightly version) on my FP2 (with new cam module) and got the same issue (instant reboot after shutting down).

Solved when I turn ON the flashlight just before shutting down ! :thinking:

I had the same problem but with a new Fairphone with the original OS (Android 7.1.2 build 18.09.2). Your workaround work well too ! Thank you.

The very same problem with a brand new Fairphone2 with Android 7.1.2, and turning on the flashlight before power off prevents the automatic reboot for me as well. Weird, but it works

to avoid duplicate topics please continue here: was released:

This includes the Shutdown fix, I’m currently downloading and testing…


Yipeeee! The fix works!


Indeed, it’s fixed, WOW!

Wohooo. Thanks to Fairphone devs for the fix. I just applied it to lineage!


I applied this update (as previous ones), but since November 2018, although I download the release and install it, it seems that the upgrade does not work.

Where can I report this issue?!

What does it say in Settings - System - About phone - LineageOS-Version?

How do you try to install the update … automatically via the Updater or manually via the TWRP recovery? Is there an error message along the way?

Does your FP2 reboot to TWRP when installing? if not it just reboot normally and display a error message…
You could force the reboot to TWRP by maintaining VOL UP during the OTA install process or by turning on Torchlight before starting OTA installation. :slight_smile: