English

Sailfish OS 3.1.0.12 beta7 release

Tags: #<Tag:0x00007f05d8f29088>

Sailfish OS 3.1.0.12 beta7 release is now ready. Installation and update instructions can be found at https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_fp2. Highlights of the new release:

  • Updated to Sailfish OS 3.1.0.12
  • Based on Android 6 (18.04 release)

Important notes for updating from old Sailfish OS releases (3.0.1.11 beta4 or older)! Because of enabling on-demand proximity sensor support all users can now flash the modem partition from Fairphone Open OS 18.04 release using fastboot. Please check wiki for detailed instructions.

Important notes for updating from Sailfish OS releases before 2.1.3.7 (alpha5)! Please be very careful when during update about flashing the Android system.img. During update process Android system.img needs to be flashed right after updating Sailfish OS and shutting down the device. Do not flash system.img before Sailfish OS update.

Known issues:

  • If anyone still notices the previous issue that updating camera configuration fails during camera module change, update or installation please report it to me and use the fix mentioned in earlier release notes (Sailfish OS 3.0.2.8 beta5 release)
16 Likes

Interesting news. I’d love if I could find comparative performance benchmarks for different operating systems on the Fairphone 2 - especially now that available RAM is tight. The Phoronix website is great for giving a list of benchmarks of a given hardware using different operating systems. An old Apple laptop for instance. Sadly, the guy never did it for Fairphone. Or Raspberry Pi either, for that matter (he did compare the hardware to other developer boards though).

FP2 works after update without problems - like always :wink:.
Many thanks to mal.

3 Likes

Thanks mal for keeping up this awesome work!

Had an issue this time with Storeman which I like to share:

  1. preparation: disabled “openrepos” sources (from Storeman UI) as recommended on the wiki page
  2. run upgrade process (for some reason I skipped the “devel-su zypper refresh -f” step)
  3. after upgrade was complete I happily started 3.1.0.11
  4. try enabling openrepos sources in Storeman -> boom :boom:
    • enabling sources not possible: “hangs” on (first?) repo URL
    • package updates fail with “file xy not found at url” (see screenshot)

Seems quite a number of people ran into scenarios linked to -> Github:

Running the following via SSH solved the most serious issues for me:
devel-su zypper refresh -f
devel-su pkcon refresh

Still “enable all sources” keeps failing. So I manually removed URL entries one by one (wrote down each by oldskool-pen-and-paper-method - fortunately not many :smile:). After enabling the remaining “all software sources” I readded the failing ones (search for the source name as you would for a package; select any found package and hit “add source” from top menu). Everything seemed back to “normal” despite one thing… :smile:

For a test I disabled/enabled the failing sources. As expected “enable all sources” still keeps failing in the “update cache” step. Apart from that Storeman works fine. Anyone who knows how to solve this, please share you knowledge, thanks! :wink:

Edit: Linked to Github -> https://github.com/mentaljam/harbour-storeman/issues/105

You could try to enable the sources manually (assuming those are not removed completely) by checking output of “ssu lr” and if there are disabled openrepos sources there just use “ssu er repo_alias” where repo_alias is the simple name given to the repo (for example “openrepos_rinigus”). I personally never disable openrepos at all but I only use simple apps from there anyway. The disabling is rarely needed but some very hacky apps or patches can cause issues sometimes.

3 Likes

Hello Antis81,
i use a little script to disable and enable the openrepo entries.
EDIT 2019-09-10: I modified the script see below suggestion from @mal :grinning: - you could place it on a directory in PATH (e.g. /usr/local/bin/openrepos.sh)

#!/bin/sh
_BASENAME=`basename $0`

usage() {
  echo "Usage: $_BASENAME help|enablerepo|er|disablerepo|dr"
  echo "       help           # print this usage"
  echo "       enablerepo|er  # enable all openrepos entries"
  echo "       disablerepo|dr # disable all openrepos entries"
}

if [ $# -ne 1 ]
then
  usage >&2
  exit 1
else
  case $1 in
  enablerepo|er|disablerepo|dr)
    OPTION=$1 ;;
  help)
    usage
    exit 0 ;;
  *)
    usage >&2
    exit 1 ;;
  esac
fi

ssu lr | grep ' openrepos-' | awk '{print $2}' | \
while read OR
do
  echo ssu $OPTION "$OR"
  ssu $OPTION "$OR"

done
exit 0

Here my history (done on root):

...
147  ssu release 3.1.0.12
148  dr.sh # 2019-09-10: should now be openrepos.sh dr
149  ssu lr
150  zypper clean -a
151  zypper ref -f
152  version --dup
153  sync
154  er.sh # 2019-09-10: should now be openrepos.sh er
155  reboot
...

And it worked for me without any problem on Jolla or openrepos store with all the updates i have done until now.

Best regards

Gabs

1 Like

Wouldn’t it be easier to have one script that reads a parameter from command line, for example “openrepos.sh enable” and “openrepos.sh disable”, then it would select the commands it runs based on the parameter? I could even think of adding the script to wiki for all users to use if they want.

2 Likes

Putting it to the wiki is a good idea.
If it is useful/possible you also can add it to a SailfishOS rpm package, so other community ports also have a benefit after installation :wink:.

1 Like

@mal
For any one arriving late, devaamo.fi no longer reachable as expired and currently in its 1 month “period of grace”.

1 Like

I contacted the maintainer of that server and he will renew the domain for a transitional period after which the server will move to some other domain. I will update the links when that happens.

3 Likes

Apparently the link for downloading the zip file is (still) dead. :frowning: I started OTA update but it failed after updating many packages… Invoking ‘version --dup’ again yields ‘Error: Installation aborted by user’ and then gives up after 9 retries. Now my OS is broken. Could you please share the zip file for beta7 with me such that I can install this over TWRP?

Many thanks!

Hallo @mal,
any news about the 3.2.0.12 release?
Many thanks
gabs

1 Like

I have been using 3.2.0.12 on my main device for a couple of days now and so far everything seems to working as before. Something that will be fixed in next release is mpeg2 hardware decoding. I’ll try to remember what other changes I made.

I’m not yet sure when I will make the release because I cannot test the device well until end of next week (i don’t want to test calls and related things while roaming).

6 Likes

I just did the update, and the update itself was flawless, so thanks @mal!

I do have a problem with openvpn. I use openvpn from the commandline to set up a vpn to my home network. To automate some tasks i made a script which starts openvpn and takes care of some other stuff, which is why i don’t use the gui.
The strange thing is:
If i connect the phone to my pc, log in to the phone with ssh and start the script, everything works as expected and as it did before the update. If i use the terminal on the phone itself and start the script (the way i would normally use it) it doesn’t work. Openvpn is started with the --daemon --askpass, and as expected it asks the password for the private key file, but after that it doesn’t daemonize. If i log in via ssh to check the situation i see the VPN interface has come up.

Any suggestions on how to troubleshoot this? Or is it possible to downgrade openvpn the working previous version?

1 Like

With a bit of fiddling i found a workaround for the problem:
What i used to do is open the terminal, and as nemo user type:
devel-su ./vpn.sh start
Where vpn.sh is my script to start the vpn. Somehow that now gives the problem as described in my previous message, but if i use the real su command it works, so now i use:
devel-su su - -c “/home/nemo/vpn.sh start”
As far as i know the main difference is that devel-su only seems to elevate privileges su starts a new shell and environment, that’s something i still have to investigate. At least my vpn works with this workaround :slight_smile:

1 Like