English

Sailfish OS 3.0.0.8 beta3 release

sailfish
Tags: #<Tag:0x00007f9ff7c518b0>

#1

Sailfish OS 3.0.0.8 beta3 release is now ready. Installation and update instructions can be found at https://wiki.merproject.org/wiki/Adaptations/libhybris/Install_SailfishOS_for_fp2. Highlights of the new release:

  • Updated to Sailfish OS 3.0.0.8
  • Based on Android 6 (18.04 release)
  • Camera improvements
    • Video flash torch re-enabled
    • More supported manual ISO values
  • Enabled step counter sensor

Important notes for updating from Sailfish OS releases before 2.1.3.7 (alpha5)! Please be very careful when during update about flashing the Android system.img. During update process Android system.img needs to be flashed right after updating Sailfish OS and shutting down the device. Do not flash system.img before Sailfish OS update.

Known issues:

  • Youtube videos crashes browser when seeking
  • Camera configuration detection for secondary (front) camera sometimes fails (only during camera module change, update or installation)
    • To solve the issue remove /etc/droid-cameradetect-module-main.conf and /etc/droid-cameradetect-module-front.conf and run “systemctl restart droid-cameradetect”
    • Repeat the previous instruction until both cameras work (configuration is at /etc/dconf/db/vendor.d/jolla-camera-hw.txt and the validity of resolutions for secondary camera can be checked also manually)

:pencil2: Operating Systems for Fairphones
#2

In addition to the camera improvements in this release the next release will (if all does well) have even more camera features such as scene modes (including HDR) and filters. First these will be usable in a community camera application currently being implemented. I have already an extra test repository with the application and other needed patched packages. The application still needs a lot of work to be user friendly but most of the features already work on my FP2 but because not all changes were merged yet and are still work in progress I didn’t include all needed packages to this release.


#3

Awesome @mal, many thanks !!!

I did the OTA-update via SSH without any trouble :grin:

,---
| Sailfish OS 3.0.0.8 (Lemmenjoki)
'---

The default wallpaper is really pretty with northern lights… :slight_smile:

What works for me : Email (send/receive), Calendar/Contacts (CalDAV/CardDAV), Screenshot (Vol+ & Vol-), Camera, Torchlight, …


#4

Thanks, @mal, that’s great work!
I did the installation from the scratch - as described in your link - and it works fine!


#5

@mal , again many thanks ;-). I also updated via ssh without trouble.

The only problems i have, is with the two sim cards i use on the phone.
But i think the problems was already on the previous versions.
I’m missed some SMS - but i’m not sure .
The configuration on my phone is:

sim 1 is for office on German telekom
sim 2 for private 1&1 provider is vodafone.

The problems are:

  1. Enabling mobile network only work with the sim 1 (telekom).
    I tried various settings on sim 2 (which i found at vodefone,
    and also i reboot the phone when changing the ‘use setting’.

  2. Sending and receiving SMS only work on SIM 2 (vodafone).

Can you give me any hint, where i can get more (log) information about these problems.
Switching the two sim cards, i can’t use both - may be the configuration did not refresh correctly?
Any hint for this behavior?

But this is moaning on a high level ;-).
Anything else works perfectly for me.

An other question i have - only for understanding.
On the tablet, the start screen (and for example also the setting) also work in landscape mode.
It seems all community ports (i also have a Gemini PDA) did not show this behavior.
Is it planned to enable the ports also for landscape mode at startup?


#6

Do you have any update on the dual-sim issue?
I haven’t updated to sailfish 3 yet because for me it’s essential to have dual-sim working correctly.


#7

@pa4wdh: No. I did not have any solution for my problem at the moment.

The problem with the mobile connection (on sim 2) was also on late SailfishOS version 2.x.
And i think the SMS problem (on sim 1) also occur on an earlier version.

So if you did not have the problems with the latest 2.X version of SailfishOS, i have to reinstall my Fairphone2 from scratch during the next weeks when i’m on vacation ;-), to check why i have it on my Phone …

May be the problem i have came form the continuous update form the first Alpha version from mal.
I did not reset my configuration since the first installation of SailfishOS - and i don’t know how to reset it (also the android part of the phone) without making a new installation :frowning:

Or do anybody know how to switch between booting android and SailfishOS without the whole installation procedure?


#8

Thanks for your update @gabs
I do not have any problems with my current SailfishOS (2.2.1.18) and two SIM cards (both KPN NL), everything seems to work as expected.

If i try the Sailfish 3 update and it doesn’t work, is there a way to rollback?


#9

@pa4wdh: there is no official way to roll back. at tjc there are some descriptions how to roll back on commandline, but it might be, that some updated configuration did not work anymore and a down grade of rpm packes always is a risc. the better way isvto backup the whole system and restore it if needed (i think mal wrote it here anywhere?). or you find a description on jtc.
i will reset my phone at this week and install it new. i will share the result here when i’m finished the installation.
so if you did not need it this week, take a look here next year :crazy_face: … happy new year …


#10

Easiest way : restore a TWRP backup :slight_smile:


#11

Hello,
It is not so smooth for me to follow the instructions from wiki.merproject page. I find them confusing, and a bit going back and forth. Particularly the section where you have to flash images, I don’t understand from which zip file each image should be flashed from.
At the end, I still tried to flash the sailfish zip file, through TWRP, but it failed immediately, mentioning that the file is corrupt.
Am I the only one experiencing issues?


#12

@pa4wdh : Now i have reinstalled my Fairphone 2 from scatch.
First Android 18.04.1 (and gms59.1.5.1 modem part) then SailfishOS 3.0.0.8 Beta3, as described on the wiki.

It seems that me problem with the SMS on the Telekom sim is really a sim (or Telekom) problem, not a Phone or OS problem (i have to talk to the Telekom support).
I tried sending SMS with Android, switching the sim cards on Android, but the problem stays with the Telekom sim :unamused:. I get an error 21 sending an SMS (what ever this meen …) and did not receive a SMS sent by and other sim.

My problem with the mobil connection vanished after the new installation of the SailfishOS.
Switching the sim for the mobil connection requires a reboot of the phone, but both sims work.
Maybe this problem did not not occur on your phone because you use two sims with the same provider …

So i think an update should be no problem on your phone :wink: (but always backup your data …).


#13

5kup : on TWRP you have to disable the MD5SUM check, then it should work.


#14

I know the instructions on wiki can be a bit confusing for some people. I can modify the instructions if anyone has suggestions how to make those better.


#15

Thanks for your update @gabs, i guess I’ll just have to try the update.

I do have an other question:
I’d like to do some audio recording and the internal microphone doesn’t work well for anything more than a few centimetres away. My plan is to use an external microphone, does anyone have any experiences to share (with sailfish specific or with the fp2 in general)?


#16

I did a summary in the previous alpha5 post :slight_smile: :


#17

Thanks a lot for the feedback folks! It is greatly appreciated!
This is what I had tried just before receiving your replies:
In order to start from a phone with Fairphone Open OS 18.04, Flashed (using command sh flash-for-unix.sh) ‘sibon-18.04.1-manual-switcher’ from Fairphone’s website, because flashing the file from wiki.merproject would result in the phone not starting anymore.
Then, fastboot flash modem ./BP/NON-HLOS.bin after navigating in the directory of the unzipped ‘FP2-gms59-1.5.1-manual’ file
Then navigate to the directory fp2-sibon-18.04.1-manual-switcher\images and fastboot flash system system.img, fastboot flash recovery recovery.img, fastboot reboot
Turn on the phone, calibrate the proximity sensor, try the wifi antenna and calling, all ok.
Reboot in TWRP recovery, and hit install, navigate to the zip file sailfishos-fp2-sibon-release-3.0.0.8-beta3.zip, and install with MD5SUM check box not ticked and without wiping.
And it seems to have worked! All antennas, and preinstalled apps work. Very pretty OS btw!!!
Only, the phone will not turn off anymore. Powering off always result in reboot.
Also, in the jolla store, the search function doesn’t work, so I can’t find aptoide. I tried searching for it, and installing it from the website, but the installation doesn’t work.
Do you think I should reinstall the whole OS?


#18

When you switch on the torch before shutdown, does that work?
At least for Android 7 or higher this workaround is needed to power off (otherwise it just reboots).


#19

So I tried a couple of times, and it does not always work. actually, it worked 1 time out of 4.


#20

Make sure the phone is not connected to USB or a charger, or the flashlight workaround might not work.
Maybe turn off Bluetooth, too.