Sailfish OS alpha5 release

(For some reason, merproject bugzilla fails to email me a password reset token, or I wouldve already edited wiki myself)

Couple of suggestions for the wiki:

  • Boot to TWRP recovery - add “hold power + volup for 10sec, until recovery splash screen shows”. I do this so rarely, there was no memory of how it worked, had to do a bunch of searching to find all the steps out.

  • Linking directly to might make sense, this made a huge upgrade to whatever I had before (something really old)

  • Copy the downloaded Sailfish OS zip to sdcard or to somewhere outside sailfish rootfs in userdata partition - if I don’t want to use sdcard or don’t have one, where exactly could I copy the zip - one example? Wording like “somewhere outside sailfish rootfs” is a bit cryptic for someone not tuning into this system too often.

1 Like

Improved vibration effects

Hmm, as far as I can tell, the screen haptic feedback still doesn’t function? I just realized, that’s a big “feeling” difference to the XpX, the FP2 feels so “quiet” :slight_smile:

EDIT … OR is the FP2 case so thick that the vibration doesn’t come through? Phone ring vibration works fine though.

The difference between the current state of vibration effects and what it was before is quite big. Previously you couldn’t even notice the vibration for incoming calls for example and now it’s clearly noticeable, As for the shorter vibrations like on-screen keyboard button presses, those are configurable in a file so I can adjust those if needed.

Hello mal,
after update, on my fp2 everything works as described.
Both cameras (i have the old ones) worked immediately after update ;-).
Thank you (again) for the fine work.

Must just be my error but for some reason can’t switch device off via UI as immediately reboots.


No that’s not just you:


It’s very strange why I have never had problems shutting down the device. Could someone (maybe @Ingo or @aspergerguy) with that issue get some logs, if /proc/last_kmsg exists I would like to see that, because that would tell whether there is some kernel crash during showdown which could cause a reboot. Otherwise output journalctl -b could be useful. Do you have WLAN, Bluetooth, GPS or some other features on when attempting the shutdown, any difference if everything is turned off?

Do you still have the old camera @mal? Reboot happens practically only with the new camera. I think Lineage guys try for several weeks already to get rid of it…


More info here:

1 Like

I have only the old camera modules so that could indeed be why it doesn’t reboot for me. Anyway it would be interesting to see if there is some kernel crash when the reboot happens.



Should have confirmed that new camera modules installed and makes no difference if all features disabled. Have a copy of /proc/last_kmsg which is 123kb, in what format do you want it attached here or emailed somewhere?

You can share the last_kmsg for example via pastebin or similar service. Or if you can send it as private message on this forum.

Here are my files (new camera modules; I don’t have the old ones)

That was with WiFi and mobile networking on, bluetooth off and location set to battery saving.
Reboot happens also if all of the above is off.

1 Like

Here is my last_kmsg file:

Thanks @mal for this release!

I have a question: people at UBports have (partly) made the new camera modules work. As far as I know flash does not work yet and the image of the front camera is rotated by 180 degrees.
Is there a chance that your work could be of benefit for making the modules work in Ubuntu Touch?
The issue can be found here:

1 Like

Indeed ! See the bugtracker for some hints in error logs, a.o.

  • msm_cci_i2c_read: wait_for_completion_timeout
  • Unable to find class com.qti.server.power.ShutdownOem

Hope this can help you, @mal

1 Like

One thing about the reboot issue: the same FP2 with Ubuntu Touch can properly power off. Not sure if that information is of any help…


I have a simple question regarding the installation process:

In the instructions it says

Sailfish OS will have a battery drain, if in the past you have installed the whole Android zip of Fairphone OS >=1.6.2 or Opensource OS >= 16.08. To fix it: […]

I bought a new FP last October and never used it so far.
So clearly I never ‘in the past […] have installed the whole Android zip of [anything]’.
However, my FP2 might have shipped with Fairphone OS >=1.6.2 or Opensource OS >= 16.08.
Does that mean I need to go through the steps to fix the battery drain, or can I directly flash the system and recovery partition with Opensource OS 18.02 via fastboot and then install Sailfish on top of Android?
Thank you in advance for the clarification and @mal for all the work put into this and previous releases.

If you have a device with Android version bigger than the ones mentioned then you will need the older firmware. My suggestion is that in case of completely new Sailfish OS installation you will flash the complete Android 18.02 on the device via fastboot, then flash the modem partition from the older release mentioned in wiki. I updated the instruction a bit to tell only to flash the modem partition from the old release since the other partition can (and probably should) be updated.

Hi @mal !
I have a somehow corrupted TWRP backup of SailfishOS that bootloops when I flash it. I changed my hardware (12MP camera) in the meantime so this could be linked…
I’m planning to install fresh the alpha5 following the instructions, anyway. But could it be possible to re-import my settings from the saved file? Like flashing one of the partitions, or manually copy and paste one folder?
I don’t have many files to save, I’m looking mainly to the configuration files for my Jolla account, e-mail settings, carddav/caldav sync, jabber chat account…