Roaming data not functioning

Changing from Samsung to FP2, I cannot access roaming data anymore (I can call, or text but no Internet) Neither in Germany, with my home provider nor in Denmark. I have the roaming on, and the preferences set right. I tried different operators. The signal “R” is on, but I cannot get Internet.
This was my friend phone and we did a factory reset, he never had this issue. So it shouldn’t be the phone
I read the forum and haven’t got any useful answer.
I tried to enter manually the APN - not working.
-> About APN, I don’t get why I should enter manually APNs every time I change provider or country? (if this is the issue)
I am at lost to understand that issue.
Thanks for any help.

Which operator do you have, and from which country is your SIM card?

The APN data depends on your SIM, not the country you’re in or the network you’re roaming on. It should be retrieved automatically when you insert the SIM for the first time but sometimes it isn’t.

Check if your SIM card is using 2G, and if it does, change to 4G (if possible).

Hi Jacques (ou plutôt “Bonjour Jacques”, si je ne m´égare pas sur l´origine de ton prénom),

If I were you I would ask my telefon provider (fournisseur d´accès) to find a solution. He must give you all informations about the APN and the ways to connect.
For example O2 in Germany :
When the APN has been determined, the connection between your providers and the other one would work.

Bon courage.

thanks for the answer.
It’s the German fonic mobile

I tried the 2G, 3G, 4G
but thanks for the hint!

The provider is fonic mobile.
When I put the settings from the provider in, I cannot turn on the “active/desactive APN” it’s in a grey shade.

Hi Jacques,

I don´t know this provider but they belong to Telefonica (O2 if you like). You should to enter the data I gave you in my last message. It could work ; or try to read this page :

If I were you I would ask my internet provider to activate your SIM card. I think that your SIM card is defectuous.

On my Fairphone 2 “APN aktivieren/deaktivieren” is grey too (not accessible, I mean).

I did try your setting and many different ones from the fonic mobile homepage and other Internet link.
I will replace the SIM, then.
thanks for the advises

Hi Jacques,
if you haven’t bought a new sim card yet. I had the same problem (German fonic SIM and being in Denmark) and for me it worked deleting all APNs and then adding - so maybe it is worth giving it another try.

Kind regards,

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.