🇬🇧 🇩🇪 Fairphone 2 with Android 9 - no Mobile Data connectivity

I have the same problem (no mobile data after Android 9 update). Can someone guide me as to the correct route to fix this? I couldn’t follow a lot of the thread above as I don’t speak German.

You need to ask your provider for the APN settings, or probably you can find on their web page. Then go to settings - network- mobile network-more/extended-check/change the settings as per provider

1 Like

Thanks but I don’t appear to have the options you describe. I can go to Settings - Network & Internet - Mobile network - Advanced - Access point names, and then there are radio buttons for Vodafone UK and Vodafone UK Prepay. Vodafone UK Prepay is currently selected.

Can anyone assist?

When you click on the name the “form” opens, you can check/change and save using the 3 dots at the right upper corner

Its German again, but that’s how it looks like

Thank you so much! I can see the form, but it’s greyed out and I can’t edit it.

Maybe you have to delete the existing APNs first as mentioned here:

1 Like

Thanks Volker, I’d like more confidence than “maybe” before I delete things. I don’t want to make things worse by guessing.

I can go to Settings - Network & Internet - Mobile network - Advanced - Access point names, and then there are radio buttons for Vodafone UK and Vodafone UK Prepay. Vodafone UK Prepay is currently selected. If I tap on Vodafone UK Prepay it brings up a form similar to that shown by yvmuell, but it is greyed out and I can’t edit it. if I click on the three dots in the top right corner, I can choose Save or Discard.

I have been told by Vodafone that I should change the Username and Password to Web, but I can’t do that.

Can anyone here assist?

1 Like

So you can def. Not tab on name or passport and an additional window opens to correct the name? Maybe you can just add a new 1, for that you should find a plus sign in the upper right corner?

I’m not sure what you mean by “tab on name or passport” but the forms are greyed out and whilst I can scroll through it, I can not select anything on it. There is no plus sign in the upper right corner, but there are three dots. When I select that I can choose to save or discard.

Actually, the way Yvonne is describing is exactly how I could finally solve this issue. You really should try it with the ±sign. You should find it at the left of the magnifying glass (which again is at the left of the three dots you mention). I also couldn’t edit the existing settings, but adding a new entry with the ±sign did resolve the issue.

1 Like

Thanks. The ±sign is not on my screen.

In that case, I would to Vodafone and ask for a new SIM-card. The reason, why the settings are greyed out is almost certainly due to the fact, that these settings are in a non-editable way fixed by the SIM-card.

It would be disappointing if that is the only solution as that takes days to resolve. It would have been nice to have warning of this before losing this functionality.

Just delete the APN entry (that does not work anyway), then reboot your phone and try to add the appropriate APN. That said, someone cannot break things when they are already broken…

1 Like

Are you saying that I should discard the APN entry? Please advise on how the appropriate APN should be added.

At the moment the only function that does not operate on my phone is mobile data. I do not want to make this worse by taking action based on guesses.

It cannot get worse, because phone calls do not depend on an APN. Which network operator are you with?

3 Likes

@AlanRussell no one can give you any guarantee, but I’m 99,9% sure, deleting the APNs will not do any further harm, as those are only needed for mobile data. So if you cannot add new or modify existing, deleting and reentering is the only option.

4 Likes

Thank you. Please advise on how the appropriate APN should be added.

Please let us know which network operator you are with, then I can send the respective settings…

1 Like

Thanks, I’m with Vodafone.