Roaming abroad not working

Hi, I was in France a few weekends back, tried data roaming for mobile internet but it didn’t work. I followed every step (Sim management - Roaming…), but it wouldn’t connect to any network. Phone network worked anyway. I also noticed that normal mobile internet (3g) in Belgium is weaker than with my previous mobile phones (often at E). Has this got sth to do with the manual setup of mobile internet when installing my fairphone?

I haven’t had any trouble with data roaming abroad (in Denmark, Norway, Finland and the UK), so I have no brilliant idea about how this can be solved, but possible solutions could be:

a) check that your APN settings are those that are recommended from your provider, and/or
b) find out which French networks are roaming partners to your provider and choose network manually.

As to signal strength I would guess that this has to do with the hardware design. I haven’t noticed a marked difference when comparing to my old HTC or my wife’s Samsung, but it might vary between models and it could be that you live in an area with a not to strong 3G signal.

Occasionally my phone ‘jumps’ from GSM to 3G (from E to H) and back, even when there is a strong 3G signal. I therefore often choose the Network mode option “WCDMA only” instead of “GSM/WCDMA auto mode” (of course I need to change this when in an area with weak 3G coverage). You could try this and see if it makes a difference.

Okay, thanks, I’ll check your options out.

@3s2 still got problems with roaming and mobile reception?

Hi Stefan, sorry for the late response. Well abroad I still experience
difficulties… Checked out the APN settings and everything seems to be
fine. Any ideas?

@3s2 still having problems?

I’ve gone abroad with my Fairphone 1 for the first time. I can’t connect to any networks, send or receive texts or calls. I can connect to wifi. I’ve tried all the configurations of mobile networks / data roaming on/off and everything else, but can’t get connected to anything. I’m in Hungary, and my phone is from UK, using Co-Op/Orange network.

Last week I was in Germany, Saarland. I had the same experience. The problem in Saarland is likely the network or rather say the missing network coverage.
Perhaps the network coverage in Hungary is the problem for you to.

What helpes me sometimes when i cannot get a connection is shortly activating flight mode.

According to the Phone CoOp webpage, you should have roaming in Hungary. Did any of the tips help?

If they did not:
Do you get error messages when trying to connect to networks? From what you wrote I guess that you tried GSM (2G) only - is that correct? To no avail? Same on 3G only?

1 Like

Thanks for the reply! I couldn’t make it work. When I manually searched for
networks, I found some, but when I tried to connect, I got error messages.
I tried 2G and 3G.

Well, I’m sad to report that I just came back from Spain and still find that I can’t connect to any network while abroad. Has anyone else been able to resolve this issue?

Edit: I rang the Co-op the provider in the UK, and they say they can’t do anything about it while I’m not abroad. This is really frustrating - am I supposed to spend part of my holiday trying to fix irritating phone problems? I’ve asked Fairphone about this three times and not had a reply from them at all.

Long shot, but did you already check whether you’ve somehow accidentally barred calls:
in the dialler (“Phone” app) choose settings from the options menu (left-most hardware keys) and then Voice Call > Call barring > [SIM]. Make sure all are set to disabled (as it is asking whether the barring is enabled or disabled).

Side note: SMS abroad is a funny thing - not all carriers have agreements on SMS delivery, so sometimes messages don’t arrive or don’t get sent without an error message. This can even lead to an incoming message arriving without any issues, but the acknowledgement not reaching the network it came from. This results in the originating network resending the SMS every hour for a number of days, and then once a day for a period after that - which has driven me insane on occasion.

Other than flaky SMS (which is a network provider issue as explained above) I’ve never had roaming problems with my FP1 (Two SIMs, from different countries, often both are roaming). Most roaming issues that people around me have had have generally been provider-side issues.

I don’t know when you asked support, but they are taking more than two weeks to answer support tickets at the moment.

Thanks for the reply, Johannes! I checked the settings and everything’s
already set to disabled :frowning:

I asked support a couple of weeks ago, but notably I asked once already
back in May and never got a response then. Thanks for any other ideas!

That’s very strange. I’ve never had any problems when roaming (a German and a Spanish SIM card, so at least one of them is always roaming). Maybe you disabled it on your provider’s web page? I just saw that your provider has the option enabled by default, but maybe something went wrong there. Did you already try to disable it and later enable it again?

Did you try the manual search in different places and at different times? Maybe you were just unlucky and there was just no provider available that works together with you UK provider…

A post was split to a new topic: Any recommendations for a provider with good roaming terms?

A post was split to a new topic: Roaming does not work

I’m having a problem with data roaming right now (in Spain). Also German O2, but on the FP1. It was working fine until this morning, when it suddenly disconnected, and now I can’t get it to connect again. It’s possible that I’ve used up my 50MB data package, but normally I then get an SMS from O2 offering to buy more data and I just do that. However, I’m not getting that SMS either. WiFi and Phone network are working perfectly. Any ideas?

Can you please check in your online account if you really consumed all of the 50MB? Maybe the other O2 case with the FP2 not being able to roam is indeed connected… (I’m saying that maybe O2 messed up their network, and that the issue does not lie with the FP1 or FP2.

You can’t see it on the online profile, but I checked on the data usage tab on my phone and it just about works out. So the problem seems to be with O2 rather than the phone, or at least that’s my hunch.