Roaming does not work

Hi there,

have you solved your problem?

I’ve got the same issue on my FP2. My provider is the German O2 (formerly Base/Eplus) and when i was in France last week i couldnt roam (even if O2 told me i have 50Mb free roaming).

I clicked and accept “data roaming” in the option but i could go on the internet. Should i do something else? According to a few tutorials for Android, that should be enough…

Thanks in advance,

Just for reference: We are having another O2 card with problems, on a FP1 in Spain.


Having the same problem with my FP2. I was in Ireland last month and roaming did not work, no signal at all (I am on giffgaff - using the 02 network). I am now in Jersey and it doesn’t work here too. Phone has never worked outside of England, which is an issue for me. My partner has an iPhone 6 and giffgaff works fine for her. Has this been an issue for anyone else and is there a fix?

Does this guide help?

1 Like

Thanks… That worked, I am so used to it being automatic. Thanks for the help!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.