Recycle your phone form page broken!?

Seems to be broken. I get Javascript errors… doesn’t work in chromium or firefox for a week now, what is going on?

Anyone knows anything?

Just tested it but not thoroughly and it seems to work with FF 84.
Does it only happen when you “successfully” submit the full form without red fields?
Have you tried control+F5 or private mode (turned off extensions)
Strange that it affects 2 browsers: is it always the same network, is there a pi-hole or something between you and the internet?

It also seemed to work on Firefox 78.6.0esr on an old Mac (MacOS 10.11.6). I did not push the “Submit” button, but it was active.

Thanks for your replies. No no pi-hole. I also tried with deactivating adBlocker and similar… .
Of course I pushed the submit button. But never happened anything.

1 Like

I just tried it again in firefox. In a private window I deactivated all blockers and privacy protection. Still the same. Also I don’t had any issues at any other side finally I am deactivating the protections it works.

Maybe it does matter.
I am using Manjaro I don’t have any special things like firewalls… etc. only the browser with its plugins. Even the same problem in chromium which I only use if something isn’t working so good in Firefox.

I don’t think that is the problem if yours is updated, I have tried it with Arch and a few months back I used the form without problems.

The Problem is that we would have to fill in all the forms and send it to try to reproduce it.
Have you tried clearing the cache, control+F5, or maybe tried to do it from another device?

I have tried to send a filled form using Opera and afterwards using Firefox. Unfortunately unsuccesfully. It looks like it is stuck. When clicking the Send button, the screen greys out and a moving stripe replaces the text in the button. And the screen remains like that for hours. No error message, no timeout, nothing.
Could you please look into this, because I want to send you my old FP2 and some old Nokia’s, to help you reach your recycle goal.
Thank you in advance.


Thank you for your confirmation! :slight_smile:

I wanted to create a support ticket now but I can’t log in… -.-

Ok this time the cause were my plugins… sorry fairphone

Support ticket is open :slight_smile:

1 Like

Please try again now!


I managed to download a shipping label now.
Thank you very much for your help.
Happy holidays.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.