English

Receiver test - what should happen?

Hi there - as some phone calls cut off without explanation I was looking into what might be wrong. Elsewhere on this forum it was suggested to try running tests, by ‘dialling’ asterisk#asterisk#66#asterisk#asterisk.
I have done that, including the ‘receiver test’. It shows two headings / options: a) play audio - playing b) channel selection - receiver.
I can hear the audio playing on a loop but am not sure how to test option b) - nothing happens when I try to click on it. (Well, the heading goes grey while I press it but the song keeps playing.) Should anything else happen?
Grateful for any advice. Thank you.

1 Like

After entering *#*#66#*#* to show testing menu with three sub-menus

Select > Service tests > Test Single > Speaker

There is also the small earpiece speaker for common phone calls, the above relates to the hands free speaker. To do the earpiece speaker the option is
Service tests > Test Single > Receiver Test

A peripheral note:

You can use the *#*#'i .e. asterisks if you enclose them with the preformatted text option which is shown as the closing tag in the top menu of the text box. </>

Thank you - do you mean to say the ‘receiver test’ will only work if I connect headphones to the mobile?

My poor use of the word ‘ear’ the receiver test should give you the same ~ song output ~ from ŧhe top speaker as the hands free speaker.

I just called the top speaker ‘the ear speaker’.

So it’s my lack of clear definition as there is an option for testing the ‘Earphone’ not called the ‘Head set’ All makes sense when I slow down a bit. :slight_smile:

1 Like

Thank you very much. It’s playing simultaneously top and side speakers. So I guess that’s good.
What I was worried about was that I can’t select a) or b), they just both show at the same time. With the mic checks it gives you mic 1, records and plays back, then switches to mic 2, records and plays back etc. - so you can choose between options. Not with the ‘receiver test’ which therefore threw me.

That’s not what I get on Android 10 version 0084

dialing *#*#66#*#*

Selecting :: Service tests > Test Single

Speaker does only hands-free at the bottom left ~ Chinese song
Earphone ~ Just tried for the first time ~ Acoustic guitar one ear then the other.
Receiver test does only top ‘ear’ speaker ~ Chinese song

On the Receiver test the text appears to indicate a channel selection but I think this is just an odd formatting issue .

2 Likes

Really appreciate your help - actually, you are right! Certainly having also tried the earphone aka headset test, the receiver one now seems to be playing just from the top. Perhaps I didn’t listen properly before :roll_eyes:

So the issue with my calls does not appear to have anything to do with speakers. May see if there’s any chance the antenna may have got loose or moved…

1 Like

There may be a software glitch that doesn’t switch between audio components properly as there are cases where the bottom mic doesn’t engage in video calls after using bluetooth headphones.

Possibly - though mine are definitely not bluetooth earpieces! Oldfashioned plug-in ones.

I assume you’re using the latest OS version, aren’t you?

1 Like

Yes, I am - Android 10.

The inital release of Android 10 was about 6 months ago. There were several updates since then.
Have you installed the latest release 3.A.0084.20210204 ?

1 Like

Well, actually I’m more referring to “3.A.0084.20210204”.

When I go to system and check it says there’s nothing to update. And have vague memory of phone restarting after update fairly recently…

The system version is displayed via Settings > About phone > Build number (last entry at the bottom)

The latest ~ full title is ~8901.3.A0084. 20210204 It’s the 0084 that is often referred to.

1 Like

Thank you - yes, that’s what I’ve got. Tbh I think the ‘receiver test’ has worked and shows there is nothing there that’s wrong. So perhaps the cut-off calls were to do with the network at the time or something else, but I now know what to expect from the test :slight_smile:

1 Like

Cut offs can happen for a number of reasons, the software isn’t really coping maybe.
If you have wifi and network on it can switch between the two

If you have bluetooth enabled and the wifi is using 2.4Ghz there can interfere as they used the same frequencies most often.

If you have bluetooth and network on 4G again there can be a cross over due to frequencies.

So if the software is not good enough it may ‘cut the connection’ and not re-establish it promptly.

You can look at the frequency issue and maybe turn off bluetooth and wifi if you don’t use them 24/7