Rebooting, blackscreen while phoning, no update possible

Hello all,
I have several problems with my Fairphone 2.
First, I can’t update the Fairphone OS. At the moment I’m using OS 17.04.8.
I tried in several WIFIs and tried with another app.
Second, my Fairphone 2 is rebooting quite often, sometimes more than once daily.
Third, if I’m calling someone, the Fairphone stays in black-screen-mode. I tried some apps to solve this problem and it worked for the moment, but even this isn’t helping anymore. And I can’t update to a newer OS, where this problem isn’t accuring anymore, as far as I know.

Thanks in advance

Did you already update Fairphone updater via Google play / yalp? Is the Google app enabled? See also:

See #rebootsguide

There’s a tool to configure the proximity sensor properly. See the Fairphone troubleshooter (Display > Stays black during or after the call) or the #blackscreenguide

3 Likes

Hello Johannes,

I tried with troubleshooter, but it didn’t solve my problem. I updated the app and enabled the google app, and I still get the error, when I’m updating.
Actuall, I would have a problem with that, however as I have some other issues as the reboot problem, where the guide says: “First things first: Update your OS”, I tried updating.

What error specifically?

1 Like

After downloading the new OS and restarting the Fairphone, it just says “Fehler” (german for error). And there is a lying android figure with a red triangle above.

In the menu you’ll probably find more details about the error (“Fehler”). To access the menu, press and hold the power button, wait for a second and then press and release the volume up button.
The error may be caused by a changed system (e.g. by rooting the phone, having used twrp or …).
Probably you’ll have to install the update via “manual install”.

Okay, thanks for that advice. However, I don’t know, what causes the problem.
It says:
Supported API: 3
Finding update package…
Opening update package…
Verifying update package…
Installing update…
Source: Fairphone/FP2/FP2:6.0.1/FP2-gms-17.04.8/FP2-gms-17.04.8:user/release-keys
Target: Fairphone/FP2/FP2:6.0.1/FP2-gms-18.04.1/FP2-gms-18.04.1:user/release-keys
Verifying current system…
system partition has unexpected contents
E:Error in /cache/fp_update_FP2-gms-18.04.1.zip
(Status 7)

This error means that your system position has somehow been changed (some reasons I mentioned above). As the update is “only” an update and no complete install it can’t install on a changed system partition.
So only manual install will imho be possible.

2 Likes

That’s probably correct. I remember I had the same issue for some early Android 6-based FP OS versions.
Doing a manual inatall helped in any case.

Just as a side note: I never really found out where the unexpected system partition contents came from. I never actively modified or rooted the device back then. I had a theory that the issue might have been related to doing backups with TWRP without installing it, but I didn’t care enough to really verify.

PS: I’m just on the road / railway, therefore I can’t provide the links ATM; in case of need, the search function is your friend. :wink:

4 Likes

Thanks a lot for the support!
I just updated it manually, and it work.
@BeMiGro It’s the same for me, I never modified anything on purpose. But it worked now :slight_smile:

2 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.