Reboot required to regain 4G

I had a similar problem once, additional very slow data connections sometimes. Lineage 17.1 and two SIM-cards.
At that time I used the right SIM-slot (2nd) for data, but this was the problem. Changing to the left (1st) slot solved the problem.
Best, Peace

1 Like

Similar issue too. On LineageOS 17.1 (Android 10), only rebooting fixes the problem.
I already tried to switch off/on mobile data, switch data from the first to the second SIM (and switch-back), enable (and disable) airplane mode, … but without success :frowning: .
I hope someone will give a magic solution here :smiley: .

I’m wondering if just a bit patience might help sometimes? I think I also have this from time to time with LOS18.1 (and recently it seems to happen more often, or I just notice it more often) however when I just do nothing and wait some time (unless I urgently need internet connection immediately)it just settles itself. Probably in Germany this is connected to 3G shut down, as I have the feeling at the moment the overall network coverage detoriated a bit?

Overall I think FP2 reception is not the best, in many ways.

To not have this issue too often I would not turn off mobile data and probably it helps to set mobile data to always on in the developer settings (to help toggling between Networks faster from Wifi to Mobile at least)

I replaced my SIM card this morning and I thought it was working, but unfortunately there is no improvement. Maybe this comes from some module of the phone; I do not know which one.
I will try to use slot 2 for the SIM, I am not confident :wink:

After my initial success with this, the poor network performance has returned. It is stressful because I use the phone for public transport so I need it to work promptly. I live and work in a city where reception is generally good. My wife uses the same mobile provider and her iPhone works fine whilst my FP2 states there is no network. I have had my FP2 almost 4 years and it has generally been OK in receiving the internet but the past couple of months have been terrible. I have ordered FP4 but my confidence is taking a knock with this. Were Fairphone too ambitious in moving to Android 9?

I posted to the bugtracker yesterday it was updated this morning - “Hi everyone, a quick update:
• we haven’t been able to look into the bug report(s) yet
• we are releasing a software update soon, we would like you to update the phone when that happens and let us know if anything changes”

Hopefully this will help.


Uhm, I can remember that we had the issue that Netmgrd was crashing causing exactly this but @chrmhoffmann pushed a change on Januar 27 and from the next build on it was fine. Considering that we have LOS 18.1 already: Is your Lineage 17.1 as up to date as it can be?
The issue that @Gorbalt has sounds very similar but it shouldn’t be the same because he’s on FPOS.

1 Like

My last (official) update for LineageOS 17.1 is the 20210716-*, after, the built version is for 18.1, but I don’t make the upgrade.
With the update of July, I guess I have the fix, but the issue seems always here (I had it Friday again). I will try to use the LineageOS 18.1 in the next days (weeks) and see if the issue stays…
I will read the thread too, maybe something could help me :slight_smile: , thanks having shared it!

Yes - you should upgrade. U are also not getting any security updates anymore on lineage 17.x.



I know, but I have to take time to backup and play with adb.
I didn’t know if the 18.1 was stable on FP2, but now, I guess yes (you don’t seem the only one to have this version on your phone ^^ )… So, I will come back on few days to give a feedback…

Even if he was the only one at some point … he’s the LineageOS maintainer for the Fairphone 2, so his recommendations should carry some weight, if in doubt :wink: . (see “Maintainers” there)


Ah ah!!! It seems the occasion to thank you @chrmhoffmann and all LineageOS contributors! Really thank you to give me an Android OS without Google during the (about) 5 last years (the FP2 1 year ago only), and that on your free time! <3
So, I promise, I will upgrade my FP2 :smiley: ! … and stop to talk, I spoil the thread :-/

I don’t know if that can help…

  1. I just have the issue, and the http(s) connections (firefox, nextcloud) failed, but XMPP worked (conversations) and I don’t have mail warnings (smtp/imap).
  2. After playing with airplane mode off/on, mobile data off/on, and wifi off/on, that works. In next cases, I will try one by one actions and see what is the good one…

Well, there will be no fix for 17.1 anymore, so if you need some help in the future, there’s only one way forward.


1 Like

I saw there is a bug opened in the issue tracker. link

I’m following with interest as the same thing has been happening to me; I have to reboot to regain access to 4G. Also at present my FP2 cannot connect to my home or office WiFi; it says ‘Failed to Connect’ and even ‘Failed to Save Network’ (even though it has previously been saved. Finally, and I do not know if this is related, I find when using phone as a hotspot, often the connection drops even though the phone may show 4G is still available. Hopefully the next upgrade can fix it…

My phone has recently started performing better. Gabriel on the bugtracker suggested the problem related to the mobile operator which made me think of the Google app ‘Carrier Services’ which I believe relates to the mobile operator service. I checked my phone and ‘Carrier Services’ update 3 days ago which may explain the improvement.

@peace, are the symptoms similar to these?

Hi Ingolf,

yes, it is very similar. To be clear: I didn’t had system crashes, only data-connection crashes.
Reading the other experiences, I can’t hope for a better performance after upgrade to LOS 18.1.

Best Regards,

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.