English

Reboot required to regain 4G

Hello,
Since 2-3 months I have a network trouble.
When I activate the cellular data once, everything is fine. But if I disconnect and then reconnect, I often lose the connection. And I can’t find it again.
I tried airplane mode, APN settings, 2G/3G selection.
The only way is to restart my Fairphone 2. But the problem is not solved.
Do you know why I have got this issue?
Thanks

2 Likes

Which Operating System in which Version do you use? Did you report to your SIM provider to see if an old SIM card could be replaced? Are you using dhal SIM? Do you actively disconnect mobile data or does this happen e.g. when you reach any Wlan?

I use Android 9 from Fairphone (not open-source version)
This is a rather new SIM card (2 years old), do you think I have to replace it?
I am not using dual SIM.
I actively disconnect mobile data when I am not using it.

Probably try to use flight mode instead of switching of mobile data (you can still turn on wifi or BT).

If I use flight mode I will no be allowed to receive SMS :slight_smile:

Hmmm ok so a rare use case😉 so if there are no other ideas I would check for a replacement SIM for free

I have experienced similar on my FP2 Android 9, either no signal in a strong signal area or a 3G/4G symbol with an ‘x’ indicating no network. I tried a replacement SIM, rebooting, but without success. Today I called my provider and they suggested I switch off/on mobile data. I did this from the pull-down menu at the top of the screen, and it went from 4G with ‘x’ to just 4G. I haven’t had much time to test performance but initial results seem good. Give it a try!

Do you mean this button? Usually I turn it on/off regarding my data usage. And that is the problem. When I turn it off then on, I do not have mobile data anymore.
image

That’s the button. Apologies, I had read your previous comments about that! I suppose it’s different fixes for different situations. I am sure Fairphone have suggested changing the SIM card every 2 years but that is slightly more involved.

There are articles referring to the age of the SIM card being a factor:

https://support.fairphone.com/hc/en-us/articles/360018494857

https://support.fairphone.com/hc/en-us/articles/360048775391

https://support.fairphone.com/hc/en-us/articles/360018703378

I tried this, and my provider supplied a SIM free of charge, activating straight away.

Good luck!

Thank you I have some of the issues listed in the third link, I will try to get a new SIM card.
I will let you know!

I’ve seen similar behaviour with several types of phones, operating systems and networks/providers. When I come back from an area with no signal, the phone sometimes does not reconnect to any network. It often worked after a reboot, switching airplane mode on/off etc. did not help.

I’ve never heard that exchanging the SIM card helps when it usually works, apart from here.

Hi,
I had a similar problem once, additional very slow data connections sometimes. Lineage 17.1 and two SIM-cards.
At that time I used the right SIM-slot (2nd) for data, but this was the problem. Changing to the left (1st) slot solved the problem.
Best, Peace

1 Like

Hi,
Similar issue too. On LineageOS 17.1 (Android 10), only rebooting fixes the problem.
I already tried to switch off/on mobile data, switch data from the first to the second SIM (and switch-back), enable (and disable) airplane mode, … but without success :frowning: .
I hope someone will give a magic solution here :smiley: .

I’m wondering if just a bit patience might help sometimes? I think I also have this from time to time with LOS18.1 (and recently it seems to happen more often, or I just notice it more often) however when I just do nothing and wait some time (unless I urgently need internet connection immediately)it just settles itself. Probably in Germany this is connected to 3G shut down, as I have the feeling at the moment the overall network coverage detoriated a bit?

Overall I think FP2 reception is not the best, in many ways.

To not have this issue too often I would not turn off mobile data and probably it helps to set mobile data to always on in the developer settings (to help toggling between Networks faster from Wifi to Mobile at least)

I replaced my SIM card this morning and I thought it was working, but unfortunately there is no improvement. Maybe this comes from some module of the phone; I do not know which one.
I will try to use slot 2 for the SIM, I am not confident :wink:

After my initial success with this, the poor network performance has returned. It is stressful because I use the phone for public transport so I need it to work promptly. I live and work in a city where reception is generally good. My wife uses the same mobile provider and her iPhone works fine whilst my FP2 states there is no network. I have had my FP2 almost 4 years and it has generally been OK in receiving the internet but the past couple of months have been terrible. I have ordered FP4 but my confidence is taking a knock with this. Were Fairphone too ambitious in moving to Android 9?

I posted to the bugtracker yesterday it was updated this morning - “Hi everyone, a quick update:
• we haven’t been able to look into the bug report(s) yet
• we are releasing a software update soon, we would like you to update the phone when that happens and let us know if anything changes”

Hopefully this will help.

2 Likes

Uhm, I can remember that we had the issue that Netmgrd was crashing causing exactly this but @chrmhoffmann pushed a change on Januar 27 and from the next build on it was fine. Considering that we have LOS 18.1 already: Is your Lineage 17.1 as up to date as it can be?
The issue that @Gorbalt has sounds very similar but it shouldn’t be the same because he’s on FPOS.

1 Like

My last (official) update for LineageOS 17.1 is the 20210716-*, after, the built version is for 18.1, but I don’t make the upgrade.
With the update of July, I guess I have the fix, but the issue seems always here (I had it Friday again). I will try to use the LineageOS 18.1 in the next days (weeks) and see if the issue stays…
I will read the thread too, maybe something could help me :slight_smile: , thanks having shared it!