Rear camera: serious camera error

Hi,

This happens every now and then, when I want to take a picture, a start the camera app and the image is black. After a few seconds (where everything is frozen) a message appears: “serious camera error”. And I cannot use the camera. If I reboot the phone, sometimes it works, sometimes not. I am starting to try taking out the battery (after powering off, of course). The first and only time I have done it, it has worked.

No problems with the front camera.

I am currently using Lineage OS, but it also happened with OpenOS, when I got my phone around september. I think that the camera is the new module, but I am not sure (BTW, how can I check this?).

Do you think I should contact support?

Regards,

Javi

Did you try to open the phone an take the camera out and re-insert it? Maybe something with the contacts is not optimal?

1 Like

I have just seen you answer. I have not done it. I have just searched how to do that, and it seems like I need a screwdriver (the kind you use for the glasses). I do not think I have one at home, so I’ll try that in a few days.

Hope it is just that!!

PS: anyway, does somebody know how can I know if I have the new camera modules?

If the highest resolution of your camera app is 4096x3072 pixel (4:3, 12,58 Megapixel) then you got the new camera module, otherwise the former.

Yes, simply go to settings - About Phone.

1 Like

@Amber, yes I have 4096x3072 pixel (4:3, 12,58 Megapixel), so it is the new module.

@ben, In settings - About Phone I could not find any information about the camera.

Thank you both!! I’ll report back when I have re-inserted my module!!

regards,

Javi.

Good luck. Ifixit has a maintenance guide for the FP2. Two screwdrivers are mentioned there. I think, you need the first one of the list, a Philips #0 for your work.

Thank you. I have not had the problem since yesterday when I did all the process. However (I am not sure if this happened before), I have noticed that under low-light conditions the camera shows some vertical lines, like a curtain, but it comes and goes and I haven’t been able to make a screenshot. Also, when you take the photo the lines are not shown.

it is no big deal because it is not shown in the pictures, but I am curious. I have also a feeling (since I got my Fairphone back in September) that the pictures are a bit like “grainy”. For instance in this picture the wall (not in the illuminated part, but in the “shadow” part), seems a bit “grainy”, with strange colors specially in the top… Maybe I am getting paranoid :sweat_smile:

I have the same issue with my Fairphone2 and its camera. It doesn’t matter if I use the preinstalled camera app or any other (e.g., OpenCamera). It often shows a black preview and after a moment tells me that there is a “serious camera error”. And if it works, I also oftentimes get the vertical stripes you mentioned.

I realised yesterday, however, that if I loosen the back cover (the one which comes in different colours), this problem is completely gone! Both apps work fine with the back cover of the phone removed. Once I put it on again, sometimes I get a “serious error” again, sometimes not (I noticed that if I clip the upper right part [where the cam is] first, then the error does not appear in most cases).

So this seems to be an issue of loosened contacts or some such by pressure from the back cover, if my guess is correct. Don’t know where, though, since I can’t look into the phone while covering it up again, nor how to fix this by yourself.

1 Like

I am having the error again, so I will open again and see what happens.

Perhaps it’s an idea to remove the camera, clean the contacts and place it back.
Have a look here for detailed instruction.
It could be that your camera is just a little bit out of place and therefore only giving a problem with the cover on. Make sure the lining of the cover at the camera place is placed correct.

I had the same problems with the camera. So I removed it and placed it back in. It seems like this fixed the problem. If the problem returns I will write again. When removing the camera it didn’t seem dirty to me and I didn’t put much effort in cleaning the contacts, but the screws seemed a bit loose. Maybe this was causing the problems.

Definitely, the solution was to open the Fairphone down to the front camera module. Remove it and put it back together. I tightened the screws of the camera module an extra bit, and the camera does not shows any more the error. This seems to me a contact problem. I wonder if next time that it suffers a fall, the modules get a little loose.

1 Like

I just did this for my phone that experienced purple vertical lines followed by ‘Serious Camera Error’ on the phone. It worked!!! Totally chuffed! It seems as suggested above that nodules could get a little loose, so having a self-fix for this is great. I used a Phillips 0 screwdriver and this youtube to take it apart, that’s all I needed.

With my first, original module, after a while of taking off the back cover and putting it back on, it seemed as though that killed the camera module, since at some point it was undetectable and did not even show an error message (and the flashlight-button disappeared from the settings scrolldown menu).

With the new module FP2 sent me, the same things is starting to happen again. I can tighten the screws all I want (without tightening them so that the whole phone breaks apart…). Won’t help.

º_(シ)_/º

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.