Random freezes (screen unresponsive) while scrolling (started after Android 10 upgrade)

Can you move any data from the Android to the Windows phone and do a factory reset.

Your problem is rare and you may get a repair/refund etc if it still exists after a factory reset.

I have done factory reset to my androids (more than one) several times…latest one samsung and ulefone but the problem persist… It is an OS problem I believe… Can I move data to microsoft? Yes without a doubt… but the problem are the windows apts… Hard to come by for the need use (example security apps for equipments so I need to go back to my android) for me, the worse decision that windows did was to pull the plug with their phone system… BY FAR a more reliable more secure os

It may not be software as it’s a rarely noted issue. Have contacted support@fairphone.com

You could try and dismantle and reset the contacts otherwise I think it may be a hardware issue.

By the way are you using the latest Android 10 version 0084

I have the same problem with my Fairphone 3 since the update to Android 10. Also, Google Chrome and Android System WebView refuse to update.
Very annoying issue.

Hi there have been many updates to A10, which are you currently on? If you use an SD card check to see if it is formatted as external ~ you will see an eject symbol to the right Settings > Storage

I have the latest Android build, and do not use an SD card.
I tried a factory reset, but that did not solve the problem.

If you went this far without success, you might as well reinstall the OS, because a factory reset in the Android world only deletes user data and Apps installed by the user and their data, the OS itself is left untouched …


In-place upgrades to a new major OS version (as opposed to cleanly installing the new version from scratch) can cause weird behaviour of all sorts. This has nothing to do with any particular OS or device, it can happen with all of them, software in general became just hopelessly complex.
Vendors can’t test every state an installation might be in, and they are not bold enough to leave cleanly installing from scratch as the only upgrade option, because obviously many users wouldn’t like that. So they do what they can with testing and roll out in-place upgrades keeping their fingers crossed.


Thanks @AnotherElk for the suggestion. Your explanation made total sense. Manually doing a clean install of FP Android 10 seems to have worked. It was not as straightforward as I hoped, because I couldn’t unlock the bootloader at first. Apparently you need two different USB drivers: one for the FP in normal operation and one in bootloader state.


Why has my recent comment been deleted? I am pretty sure that I did not break a forum rule, so I would like to be informed about by a moderator. Thanks in advance…

And with this you are relying on chance that somebody sees this.
I flagged your post for staff attention, so help should be underway soon :wink: .
(Another way would be to mention the moderators group, which I won’t do here now, just add an @ in front of moderators.)


Thanks, I received a message meanwhile, all sorted! :slight_smile:


I’ve had the same issue, right from the start of getting my FP3+. Have been using the same ‘solution’ of exiting by clicking the square, when I go back to the (partly) frozen screen I can scroll again. It happens in all kinds of browsers and apps, even just now while typing this. Has anybody heard from Fairphone Support?

Hi @Ankie35

I wonder if it is a memory problem? Do you have an SD card?
Can you check to see how much memory the core SSD has?

Hi @amoun, I do not have a SD card, and like I said, it happened right from the start so memory problems seem unlikely to me.

Yes sorry about that. How long have you had the phone and did it occur immediately you received the phone or after installing an app or two.

Have you tried starting in safe mode to disable the apps or even dismantled and reassembled the modules

in case there is a loose connection issue?

As far as ‘Support’ the issue could be the result of any number of hardware, software issue so i doubt a solution to one would help many.

Have you contacted Fairphone support to see what they have to say? especially as you say you had it from the beginning?

I’ve had it since May of this year and the bug occured almost right away. I added almost no apps and the ones I do have are very basic. It happens mostly when using the Google app.

I think it can’t be a loose connection. It seems to me to be a software issue. I read all the postst above and trying to fix the hardware doesn’t seem to be a solution for anyone.

I’ll send an e-mail to Fairphone Support. Thanks for your help @amoun!

1 Like

There are so many Google apps, so I wonder a) which one and b) is there an alternative whilst you await Fairphone’s response and advice.

I’m getting this issue. It might be two issues?

  1. Sometimes the screen freezes. I don’t think it’s hardware issue as I tightened the screws which fixed my other screen freezing issue. If I switch to the app switcher and straight back to the app I was using them it comes back to life, but it’s clear when it does that it has been receiving input and processing normally in the intervening time. It is simply the display that stops updating and specifically the app, not the OS.

  2. I get video stuttering in Twitter, which seems to trigger a similar response, app I wonder if they are related problems. It’s not streaming, as the videos on Twitter repeat and they stutter even after looping once.

In the end, the problem just returned. Apparently it is a software issue.
My final solution is to delete the cache of Android Web Viewer and Google Play Services after a screen freeze, and then the problem disappears for a while.
Sometimes annoying, but no longer a big issue.


I’m still getting this issue in Chrome. The screen stops updating while I’m scrolling, but still takes input. Switching out to the app switcher and back to Chrome shows the updated screen as if it had been updating normally.