Quick settings menu on lock screen not reachable when notifications are set to senstive

Like the title says. When I disable the “Show Sensitive Notification on Lock Screen” option in the Notifications settings menu, the quick settings menu on the lock screen becomes inaccessible.

Instead what happens is that I can pull down the top menu, but before I can touch any of the 4 quick settings buttons I get shown the unlock screen (pin code). So I’m unable to press any of the buttons. This does not happen if I enable Show Sensitive Notification on Lock Screen.

I would like to be able to quickly turn on the flashlight without unlocking the phone. But I also don’t want to shown the content of any notification without unlocking.

Anyone got an idea if this can be fixed? Is this a bug? Or maybe you got another suggestion to quickly reach the flashlight without unlocking on Fairphone 5 (Android 13).

Works fine on my FP5.

Work me too work

But primary i use ButtonMapper, to assign long press VolumeKey to on/off Flashlight:

  • without root must be LCD on (but don’t need unlocked)
  • with root can switch with LCD off
  • not have 4minutes limit, is configurable in Settings to more times and newer

Hmm that’s weird! I tried rebooting and making sure I got the latest updates. But to no avail.

Just to be sure. There seem to be two pull down menu’s on the lock screen. You can pull down the status bar (pull from top most part of the screen). Or the 4 button quick settings (pull down from anywhere on the screen). It’s the 4 button quick settings that requires me to unlock. But only when there are notifications present. I can always get to the Status Bar dropdown.

I also figured out there are two general settings for hiding sensitive notifications on the lock screen. There is the one in “Notifications” and a similar one under “Privacy”. Only when both are allowing to show all notifications it is possible for me to get to the 4 button quick settings without unlocking.

Maybe there is some app interfering with the setting? I suspect Bitwarden, Home Assistant or System UI tuner.

Yes, maybe I should try ButtonMapper and ignore this Quick Settings issue. I tried Shake Flashlight & Camera to have camera upon shaking. But that one seemed to increase battery usage quite a bit.

Thanks for the details! Indeed, then I encounter the same issue. Please contactsupport to report this bug.