English

🇫🇷 Problèmes multiples sous Fairphone Open

🇫🇷
Tags: #<Tag:0x00007f9ffcaeada0>

#1

Bonjour,
j’ai un Fairphone 2 et j’ai installé en décembre Fairephone open.
Je suis très content de ne plus être dépendant de Google,
Malheureusement j’ai quelques soucis (le logiciel est à jour).
Tout d’abord l’écran ne s’éteint plus lorsque je mets mon oreille près du téléphone, ce qui active des touches avec mon oreille.
Ensuite concernant le GPS:Dans les paramètres, il est bien coché que la localisation se fait avec le wi-fi, le réseau Mobile et le GPS.
Or sur mon application de cartes, la géolocalisation ne se fait pas. J’ai bien installé l’application Satstat, mais ça reste très peu simple à utiliser et peu précis.
Pour terminer, il y a un bon nombre d’applications qui nécessitent les services Google alors qu’elles ne sont pas développées par Google. Pensez-vous développer une sorte de by-pass afin de pouvoir utiliser ces applications ?
En vous remerciant par avance,
Et en vous souhaitant une très bonne année


#2

Bonjour,
Pour le premier point, il faut recalibrer le capteur de proximité:

Recalibrate your proximity sensor

Follow these steps to calibrate the sensor:

  1. Please make sure your Fairphone 2 is up-to-date;
  2. Start the Proximity Sensor Tool app from the phone Settings > Maintenance > Proximity sensor;
  3. Follow the 3 steps to calibrate the proximity sensor;
  4. Reboot your device as explained at the last step. You’re done!

(source)

Pour tous les autres problèmes, il me semble que microG serait la bonne solution. Pour le GPS, on peut se limiter à installer UnifiedNlp (voir ce guide complet), mais sinon microG permet de résoudre tous les problèmes d’un coup. Il y a même une version de LineageOS qui intègre directement microG.
Voir ce fil:


ou celui-ci plus long:

Ou le site officiel: https://lineage.microg.org/


#3

Merci beaucoup Chrisse pour ta réponse !
Alors j’ai calibré comme indiqué mais ça ne fonctionne tjs pas : ce serait un problème matériel ? Pourtant avant que je bascule sous Open ça fonctionnait…

J’ai installé microG mais rien n’est compatible a priori (cf capture écran…)! Sachant que j’ai bien redémarré mon FP2 après installation…
Screenshot_20190110-110839|281x500