Problem while installing LineageOS (signature verification failed)

Hi together,

I’ve been trying to install the latest ( LineageOS on my FP2.

I followed the installation guide given in

Unfortunately I get the following error in twrp:
“zip-signature verification failed”

Anyone also facing this error?

I already tried to re-download the zip-file and a older version of the zip file. This leads to the same error. Also flashing the latest twrp (so not the version which came with the Fairphone Open OS) did not help.

Any suggestions? Thanks!

You have to disable zip signature verification in TWRP.

1 Like

Hi Paula!

Thanks for your quick reply!

I tried this yesterday (and of course it worked), but due to security reasons I did not want to do this for really using the system.

I verified my zip with the procedure given on the download page, it seems to be fine, I’m just wondering why the installation guide does not mention that it’s necessary to uncheck the signature check.

CyanogenMod was signed with an older Android certificate (Issuer:, CN=Android, OU=Android, O=Android, L=Mountain View, ST=California, C=US)

LineageOS is signed with a newer “non-Android” certificate (Issuer: CN=LineageOS, OU=LineageOS, O=LineageOS, L=Seattle, ST=Washington, C=US)

My theory is that the code inside TWRP does not (yet) trust this certificate.

Maybe @z3ntu can tell?

I have no idea how signature verification works in TWRP but I have never turned it on successfully.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.