Problem to unlock Device State with fastboot command


I’m posting this thread because I’m currently stuck with some problems.

I installed /e/OS on my Fairphone 3 but now I want to going back to Android. I followed the steps like disable the secure boot but I’m unable to unlock the device state with “Fastboot”.

I can list the device with “adb devices” command, I can also reboot the device with “adb reboot bootloader” unfortunately when I want to use the command “fastboot oem unlock” I only have the answer, “< waiting for any device >”.

I launch it with cmd with admin rights. I have the android drivers installed on my computer but it doesn’t help in any way.

Do you have any idea to solve my problem?

Thanks in advance for your answers =)

Welcome to the community forum.

Ok, Windows it is. In case of Windows 10 you might find some hints here …

There’s also this … even if over time it turned out to be more of an ADB/MTP repair than a fastboot repair, but who knows …


Excuse-me for my English.
I have the same problem than Zhennefi : my phone is locked Fastboot mode. Than him, the screen indicates in red “Device State : locked”.
I have followed your instructions above, to install Android SDK Platform Tools. But, it is always locked.

In the command prompt (Power Shell), I type « adb devices », the device is recognized. Then, when it is in fastboot mode, it indicates « Waiting for any device ».

Have you an idea to resolve our problem ?
Thank you in advance.


So My problem is solved!

None of the solutions worked on my computer. I went at my parents house and used their computer and it works it seems I had an issue for doing this task on my computer. I used the second link from @AnotherElk to solve this problem.

By the way thanks for your help @AnotherElk =)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.