🇩🇪 Problem bei der Installation Lineage OS

Als Laie bei der Installation von LineageOS auf mein FP3 komme ich an diesem Punkt nicht mehr weiter. Kann mir jemand weiterhelfen?

Willkommen im Community Forum.

Ich gehe davon aus, dass diese Anleitung benutzt wird? … Install LineageOS on FP3 | LineageOS Wiki

… die am Anfang zu einer eigenen Seite für die Installation von ADB und fastboot verlinkt? … Using ADB and fastboot | LineageOS Wiki

… und da soll man natürlich mit adb devices testen, ob das mit ADB geklappt hat.
Dazu muss man auf dem Telefon vorher die Schritte bei "Setting up adb" durchgeführt haben, und das Telefon muss per USB mit dem Computer verbunden sein.

Wenn’s damit haken sollte, muss man sich aber eigentlich gar nicht mit ADB befassen, denn die Install-Anleitung (und auch die später verlinkte Anleitung zum Entsperren des Bootloaders) nutzt ADB nur für adb reboot bootloader … das Rebooten des Telefons in den Fastboot Mode (= Bootloader).

Das erreicht man auch ohne ADB an der betreffenden Stelle ganz einfach, indem man das Telefon rebootet (im Zweifelsfall den Ein/Aus-Knopf ca. 15 Sekunden gedrückt halten), und beim Neustart dann die Leiser-Taste gedrückt hält … das bringt das Telefon auch in den Fastboot Mode und man braucht kein ADB dazu.
(Steht sogar auch in der Anleitung … “You can also boot into fastboot mode via a key combination: With the device powered off, hold Volume Down + Power. Release when boot logo appears.”

4 Likes

Hallo AnotherElk,
Danke für deine Hilfe. Ich habe alle genannten Schritte schon ausprobiert. Nun bin ich im fastboot mode. Bei Device State unten in rot steht jedoch “locked”, obwohl ich vom FP3 alles geöffnet hatte. Wenn ich dann in den cmd “fastboot devices” eingebe, passiert einfach gar nichts.
Gibt es dazu irgendwelche Ideen? Ich bin mittlerweile schon fast am Aufgeben, habe schon versucht im Repair Cafe Hilfe zu bekommen, die haben einiges probiert, aber nichts hat geklappt. Evtl. hat es was damit zu tun, dass mein Computer mit Windows ist?

Da fehlt offenbar noch ein Schritt zum Entsperren des Bootloaders.
Die Anleitung dazu ist hier (ist bei LineageOS auch verlinkt) … Manage the bootloader of your FP3/FP3+ – Support

Dazu muss allerdings fastboot auf dem Computer funktionieren, da scheint es im Augenblick ein Problem zu geben …

Da sollte auch bei Device State - locked wenigstens 'was kommen, und nicht nichts.
So etwas wurde im Zusammenhang mit Windows aber auch schon einige Male berichtet. Was bei einigen geholfen hat, ist mit verbundenem Telefon im Fastboot Mode in Windows in Einstellungen - Update und Sicherheit nach neuen Updates suchen, dann soll ein neuer Link angezeigt werden, der “optionale Updates” anbietet, und da kann man dann die notwendigen Treiber installieren, dann sollte fastboot funktionieren.
Das kannst Du ja versuchen.

Ansonsten …


Wenn es #fairphoneangels (<- siehe Link für Info) in der Nähe gibt mit Fairphone 3 Erfahrung, dann können die vielleicht genauer helfen.

4 Likes

Ich tippe auch mal auf das Treiber-Problem. Ich bin zwar kein Angel aber ich würde dir trotzdem persönlich Hilfe anbieten (über Discord z.B.) wenn du magst.

3 Likes


Vielen Dank das Problem mit dem Treiber müsste gelöst sein, zumindest wird mir nun die Seriennummer angezeigt. Jetzt funktioniert aber trotzdem der flashboot flash boot Befehl nicht.

1 Like

Vielen Dank für das Angebot. Das mit dem Treiber habe ich jetzt glaube ich hinbekommen. Hilfe könnte ich warscheinlich trotzdem gut gebrauchen, falls das für dich ok wäre.

Der Befehl muss in dem Verzeichnis ausgeführt werden, wo die Datei lineage-17.1-usw. liegt, sonst wird die Datei nicht gefunden (das besagt die Fehlermeldung).
Alternativ kann man vor den Dateinamen auch den Verzeichnispfad zur Datei schreiben, das funktioniert dann auch.

Für ersteres … Einfach im Explorer in das Verzeichnis gehen, wo diese Datei liegt, dann oben in der Adresszeile im Explorer den Pfad zum Verzeichnis anklicken (dann wird er komplett markiert), dann stattdessen cmd eingeben und Enter, und dann startet die Kommandozeile schon im richtigen Verzeichnis.

In der Kommandozeile selbst kann man das Verzeichnis mit cd (change directory) wechseln … hier ist bei Bedarf eine gute, kurze Einführung in die Kommandozeile: Einführung in die Kommandozeile · HonKit

2 Likes


Das mit dem Verzeichnis anklicken hat super funktioniert. Aber jetzt habe ich dafür eine andere Fehlermeldung: couldn`t parse partition size ‘0x’. Diese habe ich im Internet gesucht ung bin auf das flash:raw gestoßen. Leider hat das auch nur wieder eine neue Fehlermeldung produziert.

Zeigt denn der Fastboot Mode auf dem Telefon “Device state - unlocked” (unten in rot)?

Wenn da noch “locked” steht, dann kann man noch nichts flashen und muss erst den Bootloader entsperren … Manage the bootloader of your FP3/FP3+ – Support
(Wenn die Schritte in Android schon erledigt waren, dann dort weiter mit “3. Unlock your bootloader […] 5. In a Command Prompt (Windows) or a terminal (macOS) type: fastboot oem unlock and press the “Enter :leftwards_arrow_with_hook:” key”.)

1 Like

Ok, vielen Dank, ich bin schon weiter gekommen. Jetzt ist die Frage, ob die Installation auch erfolgreich war, wenn da ‘total xfer: 1.00x’ steht? Ich konnte nach dem reboot system now das ganze in meinem FP3 in Betrieb nehmen. Ich bin jetzt nur etwas besorgt, dass dann später doch etwas nicht klappt.

1 Like

Ich bin mir nicht sicher, aber ich glaube der Fehler bezieht sich auf den Transfer der Datei zum Telefon (nicht die Installation selbiger), demnach sollte die Installation gar nicht stattgefunden haben. Da du aber scheinbar ein funktionierendes System hast, fand sie wohl trotzdem statt, demnach hat das Telefon die Datei erfolgreich empfangen und die Meldung wird - so vermute ich - fälschlicherweise angezeigt.

Ob die Installation stattfindet oder nicht, wird auf dem Telefon angezeigt, nachdem die Datei zum Installieren übertragen wurde.
Scheint funktioniert zu haben, sonst wäre da jetzt kein lauffähiges System, oder dasselbe wie vorher.

Ich hab’ ewig nichts mehr mit ADB Sideload installiert, aber klingt “Total xfer: 1.00x” nicht gut? 1.00 = 100%? Transfer komplett?

1 Like

Wie kommt Ihr darauf, dass “total xfer: 1.00x” eine Fehlermeldung ist?
Die kommt m.W. immer und ich deute die als Erfolgsmeldung, dass ein mal (1x) der gesamte Transfer (total xfer) durchgeführt wurde.

2 Likes

Ich habe Google bemüht und alles was ich finden konnte waren Aussagen wie “ich hatte die Meldung bei xx.x% übertragener Daten”. Also die Meldung kommt demnach auch wenn man es nicht schafft den ganzen Datensatz zu übertragen. Deswegen die Vermutung.

1 Like

Ja, bei den Begriffen findet man in der Tat erstmal nur Treffer, die von Problemen handeln. Ich hab mir mal ne handvoll durchgelesen + i.d.R. vermuten die Leute, dass das eine Fehlermeldung ist, bis dann einer kommt und erklärt, dass das eine Erfolgsmeldung ist :wink:
Die Probleme lagen immer woanders in den Treffern, die ich mir angeguckt hab.

3 Likes

Na wenn das so ist :slight_smile: Klasse, wieder was gelernt. Du bistn echter Engel :relaxed:

2 Likes

Vielen lieben Dank euch allen, es scheint alles zu funktionieren!!

5 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.