Problem after updating to Android 10

A few weeks ago I updated to Android 10, and since then my FP2 sometimes behaves strangely. For example, I can open the picture folders in the file manager, but not the folder with the videos, then the file manager is closed immediately. The connection to the WLAN is often not stable, despite a good signal. And the system is slower than before and occasionally boots spontaneously.

The biggest problem at the moment is that I no longer have mobile Internet access, the mobile data no longer works. I was in Switzerland and had booked a data package especially for this (no roaming!), which I could not use with one byte, despite active mobile data (even when roaming).
I do not know what can be the cause, because I had this problem also in October in Portugal. Back in Germany it worked again, but now it’s different: mobile internet still doesn’t work, despite some restarts. Possible causes: Provider/ SIM, hardware or OS? Who knows?

Thx in advance.


Did you check the APN settings?


Yes, I did, multiple. Bevor I found two entries, but later there was only one: O2 DE IMS

I can’t see anything what I could change there; where I can find information about the necessary settings there?

I contacted my service provider on this matter; it’s possible, that the SIM has to be changed or that the card reader does not work well anymore. First I’ll try the SIM in another mobile phone to check it.

1 Like

Update: I’ve put the SIM into another mobile, and it worked. So it’s quite clear that my phone doesn’t work properly anymore.

You may check APN setting on the other phone and compare it to APN setting when you put it into the FP2.


A SIM can be broken even of working in another phone (I had this in the passt already). Also, sometimes there might be the need to adjust the APN manually. Your provider can give the correct settings to compre and correct.


Guess the other phone has to be assigned to the same provider and the APN depends on the provider?
(The phone I used is not with the same provider.)

What’s about this malfunction? Any simular experience or comment on this? Another effect: Previously, I had a button at the bottom with small white squares that brought the overview of installed apps and now it is no longer there.

I might help to manually reinstall the system

1 Like

I checked the APN settings together with the provider support, they’re all ok.

You wrote that you inserted your SIM card into another phone and in the other phone mobile data worked.
So at that the it was the same provider so the APN settings should be the same…

You might try to use another file manager (like e.g. Total Commander).

Maybe you backup your data and do a factory reset? It might solve various of your problems.

1 Like

I’m totally non-technical and this probably won’t help you, but I had similar problems with this update. Random restarts, no easy access to all the apps, poor (at best), or totally unavailable internet through mobile signal. I tried downgrading to 3G and no change. … but then, about three weeks after the update, it’s working again. Getting a good 4G signal, realised that you just pull up from the bottom of the screen and they’re all there. Works as it did. Uses slightly more battery power, but as I’ve been fiddling with it more as a result of the downgrade in ability, I can’t even be sure that’s the case. I didn’t change anything except tried 3G and then changed back when it didn’t work.

So I’m sorry if I haven’t got an answer except that I feel your pain and time seemed to heal mine. I really hope you find an answer.

I have the same issue with 4G mobile data.

My FP2 was running fine, albeit often slow with crashing apps sometimes.

Yesterday, I received the “Upgrade to Andoid 10” notification and did it.
It went without error. I didn’t notice any issue as I was on my wifi.

But today, being outside and trying to use 4G mobile data, it doesn’t work at all.

I have not changed anything else than this upgrade. I’ve checked the APN settings, and they look good.

I’m in France and using Orange’s network.

I registered the reference to the test with 3G and tried, but without success. Even after returning to 4G, mobile data no longer works.

Normally, the connection type is displayed next to the mobile signal strength triangle (E, 3G, 4G, LTW). This information is now missing for me. It seems that this is related to the mobile data malfunction.

1 Like

That’s just the problem I had. The triangle showing mobile reception was showing good to excellent reception, there was no wifi available, and there was no 3G 4G or anything by it. If I was in the total open with an excellent signal I once had an indicated 4G, but if I tried to access anything online it stated no connection. But after two weeks it suddenly worked again.

Perhaps following a restart (spontaneously or not)?
As this has been mentioned as work-around by @ArjenU for similar problem, probably also after upgrading to Android 10: No 4G after wifi
(Apparently issue occurred under Android 9 already - see link in post #2 in that thread.)

The issue seems to have been fixed for me yesterday after an update of the Android app “Carrier Services” which contains “Bug fixes and stability improvements”.


Try turning it off and on a few times. I always turn my phone off overnight. This morning it also wouldn’t go to 4G. I restarted it and still no 4G. I turned it off, waited a minute and turned it back on again. 4G back on.

Welcome to the community forum.

Citation without giving the source is not the way to do it :wink: …

This should then also have all those working links for the terms in brackets.

Also …

The forum software here (Discourse) garbled the code because asterisks are used for formatting.
You can mark text as preformatted and bold in the editor: *#*#794824746#*#*