Primary Microphone is crackling heavily


So, like a day or two ago this must have happened for some reason unknown to me.
Basically first time I noticed it was when listening to recordings made by Sleep for Android, which were just static crackling noises. Didn’t think much about it then.

A few minutes ago I made a voice message via WhatsApp and it just was crackling noise the whole recording, with no voice at all.

Took apart the phone, blew into holes a bit and tried checking the primary microphone with the Checkup tool. Gave me the same noisy crackling. Just now I tried a voice message again and it did record my voice but with a lot of static in the background.

To have a better understanding of my issue, I made a test recording which shows the problem:

Now, my question is, anyone had a similar problem? How did you fix it? My first guess would be that somehow there’s some dust/dirt built up in the tiny hole of the microphone.

1 Like


I do have the same trouble, tried to clean the contacts, and the mike, not better. The only improvment I got was to hit the bottom of the phone. If someone has an idea. Maybe to buy a phone from people who know how to build a phone.

1 Like

This question is close to expire… and I have the exact same issue since a few days.
When switching the speaker on it’s fine, but without it the correspondents only hear a bunch of statics…
Anyone with a solution?

1 Like

I’m having the same problem as well.
I’ve replaced the microphone module once already, but the same thing has happened about 8 months later.
Does anyone have any clues to what’s causing this?
My FP2 original cover (not slim cover) has also started coming undone around the same time as my crackly microphone problems both times - could this be related?

Hey there! Sorry to hear this problem seems to happen a couple of times. It happened to me a couple of months ago, as you can read in the thread.

What I ended up doing was to simply open a support ticket with Fairphone Support and they quickly replaced the broken module under warranty. I’d advise to you to do the same thing, as fixing it on your own might be hard or not even doable. My guess would be a general problem with the microphone component used in the module. I don’t know if Fairphone did any research about this specific issue, but maybe if there are a lot of people having this happen they will look into what would cause it in the first place.

So yea, open a ticket over at and ask for a replacement under warranty with the option that you will send them the broken module for further inspection, if they want.

If they don’t want the broken module, I’d suggest to offer it for free (excluding shipping of course) on the marketplace here on the forum. I can only say positive things about that from personal experience.

Anyways, hope you get this taken care of soon and feel free to report back here about it!

Have a nice day!

Edit: About the classic cover and it being related… one can only really speculate about that. Fact is, the old classic cover is no longer being made, due to the material issues. If you are still under warranty and have a broken classic case, you can ask for a free slim cover replacement.


I’m pretty sure (I’ll explain why) that the problem doesn’t come from a damage within the modules, but is a connection problem from the module and the mainboard.

I started noticing mic problems like you did when using sleep recordings. And only realized that my mic sometimes doesn’t work completely when listening to my own telegram voice messages.

I didn’t wanted to replace the module just yet because I’m a “cheap swabian” and realized I still could get the mic to work clearly by squeezing my fingers in the bottom module area, where the fairphone text is located. Just simply pressing the fairphone sandwich together fixed it for me from about november 2017 until now.

I also wasn’t ready to pay for a module which maybe wouldn’t fix the intermittent contact between the module and the mainboard either. A coworker had her bottom module replaced, because she couldn’t charge her battery anylonger via the USB port. So I wanted to test whether her old module, which suposedly had a working mic, would work in my FP2… but it did not.
So I figured that the problem would either be in my mainboard or an intermittent contact.

I ignored the problem and always had my bluetooth headphones ready to make phonecalls, and if I get called without the headphones I used the speakerphone.

Until now. Now my USB port has an intermittent contact as well, and my fix is to squeeze down on the phone like I did to get the mic to work, so I figure it is the same intermittent contact.

Right now I’m charging my spare battery in a charging station and swap the batteries.
Fun fact: My bottom module I completely decommisioned, I pulled it out of my phone. The mic and USB port didn’t work anyways. I don’t need the vibration motor because I’m redirecting my notifications to my miband (fitness tracker with vibration).
And when I’m taking a call without my headset I’m switching from earpeace to speakerphone mic in a push-to-talk fashion.

I’m considering sending my “defective” module to the support for inspection. Maybe it is fully intact. I hope they are coming up with a new one with usb-C that one I would buy.
In the meantime I’m considering redirecting the second usb port (case upgrade port) to a do it yourself USB port.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.