Prevent incoming calls from cutting of tethering

I sometimes use USB tethering to connect my laptop to the Internet via my Fairphone 4. Sadly, an incoming call on the FP4 cuts off the Internet connection on my laptop. This happens even if I don’t accept the call.

What are some ways to prevent this annoyance? Ideally, the tethering to my laptop would be uninterrupted, but I’d still be able to tell if a call is incoming.

hello, are you using two simcards or one?

There’s only one SIM card in my FP4.

I will then not be of any help but there was a similar thread for FP5, please have a look

3 Likes

Do you have VoTLE/Wifi Calling enabled?

1 Like

What does this exactly mean:

Is the USB connection cut off or does the connection speed drop to almost nothing?
In general the internet connection can only be held up if the phone doesn’t have to change the radio access technology for calling. This is where voice over LTE (VoLTE) or voice over 5G comes into play. If that is enabled the phone doesn’t have to switch to 2G or 3G for an incoming (or outgoing) call and vice versa.
So if the USB connection is still active but you don’t get any data through, then check the VoLTE settings. You could also try tethering via WiFi to see if that makes a difference.
Disclaimer: I usually use Wi-Fi tethering and have called and used data on my notebook at the same time successfully, but I have no experience with USB tethering.

2 Likes

Wifi calling is disabled. Would turning it on help?

Not sure. I think the Internet connection was completely down, but I didn’t check properly.

Oh, nice, so turning on Wifi calling should help.

Typo, sorry, didnt mean Wifi calling but 4G Calling (different name for VoLTE)

It seems that the “Wifi calling” setting encompasses both, at least on my device with my telecommunications service provider.

Sure? It might be you just dont have the VoLTE setting, this can indeed happen depending on the provider.

If this is the case for you, you can call *#*#4636#*#* and check the IMS service status under phone information-three dots upper right to see if VoLTE is available when Wlan is disabled.

Thats my FP4 with Vodafone Germany SIM which is missing the VoLTE setting and still has it enabled per default.

Thats how it normally look in the settings when you have the VoLTE/4G Calling toggle (also FP4 with O2 Germany SIM)

1 Like

Hi yvmuell,

I agree with you that enabling VoLTE (or 4G Calling) should solve the problem. But the preferred network type should not be 2G as in your second screenshot. 4G/3G/2G would be the right choice in this case. :wink:

greets Robert

Thanks for nit picking although the screenshot should just show the setting for VoLTE being the topic here.

1 Like

sorry yvmuell,

my comment wasn’t meant as an offense. I’m supporting certain software in the circle of my colleagues and frequenty use screenshots to show the correct settings. But it happens that the colleagues take the whole settings inside the screenshot as mandatory. That’s why I made this remark.

Apologies Robert

2 Likes