English

✏ Porting TWRP recovery

recovery
wiki
twrp
Tags: #<Tag:0x00007fefc0e541a8> #<Tag:0x00007fefc0e4fec8> #<Tag:0x00007fefc0e4fd10>

#102

How exactly is SuperSU failing for you? Flashing the zip in recovery works? Do you see the app later and can run it? Where do you get stuck? Did you check adb logcat when it fails?


#103

I can flash it and open it without problems.
It fails downloading the SU Binarys. Even after several reboots.


#104

So thats just an update then inside SuperSU or aren’t those files in the original zip file that you flashed? I don’t remember SuperSU downloading files after flashing it on another phone…


#105

Yes its in Update inside SuperSU.
Doesn’t matter which Version i take. At the first start of SuperSU it have to make this update.


#106

@neolovich Install Superuser and then call Amaze and try to look into /data/app. This should start superuser and you will see, if you have a rooted device. No need for supersu to download anything …
Spielmops


#107

Thanks for the answer.
I know that i have root. Titanium Backup, Root Explorer etc works.
But i want to use Folder Mount and that works only with SuperSU.
Until now i use phh’s SuperUser


#108

Hello again
I got an error trying to backup my system.
I’ve simply flashed the recovery.img from OuinOuin.
Do i have to do something else?


#109

If you can not use FolderMount, then your phone is not rooted. SuperSu is the “app” that takes root to the phone, SuperUser manages root for all apps, that need root. Perhaps that specific SuperSu that you flashed did not work for your phone. Try flashing the boot.img. I rooted my phone with flashing boot.img and can mount what I want where I want.

Spielmops


#110

Hi all
Please for help…
I updatet my twrp recovery now to the new 3.0.0 version. And now twrp can’t recognize the internal SD card.
Have a look at the picture.

And after mounting it is still not shown as a option!!!

With the old twrp 2… Version it worked without problem.
Any idear?

Thank you for reading and helping.

Lg ivi


#111

You can access it in “Advance” then “File manager”, in data/media/0 normally. Not sure it helps, but at least you are sure that internal memory is recognized.

To install from internal, it is the same, go up from external memory then data/media/0.


#112

Yes, you right.
I can access it on this way. but i need for recovering and backup the option to select the internal SD card…
Also strange is the Data size, is shown around 10000 MB, but usely is it 1500MB, this is also a folt. --> sorry but, something is wrong with this TWRP version.

Would love to use it, but it need a fix.

greetings ivi


#113

Where did you get your update from? Did you read Post 83 of this thread? Did you use TWRP 3.0 from there? I flashed that version and it works fine.

Spielmops


#117

Hello everyone !

I’ve flashed all this, Xposed is installed with a few modules, everything works fine ! (Thanks for the hard work ! :wink: )
But now I can update to Fairphone OS 1.2.8, will I have any issues if I update ? (with the root maybe ? )


#118

Please have look here:
https://forum.fairphone.com/t/pencil2-howto-root-with-superuser/12375/325?u=therob&source_topic_id=12558

I also added the update instruction in the wiki at the top of this post here.
Maybe somebody can check, if nothing is wrong?!


#119

Thank you !! I followed the instructions and everything works fine ! :smile:


#120

Does “adb shell” work for anybody while in the recovery? For me it says “unauthorized” in “adb devices”…


#121

You have to authorize it in the pop-up window on your phone.


#122

In the recovery? In the booted android it works just fine.


#123

Try using a newer adb version on your computer!


#124

Thanks, I already got it work.