English

✏ Porting TWRP recovery

recovery
wiki
twrp
Tags: #<Tag:0x00007fefc3f7c230> #<Tag:0x00007fefc3f63ed8> #<Tag:0x00007fefc3f63ca8>

#21

So far everyone seems to be quite happy with Max’s version of the TWRP.

Except for the minor issues mentioned above, has anyone experienced any major dysfunction of it, yet?

However, I think as soon as I get my phone, as it sounds and as it seems to be able to create NANDROID backups, I will flash it to the phone just right away.

Has anyone maybe discovered differences in TWRP’s behaviour between using stock boot.img and the one mentioned in the root-thread?


#22

Great job!

Since this has the potential to brick your phone, some safety mechanism are in place.
@Max_S, do you mind putting hashes (md5sum, sha1um, or similar) of the recovery here? This would help other people to verify that the download is not corrupted.


#23

Another question:
Does anyone know if a stock recovery is available somewhere, in case someone would want to switch back or in case one would be unsatisfied or brick the phone with a custom recovery?
At least I couldn’t find a the FP2 stock recovery anywhere online.


#24

Good question. I thought it was part of the official OTA update package, but unfortunately it isn’t.


#25

As far as I can see there is only a boot.img in that zip file. I guess the data file doesn’t contain the recovery.

I would love to test the custom recovery, I am just a little bit reluctant at the moment since I will be traveling in the next weeks and need a stable phone :wink:

So I guess without an original recovery available I will rather wait until I’m back …

Anyhow, thanks for the great work! Looking forward to flash it some time!


#26

If you compiled the osos, you got a stock recovery…


#27

I see. Good to know, thanks!

Though, I am still on the stock OS, didn’t compile it myself.


#28

You can build the stock recovery … but you can’t share it. Not sure if one can remove most of the QC stuff from the Makefile. If you need one … ask around privately. I guess that is the way it works right now :frowning:

Update: But it looks like one can build a recovery without bin blobs, right?


#29

I’m also (back) on stock, but I tried it when I got the phone. Ran into the problem with the libraries, and as I was one of the first what was missing wasn’t well known then :wink: I was then checking the recovery also


#30

Hi All :wink:
I have a question…

  1. i flashed twrp and the xposed, but i don’t knew, how to get into the recovery directly from the booting on? i always must start the flashy app and chose the option recover.

->I can recommend the app flashy, it is very easy to use and you don’t need linux or windows for flashing. Of course, i don’t knew if this is more dangerous, but is far easier to use the app instant using all the commands in Linux distros or Windows.

Ok, greetings and a BIG THANK YOU for all the HELP

ivi


#31

Hi ivi.

I think you mean “Flashify (for root users)” (?)

Looks good, nice and easy. However, you will have to root the phone first. And if you made this, you know how to live without Flashify anyway. :wink:

But thanks for the hint!


#32

Welcome!
and do you knew how to Start directly from booting Into the recovery?
LG ivi


#33

Hold Vol+ while switching the phone on

(Vol- is fastboot mode, you only can access the phone with the fastboot command)


#34

And if anyone Stil looking for the stock recovery.IMG. i made a backup bevor flashing .
Tell and i will share it…
LG ivi


#35

Thank you, it worked…
LG ivi


#36

How did you make a backup?

What I found as common suggestion when searching online was that you can find the recovery partition by using

cat /proc/mtd

which however did not work (No such file or directory).
So finally I tried to take a copy of /dev/block/platform/msm_sdcc.1/by-name/recovery
by using

dd if=/dev/block/platform/msm_sdcc.1/by-name/recovery of=/storage/sdcard1/recovery.img

which gives me a 16MB file, which sounds reasonable. But I am not sure if I actually copied the right source location …


#37

I used the APP flashify, for Boot image and recovery
Backup. And yes the recovery IMG is around 16mb big.
LG ivi


#38

If it can flash .zip files, could it be used to flash the current XPosed framework? I never really understood why it shouldn’t be possible to do so with apps or via adb/fastboot. The only option presented was FlashFire, which didn’t work for me. Could someone elaborate on the difference? I didn’t quite get it…
Thanks and regards,

Moritz


#39

Yes you have :wink:


#40

Hi All
Did you recognize, that the temperature during TWRP using is growing very fast.
I made two Backups and the temp was around 70 Degrees!!
Is this normal?
lg ivi