English

✏ Porting TWRP recovery

recovery
wiki
twrp
Tags: #<Tag:0x00007fefc8c7a078> #<Tag:0x00007fefc8c79ee8> #<Tag:0x00007fefc8c79da8>

#41

Do you mean Fahrenheit or Celsius?


#42

Making backups needs a lot of cpu power, i assume, so i wouldn’t be concerned about temporary 70 deg. C, as this is still in range what a cpu can handle (temporarily).

Edit: not related to TRWP, but i also checked a couple of days ago how the cpu handles File compression. With a conservative setting for cpu governor and grouping of tasks to single cores, i also got over 50 degrees on the cpu.


#43

@ freibadschwimmer,

As i see, you right.
Thank for working at an answer, and answering !

Greetings ivi

@Stefan i mean Celsius


#44

Which App do you use for this (editing and monitoring)?
As you seem to have some knowledge about this, maybe you can also join the discussion here?


#45

Yes, I saw your other thread, that’s what got me interested to play around with the kernel settings in the first place. :wink: Though I don’t have anything yet to contribute to the battery stats discussion, since I haven’t been doing any monitoring yet. Will come (I hope) :slightly_smiling:
I am using Kernel Adiutor for adjusting cpu, gpu etc. settings.


#46

@freibadschwimmer

Which CPU-Goverment do you use?
I’am on Interactive, but i have from time to time stocking with sliding the screen.


#47

At the moment I am trying conservative, and have the max. frequency throttled to appr. 1500MHz. So far the phone works fine, from the performance I cannot see a difference to the default settings.
However, I am not sure if any of these settings would be loaded while being in the recovery. If I am not wrong I think the settings only overwrite the default when booting Android. Or am I wrong here?


#48

No, iam sure you right.
The CPU Settings during TWRP Settings seems to be almost all Kernel and Goverment of “performance”. But iam not sure. It looks like that.
Have a sunny day :wink:

ivi


#49

@Max_S: what did you do to get the emulator running?
I see you made a special avd?

When I start the emulator, in the end it’s always waiting for:
emulator: ASC 127.0.0.1:1970: Retrying connection. Connector FD = 25
emulator: Error while connecting to socket ‘127.0.0.1:1970’: 111 -> Connection refused
emulator: ASC 127.0.0.1:1970: Retrying connection. Connector FD = 25
emulator: Error while connecting to socket ‘127.0.0.1:1970’: 111 -> Connection refused


#50

I used the Virtual Device Manager (“android avd”) to create an AVD. I used the Nexus 5 as device for it. Then the stated command works for me without problems to start the emulator.


#51

Hey guys,
so I finally got around testing TWRP on my FP2 and indead it worked quite smoothly! I flashed @Max_S’s recovery and installed xposed framework. Runs perfectly and didn’t even take 10 minutes to do it :slightly_smiling:
Thanks for this great work and best regards,

Moritz


#52

Great to hear that it’s working good so far.
I’d still like to look into the problem with encrypted userdata. Unfortunately I don’t have much time for it at the moment. :weary:


#53

Thanks a lot! Smoothly installed TWRP and sideloaded Xposed on my FP2. :relaxed:


#54

Hey compiling guys,

as I have some doubts how TWRP flashing works in the simplest way I have the following questions (while having the goal to use XPosed Framework afterwards). It could be re-named to “TWRP for dummies…:wink: :

  1. One of the easiest steps (until today) to flash XPosed to the FP2 is first to flash the TWRP recovery, right?
    a) I can download now the recovery image (@Max_S compiled and provided above, thanks!) and flash it with the stated adb command, right?
    b) what is the worst-case-scenario if anything during flashing goes wrong? How to proceeed in this case?
    c) once successful installed TWRP it completely replaces the stock-recovery of the FP2, right? How can I back it up before (if it makes sence) and flash it back, if anything goes wrong?
    d) than the TWRP can do all stuff the stock recovery can do plus more, right?
    e) issues (like the time problem) only do affect INSIDE the recovery environment, and can’t bring any problems for running the normal FP2-Android5.1 (incl. booting), right?
  2. Now I can download the XPosed-zip (which is the correct one?) and use the TWRP to flash it (how exactly?), right?
    And then normal XPosed usage is possible, after I also installed the XPosedInstaller.
  3. I guess after an FP-OS update flashing the TWRP could be neccessary again, but the update-process itself should not have any problems with the different recovery-image, right?

Do you have anything else to add? Otherwise I would give it a try, if all my points are correct(ed)…

Thanks for gaining some more knowledge by asking you questions :slight_smile:
Cheers, Robert


#55

Hi Rob,

yes, however you would flash the recovery via fastboot, not via adb…

wort case: phone is dead and won’t turn on and there is nothing you can do about it. However I think that this would be very very very unlikely, as for now you are only messing with the recovery, not with the operating system itself.
If the flashing of the recovery shoul fail, you could simply try again. I don’t see a reason why it shouldn’t work on your FP2 if it already worked on others :slight_smile:

I don’t really know how to make a backup, but yes, it completely replaces the stock recovery and so far Fairphone has not provided the image of the original recovery. I tried doing a backup with flashify, but that app is simply not working on my phone. Freibadschwimmer apparently managed to make a backup of his recovery partition:

yes

was like that for me. time worked fine for me, it just appeared to be a bug at first, because twrp has a random timezone set by default. I set it to Berlin time and everything was right.

For the FP2 you will need to use xposed-v79-sdk22-arm.zip, I dunno what happens if you flash a wrong version, but I also wouldn’t want to try :stuck_out_tongue:

yes

no, it’s quite straight forward. I just downloaded the xposed zip file on my phone and put it into the download folder. TWRP can find it and install it from there…

Hope it clears some stuff up for you :slight_smile:

Moritz


#56

I just felt courious yesterday, so I flashed the recovery and it just works like a charm! :slightly_smiling:
Thanks a lot @Max_S!

I also did this and it’s boring. It doesn’t flash and gives you an error message saying “not compatible”. :wink:


#57

Quick one - does this port currently work with encryption?

Grazie!
Root


#58

I can’t tell about that, but it’s in the list of known bugs that it doesn’t work on encrypted phones.

@Max_S: I Just found out why the clock is wrong: :smiley:
The default timezone is set to -6, after setting it to +1 it’s correct. :slightly_smiling:


#59

About to backup the original FP2 “recovery.img” I had the idea to use MTK Droid (atlhough I only realized afterwards - as the name implies - it only working for MTK devices :wink: )
So I tried it, as I set it up already for the FP1 some time before and here you see the result.
Unfortunately a backup is not possible, although it is recognised in principle.
Can I do anything more with this?


#60

Do I need to set the phone in any special mode, as I made it during rooting (ther it was bootloader) before entering the above line??
For my i tried this (see pic), but it was quitted with the error message “fastboot not found”.

The FP2 is connected, ADB driver are installed and USB-Debugging is enabled, recovery.img copied to C:, just like during my root-procedure. What did I forget?