Portable Wi-Fi Hotspot: connection issues to macOS

Turning on “Portable Wi-Fi hotspot” (Settings > Wireless & Networks > More > Tethering & portable hotspot) I can see the phone in the list of networks on macOS, but when I select it, the laptop can’t connect (just keeps the animated wireless symbol).

I have tried several macbooks, with and without encryption and tested another Android phone on two of the machines which worked fine.

Any idea how I can fix it on my phone?

Upon Mac OSX High Sierra 10.13.3 just had to set up Wi-Fi hotspot with password - tap on Set-up Wi-Fi hotspot just below Portable Wi-Fi hotspot, but presumably that it what you did?

Shouldn’t make a difference but I have also enabled USB tethering on this Mac using HORNDIS:https://forum.fairphone.com/t/how-to-use-usb-tethering-with-macos-10-13-high-sierra/34407/2

Thanks @aspergerguy, yeah, that’s what I did, if I got you right.

  1. turned on “Portable Wi-Fi hotspot” on my phone
  2. had a “Set up WiFi Hotspot” by default with PW, but also tested without
  3. selected the phone from the list of WiFi networks on the macs

Get only this image and it will never connect. It does find the hotspot in the list and asks for the password.

Tested with macOS 10.11 and 10.12.

Sorry don’t have anything running ElCapitan or Sierra available to try for you.:disappointed:

1 Like

Well, for starters, the symbol you uploaded shows a terrible signal. Keep the Macbook closer to the phone, and it should improve. Possibly, there’s interference. Try to use 5 GHz instead of 2.4 GHz (legally, tho, make sure you’re indoors). You can run Wireless Diagnostics on the Mac, and from there go to Window and you have 6 options: Assistant, Info, Logs, Scan, Performance, Sniffer. Performance shows you continuous graphs of things like RSSI and noise, Info shows connection info. I can also recommend Network Utility, a user-friendly frontend for various CLI tools such as ifconfig, netstat, ping, etc. At the very least it will show you at the info tab transfer statistics. Alternatively, you can use Bluetooth or USB for tethering.

1 Like

@JeroenH - I wasn’t in the mood creating an animted gif of the (trying to) connecting signal, but changing to 5GHz did the trick for me.


1 Like

Are you sure the FP2’s portable Wi-Fi hotspot really operates in the 5 Ghz band? Did you check with a connected device or Wi-Fi scanner app? For me it always stays on 2.4 GHz, even when switching to 5 GHz. I’ve reported this as a bug ages ago.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.