Play Store cannot be reinstalled (1.8)

Dear everyone,

I cannot reinstall Google Play Store – the widget to install Google Apps only tells me that all Google Apps have been installed, but the Play Store is not in the list of my apps. I have tried this several times, restarted the phone, always connected WiFi. I use the latest Fairphone update, Kola Nut. According to Google, the device is connected to my Google account, and I my contact list seems to be synced properly, so it seems to me that some Google Apps work, but the Play Store is missig.

Have you had a similar problem? Any ideas how to solve it?

Thanks a lot in advance! Any help is much appreciated.

I’ve had a similar issue with Kola Nut 1.8.2 (that version is currently in something like a closed beta). What ultimatly helped me was reinstalling the Fairphone Update and then installing the Google Apps again.

Let me know if that is working for you!

Thank you! Would you (or the other users) suggest to install 1.6 again? I have somehow lost track with the updates, and I am not sure whether it makes sense to downgrade to an older version, but judging from the other discussions here, it seems that many of you use 1.6. However I am very optimistic that your solution might help. Anyway I have to wait a bit until I try it since I am still at work and the battery is getting lower and lower.

I suppose there are very different opinions regarding 1.8. I personally run it since it was released and never hat specific problems with that Fairphone OS version. Others had obviously.

I would recommend you stay on 1.8 since you already installed it (even if reinstalling might by required) and see how it goes.


I am afraid the problem has got much worse - when staying on 1.8 didn’t fix the problem, I decided to reinstall 1.6 instead. Apparetly a huge mistake. Now I am facing several problems at once:

  1. The keyboard won’t work. Been there before, but this time fixing this seems to be hard, because
  2. I cannot reinstall the Google apps. I have found the widget & it doesn’t react. Nothing happens when I click it. I have restarted the phone, I took out the battery, I have charged, I have a stable WiFi connection. Still: nothing. All I can do with the widget is delete it.
  3. When I realized that 1.6 does not magically fix all the problems 1.8 (apparently) causes, I decided to reinstall the upgrade. Opening the Fairphone Updater app, the screen turned black and after a while that was probably less than two seconds but felt like half a day there was another error message, telling me that the process won’t work. Which is, I suppose, why the Updater does not work - is that correct? I can’t access the gallery either by the way. This seems to quite a mess.

Long story short: no keyboard, no Google apps, no Fairphone updates.

If you have any ideas how to save my phone, please let me know. :flushed:

The funny part is, though, that I just found out that my battery is bloated. And I wondered why the back cover won’t shut. There is no better way to fix a software problem than to replace it with a hardware problem. :wink: But maybe it makes sense to leave the discussion open for awhile in case others experience something similar.

1 Like

I remember that there were people who did exactly the same thing, they downgraded from 1.8 to 1.6. Lucky you, a solution has been provided! :slight_smile:

Thank you @Stefan – I will try this as soon as I have a new battery. Btw: also a huge thanks to the support staff at Fairphone, they were very kind and helpful.

1 Like

It seems I’m having the exact same problem. I’m using the latest Fairphone OS, and I didn’t bother reinstalling Google Apps after updating the OS until today, when I actually needed the Play Store again. But reinstalling Google Apps (twice) did not result in Play Store turning up on the list of apps. Would very much appreciate help!

@doujima I’m going to quote the first answer to the original post:

I had the same problem. Now I’ve installed Kola Nut again, the google apps installer is blue but when I tap it it says fair phone is updating your operating system try later. It happens again after restarting. Help…

fixed it myself :smile:
open en closed fair phone updater and it works!

1 Like

Okay, it will be a few days before I can try reinstalling the OS (am currently stuck with very dodgy hotel wifi), but will report back.

Dumb question: how exactly do I reinstall 1.8? When I open Fairphone Updater, it just says “Your current operating system version Fairphone Kola Nut 1.8, your operating system is up-to-date”.

Go to a wifi and you should be able to enter the area for advanced users and see two buttons. Choose Fairphone OS. You should be able to select 1.8 Kola Nut.

Okay, thanks Stefan - can confirm now that after reinstalling the OS, I was able to get the Play Store to work again.


Glad, eveything wotked out for you!
This topic is now closed. New replies are no longer allowed.