Update 1.8 failed, downgrade to 1.6 produced "android.process.media has stopped"

Dear Community,

Yesterday I tried to update to 1.8 Kola Nut. After restarting my phone, the Google Apps installation could not be launched. A pop-up said Android was “setting up … in the background”. [Also, the German keyboard failed every time I tried to write something. I fixed this part by selecting the English keyboard - which did not crash.] After six hours of waiting and still no change with the Google Apps widget, I tried downgrading to 1.6 again. There is the following problem:

“Der Prozess android.process.media wurde beendet” (process … has stopped) appears every time I accept the terms for installing Google Apps, when I open the Fairphone Updater App and the pop-up of this message interrupts usage of other Apps in an OBNOXIOUS way (sometimes I have to hit “ok” ~25 times in a row before returning to an App I am using). Also, the Google Apps installation and Fairphone Updater close after this message appears. So basically, I am stuck with my phone without any Google Apps and without the chance of up- or downgrading to a different version, but with regular system pop-ups.

Can anyone give me some advice or already solved this or a similar problem? Very grateful for restoring assistance for my phone,


I have the same problem. Do you already know how to fix it?

I have the same problem as well…tried to fix that problem by installing the update manually in reboot mode via sdcard but then it says the installation got aborted…doesn`t work forFP1 and FP1U neither…

This seems to be a compatibility issue between 1.6 and 1.8.
You can resolve this by doing the following:

  • Go to your system settings
  • Tap on the Apps icon
  • Go to the ‘All’ tab (you can see the tab option at the top of the screen)
  • Search for the ‘Media Storage’ icon and tap on it
  • Tap on the ‘Clear data’ option

Cheers :]


Thanks a lot, it worked :smile:

yeah, seems to have worked…

o.k., problem fixed.

I was very stupid! Had some issues with the kola nut update and my google account, so i thought it was a clever idea to install cherry again and then kola nut 1.8.5.
Now i am not able to enter the fairphone updater app because evertime it says “unfortunately, the process android.process.media has stopped”. Nothing, except whatsapp (haha), is working and i am slidely in panic…
Anyone who knows what I can do? What be happy about any advice!

@mrsmpsa Consider reading the posts above. Next time, please use the search feature before posting (the little magnifying glass above).

This topic will autoclose in 5 days.

sorry and thanks a lot!

Did it work? …

This topic was automatically closed after 5 days. New replies are no longer allowed.