Physical SIM card fail on FP4 (but still fine on FP2)

Hi!

For several month now, I had a occasional issue with my physical SIM card not being recognised, but:

  • it was always solved after one reboot, maximum two.
  • happening once every two weeks or so, so not a big deal

From Yesterday evening, SIM is not recognised at all, several reboot didn’t solve anything, nor cleaning the contact with a tissue.

Some screenshots

And after typing ##2886##

Putting the SIM card into my FP2 it’s immediatelly functional, how is it possible?
Does it means the FP4 is faulty?

With my current operator (Lycamobile) it seems complicated to ask for a new SIM, but I will try anyway…

Did you already use this SIM in your FP2 before you got the FP4?

Yes it’s circa 4years old SIM card

i think trying a different SIM (if possible) would be the most obvious test for now.

The fact that it still works in the FP2 might reflect that its “tear and wear” results primarily from that device. Maybe the scratches etc. the card has by now “fit” perfectly in the old FP2 SIM slot.

5 Likes

It was exactly that! :smiley:

I had a closer look at the nano-SIM and it was bended, by the fact that FP2 apply some force on the side of the SIM while supporting it on the center…

Whith my fingers I just applied an opposed mouvment to redress it, and now it’s working again in my FP4 :partying_face:

Thanks a lot @urs_lesse , you’re my angel :angel:

5 Likes

Short update:
After redressing the card it worked for a couple days then failed again.

Last week I went to a Lycamobile shop to buy a new SIM card and called them to transfer my number on it (They don’t send replacement SIM, that’s the procedure :wink: )

Since then I didn’t have any issue :smiley:

5 Likes