Photocam halts recording video

Hi folks
I got and FP2 with fpOS, I used to record short or long video alike, now my cam has stopped recording anything longer than 14 seconds.
More specifically it goes on recording, so it seems, but when you see the video the image stops at 14/15 second while audio goes on.
Do you have any suggestion to solve this?
I tried closing all apps, nothing changes.

1 Like

Reboot first.
Check your storage if there is enough available.
Also re-check your camera settings. Which app are you using btw.?
If your save location is external storage check if the filesystem on the sd card and the sd card itself is undamaged.
Maybe clearing (data) cache of your recording app can help.

Thank you Patrick, I rebooted with no improvements. I have lots of space available (more than 9GB) on internal memory (where vids get stored) and external.
Im using the default camera app, that works just fine when shooting pics, both with rear and front cams.
Im now trying to find out where the chace data are stored.
Thanks for your help, I will try to download some camera app too.

2 Likes

These were my first thoughts I had, to start with.
The very strange thing about this is that recordings stop after 14/15 sec, not 32, not 4 but 14/15 sec. and audio keeps going on.
Is this the new 12MP camera module?
Some users here have reported the app was reporting not being able to connect to the camera.
Trying out another app is a good idea for crosschecking, opencamera is a free and feature rich, very often recommended app as replacement.

If it behaves the same you may very slightly bend/twist the phone in case there is a bad contact. Looking at the camera modules shows quite many pins to get them connected to the core module.
If you feel able you can also dismount it to clean the contacts. Cleaning the contacts often helps in different uncertain issues.

I have the same problem: I start recording a video, and when I stop, it hangs and the written video only keeps the first 1 or 2 sec of video, and a bit more audio… I tried the default video app (Google), tried Open Camera app, tried to record on my SD card instead of the internal storage, tried to record at 720p instead of 1080p, it always ends the same way: the video is not well written…

My FP2 has the following specs:

  • Qualcomm MSM8974PRO-AB
  • Front camera: 2MP OmniVision OV2685
  • Rear camera: 8MP OmniVision OV8865
  • Android v 6.0.1 (security fix 01/02/18, base band 4437.1-FP2-0-08, kernel 3.4.0-perf-gcde0e65, build FP2-gms-18.04.1)

Thank you Patrick for your suggestions and considerations.
Instead of trying other apps I spent some time doing experiments with possible conflicting apps. I do not have specific technical data, but I can say now that KIK social app, which gives also access to the cam, seems to be conflicting with the normal functioning of the default cam of my FP2.
I state this because cam seems now to be normally working when KIK app si closed and FP2 is rebooted.
I would like to be able to say that when KIK app is open cam doesnt work, but it doesnt happen always.
At least I found a workaround :slight_smile:
Thank you again

2 Likes

If I am not mistaking your security patch level should be more recent:

security

Anyway, after reading @paolo_de_andreis reply it cannot be excluded that also another app is occupying the camera interfering with any main camera app.
This behavior wasn´t mentioned very often here yet. This could be a hint for you to start your search for the cause as well.

Since when did you experience this behavior? Did it start somewhen or didn´t recording work right from the start?

@paolo_de_andreis

Tracking down such a tricky misbehavior is time consuming, but as it seems you were successful.

If you are confident that KIK interferes with using the camera otherwise it could be a bug which you could address to the programmers.

On the other side - these days of major surveillance push I tend to state, if a permission to make use of the camera is granted it´s itching to actually use it (at any time).
Flat TVs e.g. of LG had a bug in the firmware which was exactly doing this but without a known permission of the users.

Just recently I was playing a bit with Googles stuff on my handset to again re-check different settings in my account. Every now and then I was disturbed by a camera click without even touching any specific app for the use. :thinking:

Generally I decide which third party app will be installed or updated by comparing the permissions required, not the features and functions.

1 Like

Thanks Patrick for your suggestion. I do myself feel unconfortable with the data big corporations take from people and from me as well, we live in an era where computer literacy is essential to freedom. Im not skilled enough to avoid such monitoring, i do usually adopt behavioural tactics :slight_smile: surely thats not enough.

On those basis I dont feel like raccomanding to divert resources on exploring KIk possible conflicts, maybe we should just follow your advice and do not install such data-eating apps.

1 Like

Well the Fairphone Updater app doesn’t tell me anything about a new patch, even on WiFi…

Since I first try to take some videos with my Fairphone 2 I would say since about 2 years…

As I’m able to take photos without any problem so that’s why I think that it could come from other things than my hardware.

Good point, I’ve just checked which apps I allowed to use my camera and forbid a lot of them. I also reviewed the current running services (enabling & using Android developer tools) but nothing was strange to me.

What exactly happens is that when I stop recording, the app (default Google one or Open Camera) freezes, and the finally recorded file just includes 2 first seconds of video and the length of my recording (for example, in a video player I can see that the video lasts 1:34 but it is only able to play the 2 first seconds).

Thank you @Patrick1 for your clues, but for the moment I’m a bit lost and am wondering if it wouldn’t be finally a hardware problem?

1 Like

@netangel

Sometimes it also needs an update from the Play Store to also offer new available OS updates. (e.g. was the case at the time switching from Android 5 to Android 6).

Sounds so reading through your posts, hmm. I assume warranty is over now…
Also write speed of your sd card is out of question now as writing to internal storage don´t help either. (Hense pictures may work, but not necessarily video as well.)
Maybe there are #fairphoneangels somewhere close to you to try replacing modules and finally finding the affected module. But I´m afraid permanent replacing now is on your costs…:frowning:
There are sometimes friendly benefactors offering their functional 8MP camera modules (for a low price) as they have upgrated to the latest 12MP version.

Have you also tried the front camera? Does it also result in broken files? Both cameras have their individual module. So if both don´t perform as they should there seem to be a more general problem and replacing any of them may not help at all. If it´s only the back camera there is a good chance to fix it by replacing it.

Well I finally changed the front & back camera modules to the new ones (so passed from FP-REC01 to FP-REC02, FP-CAM01 to FP-CAM02) and now am no more facing this video recording problems.
And it seems that I have less (no more any ?) bugs that previously exited the photo application suddenly, especially when I rotated my phone when I was using this application !

1 Like

Hi, I had this issue as well. I recorded some videos, and on most of them the video stopped while the audio was recorded flawlessly.

What I found was causing the issue was the “auto-rotate screen” function. After I turned it off it has not happened since.

4 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.