Phone & SD card not detected by computer (using OpenFairphoneOS)

Since Open Fairphone OS is installed on the fairphone. My computer don’t detect it, whereas it used to do it when it was still on the default Fairphone OS.

Then it’s not possible to share data between computer and fairphone.

Computer also don’t detect the SD card. I tried internal and after external storage. None are working. But I got a message from the fairphone saying this SD card is quite slow and not the best to use for this phone.

Do you please have an idea on how I could share data between my computer and the fairphone ?
Thanks for paying attention.


But you did the swipe down and select the connection mode routine? …

Thanks a lot for your answer!
I didn’t have the opportunity to swipe down and select the connection mode routine. Maybe because of open fairphone OS. However I’ve been answered to enable the developer mode to do that.

If you don’t see any such option when swiping down, you are perhaps using a cable which is only for charging.

1 Like

Hi there,

I have more or less the same problem. When I connect my new FP2 via USB to my Mac, the phone is just detected from the Photos but is not possible to import the pictures. Doesn’t matte what I have done until now (MTP, PTP or Midi) my Mac sees nothing. I have also checked 4 different USB cables.

Another thing is, that the FP2 can be charged in the Car via USB just when I switch the phone off:

So any help, Ideas??

Thanks a lot


Admittedly I have Android File transfer installed on OSX 10.14, but only necessary to tap MTP option to reveal both internal and SD card memory

Did you change anything in the developer options? In my experience, when USB debugging is turned on in the developer options it will still work with MTP, etc. but the charging only mode does not work if debugging is on.

1 Like

Sounds like the charger is too weak. There is a wide variant in quality. You should look out for a charger with at least 1A current output. Better would be 1,5+. As not all chargers actually provide precisely what’s printed on the case or by the technical specs. Only measuring the output can prove for sure. And use a cable of proper quality as well as this can also limit what’s delivered by the charger and what’s actually received by the phone.

Thanks to all of you.
Problem solved. in my case, the answer is : “USB debugging is turned on in the developer options it will still work with MTP”
Good luck Joerg. Hope you’ll get an answer. Sorry I can’t help you that much.

1 Like

I have checked also the debugging option as well as Android file Transfer and the USB option MTP, FTP etc. and its really interesting. So when the debugging modus is snitched on, the FP 2 is charged in the car via USB :blush: and my Mac detects the phone via the Android File Transfer. Very good so far but there are still some issues to solve.

Nevertheless, with the forum and your help, as well as the Internet I can learn more every day! Thanks guys.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.