Phone not charging


My FP3+ is not charging. The yellow light goes on when I plug it in, but it does not charge. Android Auto has stopped working too.

When I plug into my laptop, I get the message “USB device not recognised” “The last USB device you connected to this computer malfunctioned and Windows does not recognise it”.

Can anyone help?

Try cleaning the USB port, after trying a new cable.


I’ve tried multiple cables without success. The cables work fine on other phones. This problem only started this afternoon.

How should I go about cleaning the USB port?

A good magnifying glass and a very small needle

I removed the port to clean it and saw the contacts were green so I scrapped them gently and the phone charged once replaced, Look also for lint etc.

1 Like


I tried cleaning it with a needle. Nothing came out, and the phone still won’t charge after reassembling.

When trying to charge it via a USB and wall-socket with the phone turned off, it keeps cycling through a screen showing “Fairphone”, and then on showing the battery percentage.

It looks like I might have fixed this by taking the battery out for 30 minutes and then putting it back in.


Actually, it looks like cleaning the port with a plastic toothpick may have fixed the problem intermittently, but it looks like a new bottom module may be needed for a longer-term fix.

I experienced the same issue recently. Thought it was down to the battery. I replaced the battery and it seemed to work but when I plugged in the charging cable yesterday it wouldn’t charge.

After reboot and switching off smart battery it charged again…

Hadn’t thought about a new bottom module yet. Have you already replaced it?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.