English

Phone drains battery faster than it can recharge, 2h battery life top with a brand new battery

Tags: #<Tag:0x00007f05dbe57c38> #<Tag:0x00007f05dbe57af8>

Hi everyone,

I have a 2.5 years old FP2, that was working fairly normally (though battery life started to get shorter, but nothing unusual after that time). Then yesterday night I couldn’t charge the battery anymore. I tried 4 cables on AC or PC, no charge. With a friend who also owns a FP2, I swapped battery, to check if mine was faulty. I couldn’t charge his battery either. His phone couldn’t charge mine. So my battery is probably dead, but it’s not the only problem. Then I remembered I had an old bottom module with a defective microphone. So I replaced my bottom module with the old one, which had no charge problems. I still couldn’t charge my friend’s battery.
I bought a new battery and bottom module, but with the tests I performed, I have only little hope that changing both would work.
When troubleshooting, I could enter the Logo-blink-vibrate cycle. I can use my phone when connected to a charger, even when the battery is 0%, but of course it shuts down as soon as I unplug. I tried removing SD and SIM card with no success. The memory use is about 60% and no app seems to drain the battery. The area above the battery starts to get hot when I attempted to charge.

Does anyone have any idea what could be wrong ? I’ll update as soon as I get the replacement parts, but meanwhile I worry it will not solve my problem, and I wouldn’t want to damage the new parts if something in my phone is wrong.

I have exactly the same problem. I have replaced all modules including battery, tried three different chargers & still the FP2 is blinking/vibrating but no charging. So I am happy if someone can come with a solution.
I bought my FP2 when it was newly released.

Update : I received a brand new battery today. Charged it full before switching the phone on. The Battery decrases rapidly, and I have aboute 2h30min of battery life, with no SIM card inserted, no WiFi, no activity at all. CPU just gets hot but I can see no reason for that.

It is definitively not a battery problem, something drains it so fast most chargers just can’t compensate. Any idea what could cause that ?

Try #dic:safemode to rule out a software issue. If the battery still drains there some part of your phone is causing the drain. #disassemble the phone, clean the connectors between the modules and leave them out, then try safe mode again. If the battery is still draining it must be the core module.

Hi lorraine_Montel,
Did you solve your problem ?
I have exactly the same issue. I bought a FP2 in November 2015 so I thought that my battery was too old. I bought a new one… but for nothing !
I can charge the battery at 100% but few hours after, the battery is completly empty.
Thanks for your help.

I now also have the same issue.
can an admin/fairphone expert help us out here??

Two posts before yours, actually …

3 Likes

Also note that this is a community forum, staff is rare here. The mods are not Fairphone staff. If you need support by Fairphone staff check the troubleshooter (as support will ask you to performs the steps listed there anyway) and, if the suggestions there don’t work, submit a support request,

4 Likes

Can you determine if the heat is coming from the CPU (is in the centre of the motherboard) or the PMIC or the power tracking IC (Both on the bottom edge, close to the battary) This is very important. If it is the CPU, you could try installing a fresh OS, but if it’s the other components you will have to:

  • Replace them and determine a short yourself or by a repair shop

  • Buy a new one and sell the defect one as a donor

1 Like

I know, thanks.
but the problem is not solved by cleaning the module-connectors, or a different cable etc.
the battery won’t charge at all now…??

Does it charge if the phone is off? If it does, did you try booting in safe mode as suggested above?

I think it’s a software problem , i downgrade to android 6.0 .1 and my battery is working much beter now

I don’t think that’s normal. Android 7 should be equal or even better in battery usage.
So maybe your battery drainage was caused by the upgrade from Android 6 to 7. In this case an installation of Android 7 together with a factory reset could help (but obviously it would mean a reinstallation of your apps and data then…).

2 Likes

I did first a factory reset on android 7 and the problem wasn’t solved.so i downgrade to android 6.
On android 7 i also had this bug " #245 Screen displays odd characters like ?!% and red battery icon".
(https://bugtracker.fairphone.com/project/fairphone-android-7/issue/245)

I think android 7 have some problem with reading the correct % of battery.
But i’m not sure.