Phone detects always connected headphone even without headphone

Some days agot I had some water in my backpack and my phone in the outer pocket gut some drops of water. But since then my phone always shows the symbol for a connected headphone even without a connected headphone. Plugging and unplugging a headphone multiple times does not change that issue. Speaker and headphones are working but phone calls only work via headphones (since the phone assumes they are connected).

Has anyone an idea

  1. how to repair this? Or at least
  2. how to ignore the “connected” headphones?

I do not think it matters but I’m on \e\ version 0.12-p-20201002981459.

1 Like

Please check the #waterwiki and and page Electronics Water Damage from for help.


It’s now a week ago since it happened so I suppose it’s dry by now…

1 Like

Well, this could be permanent water damage, even though it’s dry. You may have a problem with your top module, in which case, if you know someone with a FP3, you could try testing a working module. Otherwise, you could contact a local #fairphoneangel, he/she might be able to help you if he/she has FP3 spare parts available.


Does anyone know a temporary workaround to use the built-in speaker and microphone even if a headphone is detected?

Hi @chogo – the water might be coincidence and it might be this bug reported on /e/'s gitlab. note that the original bug description is about the mic but in the 1st reply they describe what could be your issue…

Using the Fairphone-brand wired earphones:
Once in a while, after a call using the earphones and after unplugging them, /e/OS “thinks” the earphones are still plugged in.
As a result, when the next incoming phone call comes in, no sound can be heard from the phone (the phone sounds and mike are still connected to the now unplugged earphones). Sound can be heard through the earphones if I replug them fast enough - before the caller gives and hangs up.

“Have you tried turning it off and on again”? :grimacing:

1 Like

Thanks for the hint with the #fairphoneangel! I replaced the top module and it is working again (I could also see some water damage).
@jme: I also tried installing the last update and restarted several times without success. But thanks for the hint.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.