Parts of the touchscreen don't work - See first post for troubleshooting

Hey, guys! :hugs:

I’m using my FP2 since 2 years and now I’m having problems with my display since about 1 month. As you can see in the screenshot, the left side of the display is not working. :confounded:
This results in problems when texting (i.e. I can’t use the letter “q” or the number “1” in portrait mode).

I’ve already disassembled the phone and cleaned the parts, but without a result. I haven’t contacted support yet because the warranty has already expired and the problem is just a mild annoyance in my everyday life.

However, it seems like I’m not the only person experiencing such problems so I was wondering which steps I shoud take in order to fix the problem. Reading all the comments describing how time-consuming and nerve-wracking it can be, I’m not sure if I even want to deal with it right now… :dizzy_face:

@Alan_Bradshaw: Did you end up buying a new display? Is it working so far? Did you really have to pay 87€ or did you receive a discount since it seems to be a common problem that hasn’t been caused by the user?

Any advice will be appreciated! :grinning:

Hi @w4tler
Yes I did buy a new display in the end. FP Support assured me any problems with manufacture have been fixed and the display module comes with its own 2-year warranty.
I’ve had it about four months now and it’s been perfect.


Hei, Alan!
Thanks for your quick reply. :+1:
Wow, that’s great news! :grinning: Glad to hear that they fixed the issue and that your display is working properly now. And it even has its own warranty!? :star_struck:
Considering your information, I come to the conclusion that if the condition of my display gets any worse, I won’t hesitate to buy a new one. Although I’d aprreciate a discount since I didn’t cause the problem. :innocent:

I removed the screen of my FP2 as shown in the video. Where do I find the “connectors”?

It’s the thing with three rows of pins above the map of the Congo on the main module and the counterpart on the display.

1 Like

In May 2018 the right part of my display didn’t receive touch inputs any more. 4 Months out of warranty the support team couldn’t help me. The strange thing is: sometimes the right part of the display works fine and sometimes not. At the moment it works great!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

Something has happened with the screen. I can’t swipe in the middle and I can’t use some letters in the middle of the keyboard. It depends which language I using (I use 3 different languages) so usually it’s h (except in English) the others I can’t type. Also there’s no autocorrect nor word suggestions in other languages than English (without those I couldn’t be writing this, but I need to be able to use other languages that uses different keyboard with å,ä,ö.). I’ve dissembled the whole phone but it didn’t help. I don’t know how to take off the screen tho. Does the problem lie there? How do I fix that?

Here’s a teardown guide that shows how to remove the screen. Definitely try this, you never know if it’ll fix the problem; keep in mind, however, that the vertical bands that stop working are usually a sign of a broken screen module.

1 Like

Dear All,

I am really confused. I have a FP2 where the display started the thing that was described here, touch on the rightmost part stopped working. I therefore ordered a new display module.
And now there comes the weird part: assembling the new display and starting the phone (which it actually does, it vibrates and connecting it to my computer via USB it appears there), the screen stays completely black. Obviously, I thought that the newly delivered display module is broken. But the support suggested that it is my phone. First, I couldn’t believe that, BUT:

I tested both screens on my dad’s FP2. Turns out that the old one exhibits the same problem there, too, but the new one is working fine! Does anyone have any idea what is going on here? I don’t get it, honestly, cause obviously my phone is able to connect to a display (the old one)…

The only idea I had so far: are there different versions of FP2 display modules? Actually, my old one and the new one look different, while my dad’s original one looks (nearly) identical to the newly delivered on.

I would really appreciate any ideas, as I am just super confused :stuck_out_tongue:
Thanks a lot!!!


But did you try putting your dad’s screen in your own phone? It might be a good clue.
Also, is your software up-to-date? If you open the “Updater” app, what does it tell you?


Hi Alex,

thank you a lot for your super fast answer! It makes me feel less alone with this confusing and quite long-lasting problem :stuck_out_tongue:

Okay, this is interesting. At least in the topic you posted there are no people reporting that their phone works with one but not the other display version. But for me it strengthens my hypothesis, as the one that works has (most of) the signs mentioned as indicating an old module, while the new one and my dad ones have (most of) the signs of new ones… Strange. Is there anyone with any such experience?

Sorry for having forgotten to mention that: after putting the new screen on my dads phone, I started praying that his might work on mine so that we simply could change them. It didn’t. And as mentioned, his display module also seems to be one of the new version (I guess his phone is also much newer than mine)…

My phone is running Lineage 17.1:

I did update it recently, but I did not yet do a completely new installation of Lineage, do you think there is a real chance that this could help? (I have an app installed with a lot of personal data that I cannot backup for the reason that I did a real lazy job when programming it, so it would be either really lots of work or lots of data loss)…

Thank you and have a nice day! Still appreciating any ideas :blush:

I wouldn’t have been surprised if you were running a very old OS version, but here you’re running LOS 17.1, so it shouldn’t have any problem.

One thing you may want to try is flashing the #modemfiles in TWRP.

Yes, it may if the advice of the #modemfiles doesn’t work.

Can’t you just do a #twrpbackup? Like this if a reinstallation works, well you can just restore the backup on top with all your app data.


Dear @Alex.A,
today I finally gave the modemfiles a try, and they solved it! My FP2 does now recognize the new screen! Everything is finally working the way it should, amazing! :star_struck: :+1: :heart_eyes:
Thank you very much!!!


The touch screen of my fairphone 2 does not work in one part: With the drawing tool from the service checkup it becomes obvoius which part of the screen does not get any touch signals: a column that is (holding the phone in portrait mode) 1cm wide, and 1 cm distant from the right screen border. If i type “i” on the keyboard, it makes “uo”. For now I can write text only in landscape mode.

Is there any possibility I can fix this without replacing the screen?

You can try to remove the screen, clean the contacts, and reassemble it again.
I’m not sure, whether the touchscreen function is connected in a kind of matrix, like keyboards, but if it doesn’t help, it should not do any harm either.

1 Like

Thanks for the advise. I carefully cleaned the contacts with rubber (eraser), but sadly its still the same problem. Didn’t work for me.

Is there a Fairphone angle or a meeting nearby, so someone might help you with a spare screen for testing?


The following may be worth a try for the desperate:

Has worked for me on several occasions.