OTA update to FP2 OS 21.05.0-rel.1 fails, cannot find manual installation file

Hello, I tried to do the OTA update of my Fairphone 2 system to the recently released FP2 OS 21.05.0-rel.1 using the Fairphone Updater app, but it fails during the recovery installation part with the image of the Android belly-up and an “error” (and nothing else) message.

I’d like to install it manually, but I cannot find the installation file. The latest system version appearing on the downloads page is 21.03.0-rel.2.

Anybody please knows where to find the new version of the manual installation file?

The manual install file doesn’t seem to be there yet.
You might also keep an eye on Fairphone 2 (A9). Manually install Fairphone OS – Support.

If you’d like to experiment, the manual switcher file to get from Fairphone Open OS 21.05.0-rel.1 to Fairphone OS 21.05.0-rel.1 is available already … Download Releases — FAIRPHONE open source documentation.
I don’t know how this wouldn’t install Fairphone OS properly, I didn’t try it myself. Perhaps watch out for a data wipe in the process.

2 Likes

Thanks for the tips @AnotherElk. I saw the manual switcher on the FP Open page, but people should be careful when using the manual switcher version because it wipes your data partition, unlike the normal manual installer (so the different installer versions).

You can naturally hack the switcher script to make it work like the normal installer, but I prefer to wait a few more days for the correct version.

When you are at this stage, briefly HOLD the power button and press the Volume UP button to get to the AOSP recovery. A yellow line at the top of the menu should indicate if you are still at 21.03.0 or already at 21.5.0. If you are still on 21.03.0, you should be able to manually re-install this version (21.03.0) and keep your data.

P.S.: Actually it seems (I just tried it again), that after the 21.05.0 update, the Android belly-up step is gone. Holding power and volume up took me directly to the AOSP recovery. Marking @AnotherElk because you might find this interesting (and perhaps worth to try to verify).

2 Likes

By the way, the new manual installer is now available on the downloads page mentioned on the original post. Thanks to all anyway, looking ahead for the bug fixes.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.