Official LineageOS 21 for Fairphone 3/3+

Worked fine for me so far, with different routers/APs.

My home infrastructure is also AVM-based (F-Boxes & -Repeaters). So maybe that is a reason? But why?

@TeamB58: Could this be an issue with wireless-regdb, or somesuch?

3 Likes

I can confirm this. I cannot connect to AVM based wifi anymore. Others seem to be working.

@TeamB58 is there a possible workaround for this to get avm wifi working until this is fixed?

1 Like

Did anybody confirm yet that the current Wi-Fi trouble is not the 5 GHz channel 116+ and perhaps FRITZ!OS version thing? … My FP3 doesn't like higher 5Ghz Wifi channels, especially channel 116

1 Like

Same issue with the wifi and same setting with a fritzbox.

My 5GHz band is set to channel 40, so at least on my end, that’s not it.

1 Like

I have these issues with 2,4Ghz Wifi

2 Likes

I separated the 2.5 and 5GHz- networks. The former is in channel 11 and the latter in 44.
I cant connect to either network with the current version of lineage.
Other devices are of course working fine

1 Like

I am on iode 5.3 (released yesterday), Router is Fritz.Box 7530 (OS v7.57).
5GHz WLAN (WPA3/Wi-Fi5) has it’s own SSID and works only with channels under 116 (as mentioned before). 2.4GHz (WPA3/Wi-Fi4) works fine, no issues.

I can confirm the July 10th update makes wifi connections “disabled”, either 2.4GHz, or 5GHz on several devices. Also i tried to manually flash boot/vbmeta/dtbo and the system itself. Testing downgrading right now…

Ps: when connecting 5GHz networks the wifi on the fairphone seems to be restarting.

After some time: I decided not to downgrade as some documentation says you have to erase data partition.

i logcatted lines like (anonymized):

  • WifiNetworkSelector: “<SOME_SSID>”:<SOME_NUMBER> reason=NETWORK_SELECTION_DISABLED_CONSECUTIVE_FAILURES, count=<SOME_NUMBER>;
  • E WifiHAL : Invalid data received from driver
  • WifiService: Keeping REDACT_FOR_ACCESS_FINE_LOCATION:java.lang.SecurityException: UID <SOME_NUMBER> has no location permission
1 Like

I have two networks at home, one from my Turris Omnia running OpenWRT fork by CZ.NIC on both 2.4GHz and 5Ghz and one from my ISP router on both 2.4GHz and 5GHz.

Connecting to my Turris Omnia fails, it was working before QPR3 update.
Connecting to my ISP router works on both frenquencies.
I should check what parameters are working or not.

Edit: I did try to change many settings on my router, but I’m still unable to connect.

Also separated band setup of Wifi in Fritzbox 4060. No connect possible since last update!

Applied the July 10th update without reading a lot in this thread, and now I’m stuck with the Wifi issue as well. Won’t connect at all, regardless of whether or not I use 2.4 Ghz only, 5 Ghz only, or both.

Router is some random piece of plastic junk (Speedport Smart 4), tried 2.4 Ghz on channels 1 and 6 selected by the router, 5 GHz on 100 and 104.

Did anyone find what is exactly not working in wifi? What AP settings?

I guess it is some driver issue like the logcat says on my phone.
I’m also wondering if the devs are aware of it and if not, should a ticket have to be filed? :thinking:
Furthermore i would suggest not to make the same mistake as me: double installing the update. :expressionless: My strategy will be switching A<->B to get the last working state running next time.

1 Like

I’m pretty sure @TeamB58 is already aware of the problem and looking for a solution. BTW, the Moto G7 with the same chipset seems to show similar behaviour: WiFi networks instantly disconnnect after connection attempt (#7348) · Issues · LineageOS / issues / android · GitLab. It might help if you “officially” report the issue to Gitlab with a logcat and reference the G7 issue.

To give you some comfort: Rolling back to the other slot wouldn’t have helped! Once you successfully booted the new build, Android’s rollback protection would not let you boot the previous build…

2 Likes

Hi All,

Firstly, I am sorry for this issue. I’m afraid we shouldn’t have shipped this without proper testing. We now have an option to stop builds and unship the device until the issue is fixed so other new users who try to update will not be affected. Let me know if that has to be done.

For all affected users, this is an issue with the old prima drivers + Android 14. They both seem to be incompatible and all devices using this combination is currently affected. The moto maintainers have joined hands in investigating this issue and we are not sure how long it might take to identify and fix the issue. Not sure if there is any workaround for this at the moment.

Please let me know what we can do now.

Thanks.

2 Likes

my isp router I’m able to connect (which web interface does not give enough details) is having this wifi setting given WiFi Analyzer available on F-Droid : [WPA2-PSK-CCMP][RSN-PSK-CCMP][ESS][PSK]
Unlike on my Turris I can’t connect to has this setting : [WPA2-PSK+PSK-SHA256-CCMP][RSN-PSK+PSK-SHA256-CCMP][ESS][MFPC][PSK]
Can it help? Also, I do not know yet how to get the first setting on OpenWRT to try if that can be a workaround.

1 Like

Hi to all moto maintainers, especially @TeamB58 !
thank you for all your work. :innocent: :+1:
I have no problems.
Yesterday I found the time to do the upgrade and my phone tells me now “Android-Version 14, LineageOS-Version 21.0-20240606-microG-FP3”. I’m using Wifi on the AVM Fritzbox 5530 Fiber and the FP3 connected without a hitch after the upgrade. Today the FP3 tells me Wifi is on 5GHz - the router “chooses itself” which channel to use, I don’t know yet how it would be with 2.4GHz. If it would help I could try it by changing the setting in the router.