Official LineageOS 20 FP4

Thanks for link.

But I think that I will not be able to report it.

As I understood, it’s mandatory to join a logcat.txt when we report a new bug.
As this bug appear sporadically and I don’t have found how to reproduce it, I don’t know when to start the log.
Because if I’m right, I have to send the adb command to start logcat before reproduce the bug, it’s correct?

I dont understand much about this or difference if any, however you can add to you power button menu the “bug report” shortcut.

Ok, I have tried to add this issue on GitLab with the report generated through the “bug report” from the power menu.

I hope that it will help to have this issue solved.

Thanks for your help


What key combination can be used to do hardware tests on Lineage OS? In Fairphone OS it goes yes with: * # * # 2 8 8 6 # * # *

As you said, you will most likely not be able to lock the bootloader, still I dont think its a one way road as you can use it with an unlocked bootloader after manually installing FPOS again.

I am not sure if this is true. Yes, there is a ( obviously malfunctioning) rollback protection that can brick your device. BUT: I think what is important is the monthly Android security patches and not the main Android version in general. So I think you might be able to revert to the default OS if you have, say, LOS 20 (Android 13) March security patches installed. And there is a FPOS (Android 12) version with April security patches available…


There is no such code in LineageOS.

Yep, happens to me twice a day since latest update.
Very hard to purposely reproduce though.
Thanks for reporting it!

Yes it’s right. It’s the security patch which is important. I have contacted the support of Fairphone and they have confirmed that. The security patch of FPOS need to be equal or higher of the security patch onf LineageOS to roll back and relock the bootloader.

I have tried on a second device to roll back from lineageos (Android 13) with security patch of March 2023 to FPOS (Android 12) with security patch of March 2023, and then relocked the bootloader and all was OK.

1 Like

I hope that it can help to have this issue solved.

If someone understand how to reproduce it, please share it to add the information to the ticked

Not worked for me. Was running A13 iode with security updates of March updated to FPOS12 with March security and cannot lock. So someone at FP needs to get things straight. My only other thought is the custom key that gets added by iode at the beginning. If FPOS doesn’t delete this then I’ll delete and see what happens!!

You have to delete the Iode custom keys before manually installing FPOS again, at least it was the case in the past.

Thanks for your quick reply. My plan is to revert fully to stock and relock. Was impatient for A12 so played around with LOS 20 and then flitted between Calyx and iode. I just want to reset to stock and lock now, so hopefully the steps you’ve given me will now successfully do this :+1:

Doesn’t work and the 2nd command that disables verity needed an extra command on the end which was flash vbmeta vbmeta.img It seems that Calyx and iode know how to be able to lock the bootloader it’s just a pity that FP don’t.

Hi folks!

Has anyone successfully used the new Android 12 binaries to build LineageOS?
As far as I understand, there are some files missing that were present in Android 11.


Hi y’all,

I am running LOS and I noticed that the call volume is always very high. The volume control does not seem to have any effect and it appears to be always at maximum volume. Do more people experience this? And where would I report such an issue?

I’ve noticed the same thing with my volume. If you want to report it, you probably need to open a bug report with Lineage.

See FP4: cannot change call volume (#5763) · Issues · LineageOS / issues / android · GitLab

I noticed that the Messages app that comes with LOS 20 does not include a feature to search through messages. What other apps are people using for SMS/MMS on LOS20 that support searching? (And will handle unencrypted sms/mms – I’ve read that support for unencrypted sms/mms has at least been deprecated from Signal if it is not already removed)

You could give QKSMS a try: