Official LineageOS 20 for FP3/FP3+

Hello, I am thinking of getting a 3+. Has anyone here installed Lineage OS on one?
Any problems?
What recovery?
Anything not working?
Easy to install Google stuff?
Google wallet NFC working?
Please be gentle with me, I’m new here and finding my way around. :grin::v::peace_symbol:

Hi, I’m using LOS more or less since the beginning, now on 20. Everything works fine (for me)
Standard serup, twrp only temporary booted if necessary (fastboot boot). Mindthegapps for Google. Wallet does not accept LOS NFC based paying (device not certified) , but PI certification is fine, all my banking apps work. I don’t care for Google pay, they already get enough data from me… (Interestingly, rooting and hiding did work for pay…)
Btw, also using personalDNSfilter from f-droid

Thanks for that. Probably get around Google wallet authorization via a magisk module I’m using currently.

Regards

This seems to be a problem with the current release of the Aurora Store app available via F-Droid.
To temporarily circumvent this (until the problem is fixed in the stable release version) you can install the latest nightly version from the link below, which fixed the issue for me:

https://files.auroraoss.com/?folder=AuroraStore/Nightly

1 Like

thx for the hint! but meanwhile i managed to downgrade aurora to the next lower version and after clearing cache, it is working for now. so this is not a los issue.

Big thanks to all involved making this possible!

1 Like

Is there a reason there was no new build? I was hoping for the april updates.

Hi everyone, I’m Pol from Barcelona and first of all thanks to the devs for the efforts.
I’ve been using LOS with microG 17.1 since two years ago and last weekend I decided to jump to 20 with migroG.
Everything worked fine with 17.1 but on LOS 20 I’m having issues with the sensors. The phone is not rotating the screen, and the proximity sensor is not working (which is annoying during calls).
I’ve tried Sensors Sandbox and is getting no info from any sensor, and when accessing the hardware info on CPU Info app the app reboots.
I was wandering if someone else had the same problem and I was asking myself if it maybe has to do with the dirty install? Any update o settings I should check?

Last thing but with less importance, is that after upgrading to LOS20microG Google Drive installed on LOS17.1microG using Aurora was not working any more. I tried installing through Aurora again but it’s not working anyway.

Thanks

Hi
I recently updated my FP3 from Lineage 19 to 20. Already in version 19 I sometimes had to reboot my device after start-up because some apps like K9 Email and Deutsche Bahn (DB Navigator) stayed “inactive” (visible but not usable, greyed-out). This problem continues in Lineage 20. Now I have always to restart my device a second time in order to get those apps activated. Everything else works fine :slight_smile:
What might be the problem?
Thanks,
Markus

Do you eventually have an SD card installed as internal storage?

2 Likes

I experience the same issue, already with LOS19, also in LOS20. It seems to affect the apps stored on the SD card.

1 Like

The new image is up and installed fine. Thanks for the work.

I make my first OTA update with LineageOS 20.
Firstly I have the updater bug describe by @fwg-cag. I clean the storage of updater app like indicate, but after I had reconfigured my precedent updater preference, I experiment again the bug. If I uncheck Prioritise update process updater work again.

So I start update with Newpipe video in background. After the second step other apps which not running can’t be launched. Updater go to the end. I restart but not in the new update.

I try again without newpipe launch. Some apps crash, but the process goes to the end. I reboot in the new update.

I experienced when I shut down my phone with newpipe work, long vibration and then automatic reboot, maybe the first fail is due to that. Someone have this behavior when the phone is shut down with a high load of memory ?

Apps can still access the front camera if camera-access is blocked (through QuickSettings-Tile) on my phone. Could someone check if it is the same for him/her?

I am asking because I use iodéOS (based on LOS) and I would like to know if it is a LOS-, iode- or "me-"problem, so I can report it to the right place.

Thanks in advance :smiling_face:

When i deactivate camera access, the camera apps state that fact and ask me whether it should be overridden. No image delivered

2 Likes

Yes, indeed. So always install Apps on the internal storage?

You should switch your SD card from internal storage to external/portable storage to avoid the problems you have experienced. See :pencil2: A little guide to… using SD cards - Help / Guides - Fairphone Community Forum and the references included there …

3 Likes

Maybe it too soon to close the LOS 19 topic. Sorry that I have to ask here: Before moving to LOS 20, I would like to make a backup on LOS 19. So what I did is that I flashed twrp-3.7.0_9-0-FP3 and booted it. But then it doesn’t ask me to decrypt my data so via MTP my internal storage shows only the encrypted files and more importantly, it can’t create a backup. And I can’t copy files via MTP.

Note: removing phone lock code doesn’t help.

Note: when I have TWRP flashed, LOS 19 doesn’t boot anymore. I have to flash a lineage recovery or have TWRP on slot b and switch back to slot a to have LOS boot again. Maybe this problem is related?

Maybe also there is another way to do a full backup and I’m using a deprecated strategy? (seedvault still depends on apps authorizing backup of my data :rage: so it doesn’t seem to be much useful that adb backup, besides having a GUI)

edit: I could use neobackup but it need to root and before installing magisk i would like to do a backup since the procedure is a bit scary. So, catch 22… Or maybe there are people that did it the simple (but not recommended) way of renaming the magisk .apk to .zip and flashed it either via TWRP or via sideload-flash with LOS recovery?

First, you don’t need to flash twrp, you can just boot it temporarily. That’s good enough for all practical purposes ™, IMHO. I thick i remember that twrp cannot decrypt data at the moment. Seems to be your problem. And apps that forbid backup tend to not work restored, in my experience. Because they tie their data on some unique rom/install id. Especially notorious are banking apps and crypto messenger.
That’s why i use apps which take their data from my nextcloud instance or can (automatically) create exports which are automatically backed up to nextcloud.

Rather you must not flash it!

2 Likes

@tuxayo adb backup is depreceted and on app that use high sdk target don’t run… seedvault can backup such apps. So it’s not only a graphical difference.