Official LineageOS 20 for FP3/FP3+

I’m trying to update from LOS20 (april 3), but updater fails with an “Install error” message just after the finalizing stage has started.
I tried looking in logcat an found the lines below. What could be the problem here?

05-10 19:58:48.518  1274  1274 W update_engine: [] Unable to mount destination device /dev/block/bootdevice/by-name/system_a on /postinstall as ext4: Device or resource busy (16)
05-10 19:58:48.530  1274  1274 E update_engine: [] Unable to mount /dev/block/bootdevice/by-name/system_a with any supported type

Upgrade to the may 15 release did work… The finalize stage took a long time but succeeded. I still don’t know why it failed last time when I tried multiple times, after rebooting my phone etc.

1 Like

In case somebody faces issues with Apps not running because rooted device is detected, e.g. banking apps, this is how I could workaround such an issue:

I’m running LineageOS for Micro-G with locked bootloader w/o additional modifications (su, busybox, Magisk etc.). Since microG also supports SafetyNet nearly all Apps are running fine. I only had one modern banking app that complained about a rooted device. A closer look in logcat revealed that they use the OSS RootBeer library for the checks and it complains about dangerous properties. Specifically ro.debuggable which is set to 1. Nicely RootBeer provides a sample application that shows a list of all the checks and which are failing. Luckily this was the only one.

The debuggable flag is set because build variant userdebug was used instead of user as default for the built images. I don’t have a need for userdebug but I also don’t want to build images by myself, so I checked for ways to manually change that on the already installed system. Seems that there are Magisk modules available for that, but it is not an option with locked bootloader (at least I guess Magisk will not work in that case). I fell over this reddit thread which provided a surprisingly simple solution:

  • Connect the device via adb
  • adb root
  • adb remount
  • adb shell
  • mount -o rw,remount /
  • nano /system/build.prop
    • Change ro.debuggable to 0
    • Change to user
    • Ctrl-O and Ctrl-X to save and exit.
  • mount -o ro,remount / just to be safe
  • Reboot device.

Now the RootBeer sample app changed green and the affected banking app started working fine. My biggest surprise was, that even after upgrading to LOS 20 the modifications are preserved and everything still works fine. So I also assume that all this also works if already upgraded before. Maybe this helps some of you as well.


I‘m running the FP3 with a locked bootloader and official LOS19. If I like to switch to LOS20 must I open up the bootloader again or can I flash recovery and rom without?

@sky Is the build in updater of LOS not working?

Anybody else with that phenomenon?

When the pop-up “xy does not react” (loosely translated from German) with the option terminate, wait, and eventually also feedback, and you click wait, and the app is back again working, the pop-up still regularly opens again. Only possibility is to really terminate the app, otherwise you won’t get rid of the pop-up

Eyup, some months ago I noticed this behavior 2 or 3 times (on LOS-based iodéOS).

I had the same configuration. I didn’t open the bootloader again. I fallowed the wiki upgrade instruction and that work.

@lklaus I haven’t noticed yet

1 Like

Thanks for the reply. I also did the upgrade without issues following the official procedure.

1 Like

Yes. I get this, too.

The first Update with the internal Updater after the switch to LOS20 have had an error and was not running. Deleting of Updater data and cache solved the issue also by me.

Can you tell me how you did that? Or was it only the update that was not running any more?

Just go into Settings → Apps → Show all apps → 3 dots in the right corner (…) and select showsystem apps → Updater → Delete the data and the cache

If that’s not working see my answer below to disable an option in the updater.

JFYI. after an update to LOS20, currently the “Prioritize update process” option is not working. This option is disabled with the reset of the data you did. When you try to enable it, the updater is forcfully closed with (or sometimes without) an error message and you can’t update any package again without disabling this option.

Hope this will be sometimes fixed in a future release.

1 Like

Yes, I have the same problem with different apps. As far as I can tell, restarting the phone helps - until it happens again with another app…
(iodéOS 4.1 which is based on LOS 20)

Hi all,

Regarding the Updater crash while enabling Prioritized update option, sorry I somehow missed to merge this change. Just now merged and should be fixed with next update.



Sorry for my question - I tried to read everything but perhaps missed it: on the download side is no recovery image for LOS 20 instead one boot.img - is this replacing recovery.img? And there are two other files dtbo.img and vbmeta.img - those two files are not included in the LOS microG version. Do I have to flash those two files as well and does this boot.img replace the old recovery.img?

I have a FP3+ with lineageos this some versions ; I’ve just upgraded to LOS20 via the official procedure and I have trouble getting magisk to work (for bypassing stupid “root” detection, my phone is not even rooted…). I’ve followed the new procedure, downloaded the boot.img, patched it via the apk, flashed it to boot_a / boot_b, but after booting, apk still thinks it’s not installed.
I’ve tried also to boot directly without flashing, still the same.
Any idea ?

Mhh since my upgrade to LineageOS 20, i have one small problem.
I can’t update the phone via the updater app (it crashes), update via sideload works fine.

am i the only one? XD

For me, the “former” method has always be the simplest… and it still works:

  • rename magisp.apk to
  • boot to recovery and sideload

It has been working each time for me.

1 Like

Work fine for me.
(Post must be at least 20 characters… OK, I guess my reply will be accepted now. :slight_smile: )