Official LineageOS 19 for Fairphone 3/3+

Does adb devices list anything? Otherwise adb seems to be disabled.

You will have to flash the NikGapps package over the old one to reset the Google Apps to standard settings and get around this boot loop.

As I explained, when typing adb devices I get the serial number of my device. Does this mean the device is or is not recognized? And what package would I be supposed to flash? More recent or old one?

The command I was asking previously was the fastboot which is different to adb. Do both list your device? If it list your device, your fastboot and adb connection should be ok. If adb doesn’t list your device, adb is disabled.

It shouldn’t matter as long as it resets the permissions of the Google Apps. The package I used through my first flash worked for me to fix the problem, but I’m using MindTheGapps.

You try to load the recovery image (over recovery). You should sideload the full image

Hi HardCoreTec,

Are the “security fixes” special to the FP3-Build of LineageOS 19? - or are they global for all LineageOS 19 ports to other devices?

Would it be possible to provide a test build without these security fixes in the former case? - then it would be possible to see if the problems with denied accesses are gone.
I already tried to grant to System-UI the missing access rights (according to the logs) - but it was not possible to set the needed access rights with the normal Setup-App - thus this has to be done by adb or whatever developer tool.

At FAQs - NikGapps | NikGapps Website there is an interesting guideline to do a “clean flash” without loosing data. I’d try this, if there is a real chance to fix the access right problems. The strange thing is, that I find no other bug reports regarding “systemui” and “requires android.permission.ACCESS_FINE_LOCATION”. So I suspect that this problem is very specific to this FP3 build of LineageOS 19. Am I wrong?

Thanks for your support,

Hi Achim, no they are not specific for FP3, these fixes are global and provided by Google or volunteers.

It’s not that easy as there are OTA-Updates provided in this release which restrict flashing old versions to the device without cleaning all data. Don’t know if this time is spent wisely with this approach as it also seems that the official non LOS FP3 build has this boot loop.

Did you reflash the latest NikGApps over the old one and done all the steps I suggested here? This procedure should also work for users using NikGApps.

As the unofficial LOS FP4 release also ends up in a boot loop when GApps are installed with this update, you can see that there is a relationship to this fixes provided by the last update. And it seems that this is a bigger problem with Google Play Store, not (only) a LineageOS one.

Yes, that was it.
Didn’t find the setting at first, thought it was a global setting and not somewhere in the PlayStore app.

@TeamB58: I checked the build instructions and found that the FairphoneCamera is not available open source but only as binary blobs via the script :disappointed_relieved:. So would just the right combination of forwarded proprietary blobs make up and running? Does show what is missing to get there? Your help would be much appreciated …

Hi All,
Do we still have issue with the latest build related to Lineage or as per the ongoing discussions, it’s related to the GApps package it self?

Please help confirm this by today.


1 Like

hey Margherita_Gr!
I had similiar issues like you at first.
for me worked the the lastest package ( together with an older version of gapps (
The system is working again apart from gapps. I don’t mind the non functional gapps as long as everything else is fine. I just wait for upcoming updates.

The problem is a correlation between the last update and using any Gapps packages (at least MindTheGapps, NikGApps, microG), It can be fixed by reflashing the Gapps package again and correct the messed up permission on these packages. Otherwise the phone is stuck in an endless boot loop, as it can’t start the Gapps services.

I doubt that the disfunction of the Gapps will be fixed in any LOS release in the future as it’s not the fault of LOS and provide no Gapp package by theirself. After you successfully reinstalled the Gapps package, just complete my workaround and fix your Gapp-Settings to have a fully functional phone again. It’s not that complicated and is fix in a minute! :wink:

Did you remove the build because of the issue?
Does this mean you were able to fix it? If so, very cool! If not, still good to remove it.

Yes, fixed with


after reflashing MindGapps to its base version the boot is successful

Can you explicit what you mean here ? I am locked at this preliminary step.

Thank you for the whole explanation though.

Just wanted to say that you need to select the right package for your phone in relationship to the LOS version the user is running, as at least also FP4 is affected by the bug.

For that phone, you currently need the right “base” package which is in relationship to the LOS19 or LOS20 build people are using on their phone.

which GAPPS package variant is used by the most maintainers / developers of LOS 19 for Fairphone 3/3+?

I’m currently using MindTheGapps, but am willing to switch to another variant to avoid having problems, that are specific to my GAPPS variant, so that the maintainers can’t reproduce the problem.

I have the impression, that the combination of MindTheGapps-12.1.0-arm64-20220605_112439 version which I initially installed with LOS19.1 causes some permission problems for classes/packages like System UI and TelephoneRegistry, which are finally leading to problems like freeze - often logcat contains several lines reporting very long draw-times, which indicate severe system stability problems. Especially MagicEarth is freezing very often - this was not the case as long as I used the stock ROM.

Is the MindTheGapps package containing some parts that are not regularly updated? - like some setting-files, scripts
→ should I perform a sideload update of LOS in combination with a new MindTheGapps release?
Which MindTheGapps version should I use in combination with the next update of LOS?


1 Like

But what does that mean getting “the right package” ?

Of course I use the package that is built for my phone with the GG package. (I have used those for two years and upgraded them at least three times without troubles)

I just tried setting the last build (as I saw it available this morning) and I am still blocked in the boot loop.

Same here with microg.
When the phone sleeps it’s loosing the Wifi. When waking up it reconnects to Wifi again.
No great problem to me as long as I have mobile data too.

some time ago I reported the following problems from some of my logcat logs:

Today I found
There is documented the way to set permissions for system apps.

Which part is responsible to set those permissions for system apps like “SystemUI”?
Is it the task of the LOS19.1 package for FP3/3+? - or is this the task of MindTheGapps?
Is it possible to add a settings file to /etc/permissions without rooting the device? - by adb session with console text editor like “vi”? - or is this partition mounted read-only?
My Fp3 freezes very often and several activities are lasting longer the used from Stock-ROM.
For example MagicEarth freezes on LOS19.1 at FP3 very often.
Also on start of “Open Camera” the access to the camera device is often provided with a very long delay.

So I’d like to fix all my detected permission problems to see whether this changes anything of the other problems.


I’m seeing the message
LocSvc_ApiV02: reportSv:3443] At least one RF_LOSS is 0 in gps.conf, please configure it

Seems I get a gps fix, but using a navigation app fills the log with these messages