Official LineageOS 18.1 for Fairphone 3/Fairphone 3+

When booting, the screen remains black until the lineageos logo appears. I can also no longer boot into recovery. The screen remains black.

Hello, do you know if the problem is known that the Fairphone logo no longer appears when starting and instead you have a black screen?
Also the message that the bootloader is unlocked is no longer displayed.

Hi,
This could most likely be that the splash partition is corrupted. Maybe you can flash splash.img from the stock release package.

I am not sure as I have not tried this before. Awaiting suggestions from others.

Hey, this has been the case for me since the last update but one. Before that, everything was always OK.

Mmmmh, so it looks like I’m the only one… :slight_smile:

The problem is still there after today’s update.

I tried to fix it myself by reloading the splash screen with fastboot. When I do this, I get the following error message:
./fastboot flash splash_a splash.original.img
Sending ‘splash_a’ (11264 KB) OKAY [ 0.469s]
Writing ‘splash_a’ FAILED (remote: ‘partition table doesn’t exist’)

What am I doing wrong?
With the command:
./fastboot flash splash splash.original.img
I don’t get an error message but when I start the Fairphone the splash screen is not displayed.

As I said, everything worked until two updates ago. Something must have gone wrong.
I would be very pleased to receive help.

I understand your bootloader is unlocked, so what about just flashing LOS?

As far as I know the splash partition is just data containing the image to display. To actually display the image code has to run, and I believe that code is part of the Android boot, i.e. the aboot_a/b partitions. I could not be bothered to disassemble the code, but the splash partition is definitely mentioned there:

$ strings aboot.img |grep -i splash
SPLASH!!
splash
ERROR: splash Partition not found
ERROR: Cannot read splash image from partition
ERROR: Splash image size invalid
ERROR: splash Partition table not found
ERROR: splash Partition invalid
ERROR:splash Partition invalid blocksize
ERROR: Cannot read splash image header
ERROR: Splash image header invalid
ERROR: splash Partition invalid offset
ERROR:splash Partition invalid memory
mmc read splash failure%d
chip serial splash =%d

You might try re-flashing both slots (A and B) with aboot.img, but I don’t see how you could arrive at a state where something like this would break.

1 Like

I don’t understand what happened either. As I said, the whole thing happened after the update.
Can you tell me exactly how I have to proceed now regarding aboot.img?
And where do I get aboot.img?

So just flash the current LOS version over it again? Will no data be lost in the process?
And should the new update this morning also have eliminated the problem after installation?

The official LineageOS OTA zips include the aboot image, so flashing those should do the trick. I can’t guarantee this will change anything for you though. I would also assume that waiting for the official update to install will have the same effect.

Thanks for the help. I also thought it would be enough to install the weekly update to get it working again but unfortunately that was not the case.
Do I just have to flash it to A and then to B one after the other?

Yes, that would overwrite both slots. Still not convinced it will help you though…

What would be the alternative?

That’s pretty hard to tell from a distance. If you don’t feel like giving up on this issue, feel free to write me a PM to keep this thread from growing out of control.

After this update, the splash screen und unlock message ist back :slight_smile:

I did yesterday and today some test calls and even on lowest audio settings calls over speaker and headset are pretty loud. I’m not sure if it has to do with latest update (I missed the last 2 or 3 updates) but we had this problem before (see postings on 23.04. and 25.04.). Hope this will be fixed in the next update. Thanks a lot in advance!

I installed LineageOS for my girlfriend today. Unfortunately, the front camera has only 12 megapixel resolution and the rear camera only 4 megapixel. Even with the Google camera app there is no improvement. I hope that it gets back its full resolution through an update.

Hi, and welcome to the forum.
Many people have already stumbled over the apparent discrepancy in advertised and final resolution, at least for the front camera. This support article also talks about “12 MP output”, so that would explain the issue for the front camera.
I cannot tell you anything about the rear (selfie) camera. I suppose we can assume that the sensor there might also use 4 “physical” pixel elements to generate one output pixel. Others might wish to comment on that.