Official LineageOS 18.1 for Fairphone 3/Fairphone 3+

Done, see here: Unable to use NFC interface (#4132) · Issues · LineageOS / issues / android · GitLab

I’m also starting to get warning messages about having a rooted device, although I’ve never rooted this particular device. I installed LineageOS, OpenGApps pico, and relocked the bootloader. E.g., the official german Corona notification app complains about root.

1 Like

I assume the App detects a custom ROM and just names it incorrectly as root…however there is a fork available in F-Droid which should work Corona Contact Tracing Germany | F-Droid - Free and Open Source Android App Repository

1 Like

Also, i opened an issue on cwa’s git repo asking to be able to acknowledge the message for good which resulted in a feature request from the team itself. So, it may be able to deactivate that popup in the near future

Thanks, but at least for me personally, the false positive root detections are not really an issue. I just mentioned them to give an additional data point for the discussion of the issue above.

1 Like

Hi together,
some posts above I complained about wifi-crashes which happen all the time while I am connected. I think I found out the reason for that.
It seems to have something to do with 5 GHz. If I disable my 5GHz wifi with the same SSID, the crashes do not happen any more. If I rename the 5GHz band to a seperate SSID, I can’t connect to that network - only to the 2.4GHz one.

That’s a bit odd,

  • does it show
  • what frequency band do you have the phone set to?
    Settings > Network and Internet > Wi-Fi >Wi-Fi preferences > Advanced > Wi-Fi frequency band

Sorry my Settings are for default A10

Factory reset. Huge difference. Phone is responsive. Guess something went wrong during the last major LOS update. Happy to finally have this issue resolved.


Finally took some time to upgrade from LOS17 with locked bootloader. No data loss, everything went great, thanks devs! :slight_smile:

Question: does Galileo GNSS work for anybody here?

When using Gpstest, I see Galileo sats listed but never get a C/N0 for them, but do get values for the other sats (GPS. GLONASS, BeiDou)
I did notice the same on LOS17.1 just before upgrading. Couldn’t find any LOS bugs about GNSS or Galileo.

Latest update: has anyone’s torch started to flicker when on via the notification shade? Only noticed it recently so may have been an older issue

Update: I think this was fixed by changing the performance from the middle option to high

Anyone happen to use the ProtonVPN app?

I noticed the app is not visible in the android VPN settings, and therefore I cannot enable its killswitch. But using a different vpn app like ‘OpenVPN for Android’ and ‘OpenVPN Connect’ are actually showing up in the VPN settings. No sure if this is a ProtonVPN bug or LOS bug.

ProtonVPN user on LineageOS 18.1 here (!Not Fairphone 3/3+, but Samsung Galaxy S5!):
I see ProtonVPN in the android settings and I would be able to enable the kill switch.
Seems that it might be connected to the LineageOS build for Fairphone or how you’ve installed the app itself.

Thank you for the reply. I tried the official .apk, fdroid version and Aurora store version, but no luck. I’ll guess for now I’ll stick to the OpenVPN app.

Upgraded to latest version. Now all my launcher shortcuts are gone and I can’t add new ones!

This has happened before. My factory reset solved that too, but I don’t want to do that again…

Looks like the Nov 29 build was withdrawn from

For a few builds now, I’ve been having an issue where I can’t make or receive calls, seemingly at random. A reboot fixes it. Anyone else experience this?

Not for me. I can use the phone just fine

Weirdly enough, I can’t use both SIM cards at the same time. I get that the Fairphone 3 is a Dual Sim Dual Standby phone so I’m not supposed to be able to have calls or data enabled on both cards at the same time, but I can’t get both to be in standby mode at the same time. If I set one card to be the default for mobile data, I can use it normally, but the other one will disconnect (“No service”), and I become unable to use it for sending / receiving texts nor calls. I have to switch the card used for mobile data regularly if I want to make sure I’m not missing a text.

Before I try flashing the original ROM to see if it’s a hardware problem, can someone confirm it’s possible using LineageOS 18.1 to have two SIMs in standby at the same time (e.g. being able to receive text on either without having to go to the settings)?

I can confirm this! Using 2 SIMs simultaneously

Is it normal on this ROM that I have to move the performance slider all the way to the right to get a somewhat snappy experience? Otherwise the phone seems reeeaaally slow :confused: