Official LineageOS 18.1 for Fairphone 3/Fairphone 3+

I know I’m late to the party regarding this discussion, but my vote is strongly for including the Fairphone camera into the LineageOS ROM (or at least offer it as a flashable ZIP or as an APK). Snap is just way too simple in my opinion, and OpenCamera is starting to get annoying with the multi-second delay before taking a picture.


I tried once, but the app did not work reliably when simply copied onto the system. Right now I am using a Google Camera port, will post a link later. See also this discussion.

1 Like

It has a few additional proprietary dependencies and a few arcsoft libraries.

Thank you for that link, I’ll test the Google one for now.

If I’m reading the nightly changelog correctly, it looks like some extra ambient display and raise to wake features are being introduced in the next build. Great stuff!

From our side we have now uploaded a hotfix to mitigate the auto-brightness problems. Fix will appear in next build cycle coming week.

Idea: define the minimum brightness at a reasonable level with display still readable. This should prevent insane behavior.

The Google “machine learning” thing is still very complex (every app gets its own brightness adjustment parameters) so I doubt people will be much happier with it. :neutral_face:


I’ve got terrible performance after upgrade to 18.1 and phone is extremely sluggish. Uninstalling some apps helped, but phone still lags a lot. Could a fresh install help? Or any other suggestions?

Well since you asked for suggestions, I would suggest you enable developer mode in the Settings menu (you will find instructions online), then hook up a data cable, install adb and run adb root, followed by adb shell top, to look for processes that are slowing down your device.


Try setting the performance-profile to max (more performance), that solved it for me. Only downside is it drains the battery a bit faster outside of sleepmode.


Depending on what apps you’re using it might also be a memory problem. I activated zram (and am experimenting with how much seems to be the optimum in my case, right now I’m using 512MB), but reactiveness is a lot better.
I still have a copy of a payed franko kernel manager where this is easy.
I would start with @dk1978’s suggestion, though

1 Like

Hi there!

First I want to say thank you for all the effords which have been put in bringing LineageOS to Fairphones!
Then to my question: I have a Fairphone 3 with LineageOS 17.1 (20210524). Now I have the problem that the phone shows “can’t read data” after the first boot does’n complet and the phone starts booting again. (I can imagine no reason for this, since I don’t recall doing something (like OTA updating etc.) which might have caused this.)

My question is: Might it be a good idea “just” to upgrade to 18.1 via the normal way? (Install LOS + Magisk via Sideload via TWRP)


Is it possible to have Wifi calling in LOS 18.1? There is an option in the settings to activate it, but if I do so and dial ##4636## to show the IMS service status, it will say “Voice-over-WLAN: Not available”. I know that my carrier does allow VoWifi because it worked in stock rom.

Update: Unfortunately I had problems installing the current LOS 18.1, but I tried multiple times. Now I’m back to stock rom because I really need the phone.

I will look into this.

1 Like

Sorry to hear that. If you have time and feel like trying again later, PM me here on the forum or contact a Fairphone Angel so we can look into the problem.

My impressions of the auto brightness fix is that it’s still the same behaviour, it just that the lowest brightness setting is higher now, so it’s not as noticeable. All in all, it’s not annoying anymore.

I’m still having issues with NFC, I’m unable to pay with it or read my ID card, both of which worked before switching to LOS.

I also noticed that two different apps seem to be unable to use any data connection. I’m not sure if this is because of LOS, some OpenGapps weirdness, or the apps themselves. Although now that two apps show problems independently, I’m starting to think it might be a common reason.

which apps? and which mobile provider are you using? I think I have read about issues with t-mobile using ipv6 settings in the APN settings…

The APN doesn’t say anything about IPv6, I’m on a german reseller of E-Plus. Both apps also don’t work on WiFi, or on VPN connections, so it probably aren’t the mobile network settings that are broken.

The Apps are S-Invest and Endlos-Quiz Pro, both installed directly from the Play Store.

I have been using WiFi calling since 17.1, also works on 18.1. Dialing ##4636## displays an error dialog however…

It’s *#*#4636#*#*.
The forum software uses asterisks for formatting (notice the italic characters in the source), so it doesn’t get displayed that way if users type this string without working around this behaviour.