Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

Hello,

back in december I installed @dk1978 's alpha image of LOS17.1 on my daughter’s brand new FP3+, and it has worked flawlessly until now.
Question 1: Now I’d like to switch to the official LOS17.1 image. Do I just flash it over the alpha like I did for the alpha at the time ? Will I need to reset the phone ?

Question2: I didn’t bother with relocking the bootloader at the time since it was only for testing… but the little devil took it and used it like the present that it was :slight_smile: So now, if I relock the bootloader, will I loose the data ?

Thanks,

Rémi

Hi @knefl,
I updated to the latest version (20210414) yesterday and notifications still don’t show up.

Thanks for your feedback, @in-go !

I suspect that it is not a problem of LineageOS though, but possibly a problem of FP3-specific components.
We have two LineageOS-for-microg 17.1 devices (including an FP2) here in our household that do not have the problem. The screen activates when a message is received.
But my wife has the FP3 with the FairphoneOS (Android 10) and here too the screen does not wake up. However, that had still worked on FairphoneOS on Android 9.

Maybe @dk1978 can say something about my assumption?

Just as a reminder: It did work with the GSI version of LineageOS 17.1 microG…

Looking at https://eu.community.samsung.com/t5/galaxy-s10-series/s10-notifications-not-waking-up-screen/td-p/979612

It appears that in that situation it will work with native apps, but not WhatsApp for example. Though the ref is A10

@amoun
You can’t compare Samsung phones with stock android. Samsung devices run OneUI, a highly modified android interface. This means that many things don’t look or don’t work the same. In this case, notification bubbles are not implemented in stock android yet (at least not in A10, still experimental in A11), while they are in OneUI.

Edit: Precision about notification bubbles added

4 Likes

Thanks for all the hard work on lineage os for fp3!

I’m on the April 12, 2021 build and restarting actually turns the phone off - I’ll try the next build when it comes out to see if that fixes it…

Hi everyone, I had already posted here some issues I’ve been having with LineageOS on FP3+, but didn’t get any replies, so let’s see if I have better luck here.

When my Fairphone 3+ arrived 2 weeks ago, I immediately installed the latest LineageOS on it, but I have been experiencing some problems. I’m not sure if the phone is at fault, or if it is due to LineageOS. Hoping you can help, or if not, point me in the right direction to get some assistance.

  1. the most serious problem is the headphone jack. Listening to music or calls is fine, but the microphone seems to be very badly distorted. I tested it on multiple headsets which are working fine on other phones. Currently I can’t use the jack for phone calls as the other party can’t hear what I’m saying.

  2. Wifi/mobile is much weaker than my previous phone (Xiaomi Mi5). For example, in my bedroom I am a long distance from the wifi modem, but this wasn’t much of a problem for my previous phone. With the FP3 I get no wifi signal. Same with the mobile data, it’s much weaker than the previous phone.

  3. Whatsapp calls seem to occasionally lose connection when screensaver comes on. It gives a message saying it’s trying to reconnect and the other party can’t hear me (nor me them). If I turn on the caffeine feature, the problem doesn’t happen.

  4. This is a minor issue but it would be nice to have a solution. I like to listen to music in bed before I sleep, and I usually have the volume at the minimum. However on the FP3, the volume is too loud at min setting - is there any way to lower it further?

Many thanks.

1 Like

Sadly the best option would be to return to FPOS and compare :frowning:

Hello together,

I can confirm the problem no. 2 of FairlyLively.
On a specific place where I always but my phone I can’t stream music with Lineage but I could listen with Android. Android was installed for nearly one year, lineage is now installed since this winter and since it came out. The WIFI/WLAN driver seems to crash or disconnect. If I only tab on the network, it connects immediately again.
The crashes seem to become more frequent in low wifi connections on much distance to wifi router. But it could also happen if i sit in front of the router.
It is not a specific problem of my router, this also happens on public wifi and bad connection quality.

Installed at the moment: Lineage 17.1 (04-12-21)

2 Likes

On the April 19, 2021 build now - reboots fine now…

I can confirm point number 4 about the volume. The lowest volume setting is very loud compared to the stock rom and is not usable for listening music when waking up.

1 Like

Thanks for confirming! Number 1 is the one I’m most concerned about as I think it may be a hardware issue - Fairphone support are telling me that they won’t support the issue until I revert back to the original OS, which is understandable, but frustrating.

You don’t have any microphone problems if you use a headset with the jack?

This is something I should be able to adjust with a sane amount of effort. Would be a welcome break from chasing bugs I can never reproduce on my devices. :smiley:

3 Likes

I’m using a headset while phoning quite regularly. Up to now nobody complained about not understanding me, or bad sound quality (and from ongoing conversation i can deduce they understood me :slight_smile: )

1 Like

Thanks for confirming - that’s what I feared. It’s too obvious an issue to have been missed. So it looks like I’ll have to restore the original OS in order to get Fairphone to fix the issue. Frustrating!

The issue on FOS is from my understanding the same, no problem with headphones/earphones but very low volume and echo sometimes in hands free/WhatsApp etc

Detail on following post about FOS A10 0077 not resolved in A10 0084 but finally acknowledge as an issue.

1 Like

I’m sorry, I don’t have a headset, but I will try it when my gf comes here. She has one.

1 Like

Just switched (coming from /e/ Pie). Feels good to be back at a true LOS!

Being an audio fan, I kind of liked the Bluetooth SBC ‘XQ’ HD audio extensions that /e/ Pie (and I imagine LOS Pie) offer. I did not see the option on this FP3 LOS Q. Can anyone comment on this?

I don’t have BT devices here for testing. Did you try the SBC option in the Developer Options/Bluetooth Audio Codec? Edit: maybe with device connected, option does not change for me.