Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

I can confirm point number 4 about the volume. The lowest volume setting is very loud compared to the stock rom and is not usable for listening music when waking up.

1 Like

Thanks for confirming! Number 1 is the one I’m most concerned about as I think it may be a hardware issue - Fairphone support are telling me that they won’t support the issue until I revert back to the original OS, which is understandable, but frustrating.

You don’t have any microphone problems if you use a headset with the jack?

This is something I should be able to adjust with a sane amount of effort. Would be a welcome break from chasing bugs I can never reproduce on my devices. :smiley:


I’m using a headset while phoning quite regularly. Up to now nobody complained about not understanding me, or bad sound quality (and from ongoing conversation i can deduce they understood me :slight_smile: )

1 Like

Thanks for confirming - that’s what I feared. It’s too obvious an issue to have been missed. So it looks like I’ll have to restore the original OS in order to get Fairphone to fix the issue. Frustrating!

The issue on FOS is from my understanding the same, no problem with headphones/earphones but very low volume and echo sometimes in hands free/WhatsApp etc

Detail on following post about FOS A10 0077 not resolved in A10 0084 but finally acknowledge as an issue.

1 Like

I’m sorry, I don’t have a headset, but I will try it when my gf comes here. She has one.

1 Like

Just switched (coming from /e/ Pie). Feels good to be back at a true LOS!

Being an audio fan, I kind of liked the Bluetooth SBC ‘XQ’ HD audio extensions that /e/ Pie (and I imagine LOS Pie) offer. I did not see the option on this FP3 LOS Q. Can anyone comment on this?

I don’t have BT devices here for testing. Did you try the SBC option in the Developer Options/Bluetooth Audio Codec? Edit: maybe with device connected, option does not change for me.

I tried around there, but I do not seem to get any other option than SBC enabled any longer than until leaving the Developer Options menu :flushed:

The SBC ‘XQ’ options in /e/ Pie were available as ‘HD audio: SBC’ (much like here) in my Bluetooth headset’s settings.

If I can help by testing or supplying logs, please let me know.

The update today breaks something. The message was the filesystem is corrupt and I can try to reboot or make a factory reset or something. I pushed the power button + volume down to boot in fastboot mode and changed the active slot with " fastboot --set-active=a". The active slot is shown in the error message and when it says b. Then you have to change it to a for example.


same here. It had just finished installation on my FP as I read your post… :slight_smile:


Edit: nvm, confirmed the problem. :frowning:


I have the same problem after the new update. I switched the active slot, but get the same error message on the second slot. After another reboot, the second slot booted properly.

1 Like

To switch regardless of the active slot: fastboot set_active other


Life never gets boring with Android. :sweat:
Please don’t do what the message says about wiping data. Something broke on the LineageOS side, and I will find the problem and maybe block the update so nobody installs it.



is it possible to update from @dk1978 's alpha image from December to official LOS17.1 while keeping data ? Do I just flash the official rom over the alpha ?

About the flakey update (which I downloaded & installed just before getting here :neutral_face:): seems that rebooting [& failing to load Android] 3 times in a row, causes LOS (recovery?) to switch the slot. My FP3 is up again (sigh :grinning:)

1 Like

@dk1978 I guess it’s something with April security update that is causing this issue. Do you see any other reports confirmed by other maintainers?

There were reports that some devices, e.g. mata refused to boot after CAF changes. The last (broken) update was removed from the servers just now.