Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

Though restarting hasn’t shown an effect before, it did now and everything works well again. Thanks.

Hi all,

First of all I also want to thank all the Devs (especially @dk1978 ) here for providing LineageOS for the FP3/FP3+. Your efforts are greatly appreciated!

I am also using a FP3, still with one of the first 16.0 unofficial image. Because I am planning to update to LineageOS 17.1 from the official LineageOS site soon I have a question regarding the firmware updates (modem/baseband/etc.) for the Fairphone 3.

Parallel to the update to LineageOS 17.1 I also want to update the firmware of the mentioned hardware components. If I am correct the LineageOS images will not update the firmware of the modem/baseband etc. Is this correct?

So is it somehow possible to extract the needed firmware files from the current Fairphone OS and flash them manually? Would it be wise to update the firmware or should I only doing this in case of problems?

Thanks a lot in advance for any help!

I have issues with increased battery drain, too. But to verify it is the same issue like yours, what should I do?

I am happily running the LOS 17.1 for microG. Thank you very much, @dk1978 ! This is really great :slight_smile:

Unfortunately, I have a problem that is quite serious. However, I do not know how to provide meaningful input on it. Would logs be helpful, and if so: which ones?
The problem: it has happened three times now that the phone just turns off in the middle of a call. I also don’t know if there is a warning in the sense of “phone is shutting down” or something like that on the screen, because I have it on my ear :wink: I also couldn’t find any common element between the three incidents, apart from the fact that I was on the phone (which of course doesn’t mean there isn’t one). The battery was not near zero, I didn’t receive an email, signal message or something at the moment it shut down. I haven’t had this problem with stock A9, stock A10 or /e/.

I am afraid this is nothing new and affects all OSes. There is an entire official Fairphone blog dedicated to the topic. I am hoping that an update of phone firmware (likely one of the modem or dsp partitions) will be able to fix this for us as well - but at the moment I have no idea as to what exactly causes the problem.

Hi and welcome to the forum!
You are correct, the LineageOS images contain partition images for system, boot, vendor, vbmeta, and dtbo. You can extract other partitions such as modem from stock OTA zips, provided you install the necessary tools and flash them yourself with fastboot. I do not believe this is harmful in any way, as the code on these partitions is suitably decoupled from the Android OS and partially runs on dedicated processors at runtime.
At the moment this may be an option to finally resolve the nasty random reboot during calls issue.
Please do backups of your data when you go from 16.0 to 17.1.

Thanks for your quick reply!
I am aware of the blog post, but I was of the opinion that my issue was a little different, for two reasons:

  1. It never happened to me before the installation of 17.1 (microG-version) although my phone is more than one year old
  2. Fairphone talks about random reboots. As far as I can tell, my phone does not reboot. It turns off and I have to press the power button for a veeeeeeery long time to wake it up again. To be honest, I never tried to wait for 60 seconds or so whether the phone turns on again by itself, I always pressed the power button after 20 seconds or so. What I noticed: in the call logs the last call during which the phone turned off does not show up, it seems to be not registered/stored.

But if you think that this is the same issue as in the blog post, I will just wait and hope that FP will sort this problem out…

Some good souls did this for FP2:

Maybe it can be adapted for the FP3 too?

Hi again,

thank you @dk1978 and @maba007 for you quick reply and your suggestions.

I checked the FP2 modem files, the Stock OTA zip for the FP3 and compared both. If I ignore the mentioned images by dk1978 (+ the userdata.img) the remaining .img, .bin and mbn files are:

(In the FP2 modem zip file, sdi.mbn is missing in the FP3 OTA zip)
emmc_appsboot.mbn
NON-HLOS.bin
rpm.mbn
sbl1.mbn
splash.img
tz.mbn

(Additional found in the FP3 OTA zip file)
adspso.bin
cmnlib_30.mbn
cmnlib64_30.mbn
config.bin
devcfg.mbn
FP3_flashall_mac.bin
frp.bin
km4.mbn
lksecapp.mbn
mdtp.img
product.img

Unfortunaly I cannot connect every file to a specific function and if it is really necessary or possible to update them. If I am correct the file “emmc_appsboot.mbn” is for the bootloader and “NON-HLOS.bin” for the LTE modem and maybe also for WLAN. But I am not sure about the functions of all other image files as I cannot find a reliable information about them in the internet. So my guess in the moment is that the six first listed images are important for the FP3 firmware update.

Maybe someone can check my assumption or has maybe a clue what the purpose of the unknown files are.

Thanks a lot in advance!

Tried that - No buneo

XXXX-iMac ~ % cd /Users/imac/Desktop/platform-tools
imac@5Ks-iMac platform-tools % ./fastboot devices
XXXXXXXXX - fastboot
XXXX-iMac platform-tools % ./fastboot flash recovery lineage-17.1-20210208-recovery-FP3.img
Sending ‘recovery’ (65536 KB) OKAY [ 1.716s]
Writing ‘recovery’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
XXXX-iMac platform-tools %

According to the documentation it should be

XXXX-iMac platform-tools % ./fastboot flash boot lineage-17.1-20210208-recovery-FP3.img

Edit: but it looks like you already tried that

This has been more promising TWRP booted using terminal was able to wipe all data as per alpha steps ( Dalvik /ART Cache and System, does not seem to want to side load the 17.1 zip file so going to try the 16.0 see if that works ( will update this post )

Can you be more specific about that? Any error messages? How did you execute the sideload from the computer?

OK so this is where I’m at…It got to 47% and maybe failed…not entirely sure? ( it said 47% on terminal and the progress bar on the side-loader got to halfwayish) This is the as far as i’ve got.

Last login: Sat Feb 20 12:42:16 on ttys000
imac@xxxx-iMac ~ % cd /Users/imac/Desktop/platform-tools
imac@xxxx-iMac platform-tools % ./fastboot devices
A2XXXXXXXXX fastboot
imac@XXXX-iMac platform-tools % ./fastboot boot twrp-3.5.0_9-0-FP3.img
Sending ‘boot.img’ (29490 KB) OKAY [ 0.661s]
Booting OKAY [ 11.459s]
Finished. Total time: 12.442s
imac@XXXX-iMac platform-tools % ./adb sideload lineage-17.1-20210208-nightly-FP3-signed.zip
Total xfer: 1.00x
imac@XXXX-iMac platform-tools %

The Fairphone now says this

UPDATE <<<<<< This worked both Slot A and B said there was no recognized OS prior to reboot. Decided to go for a cheeky reboot anyway then out of the darkness emerged the Lineage animated logo HUZZAR !!

Huzzar

5 Likes

Hello guys,

Hope i’m not coming with a bug everyone already knows about, but right after a fresh install where I activated WiFi and installed a few apps on a new FP3+, I noticed I don’t have 4G connection working…

I can see the mobile network type in the icons drawer (when I pull from status bar, in the “mobile data” icon; it is activated and says it has 4G or H+ connectivity), but status bar network icon does not show the 4G text… And when trying to load a page it says I don’t have internet.
The icon in the status bar is in the same state as when you disable mobile data (which I did not of course)

I tried with or without roaming, checked every option I could find…

Anyone having the same issue ? Or knowing how to debug this?
I installed without opengapps. Installation went smoothly except I had to re-flah LOS after changing recovery to twrp.

Than you in advance !

Thank you for your reply. Unfortunately I’m unsure how to verify that. Does anybody else have deeper insight ir an idea?

3 steps here as having the same issue its a crock of shit.

  1. Go buy yourself a pay as you go sim for a £ from a corner shop/ Tesco etc on another network.
  2. Put the sim in the phone does it work. Yes/No
  3. If it works the issue is your provider. Phone them. Certain phone providers are very 1984 in the UK.
  4. If it doesn’t check your APN numbers https://community.ee.co.uk/t5/4G-and-mobile-data/EE-APN-Settings-Where-to-find-them/td-p/741851

Failing that scream into the void and phone Fairphone when they open on Monday

I don’t think that helps as long as LineageOS is installed.

2 Likes

OH yes :slight_smile: Fairphone have no desire or design to support anything other than FP OS A10

I tried two different pay as you go sims. Both Vodaphone and EE PAYG sims work (Calls & data) on the fairphone, two different EE contract sims do not work with data in the Fairphone but work with calls. The same contract sims works in a different phones with data and calls . It’s not a Linage issue its a contract network provider issue and it’s preventing data getting to the phone. I believe EE are actively preventing this to discourage normal users choosing less invasive OS, this is done automatically without permission by the network by checking for particular traditional signifying outgoing API’s, if they don’t find them your phone gets the silent treatment. The issue has been raised to 3rd tier support. They don’t have a clue or are playing dumb, tbh I’m not sure. I will be running wireshark over the next few days and post my findings here.

UPDATE >>> Fixed they rang this morning to tell me my device had been blacklisted and it took 48 hours to appear. They removed me from the list hay hoo data is back.

4 Likes