English

Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

Since using the update from Jan 27 (microG), I see an increased battery drain by the cellular network standby process (> 33%), despite being connected to WiFi. I disabled the parallel connection option in the developer menu, but no avail. Does anybody run into the same issue or know how to solve that?

Hi community. First of all I want to thank all the Devs here for contributing all the good stuff what makes my FP3+ such a great device.
I hope I’m addressing my “issue” in the proper channel (I don’t really know if it’s a feature request or a bug):

I’m running my FP3+ with LineageOS 17.1 and OpenGapps Nano. When connection the FP3+ via Bluetooth with my car the car does not show the signal quality of the connected device. It also tells me, that there is no service available. Nevertheless I can make an receive calls through the car system what is really strange. I tried to switch to the different Bluetooth AVRCP versions to fix this behavior (1.4 - 1.6) with no success.

BUT: When adding a second SIM into Slot 2 everything looks as expected. My car shows the signal quality and the provider information of SIM in Slot 1 when connected via Bluetooth. I tried this in two other vehicles from colleagues and it is exactly the same behavior.

My conclusion is that the LineageOS 17.1 Bluetooth stack is sending the connection status of SIM 2 if only one SIM is inserted into the phone (SIM 1 slot) which gives a misleading information to car systems. Luckily telephony works. It would be great if this could be fixed.

1 Like

Hi aes0p and welcome to the forum,
I would recommend you post an issue on the LineageOS so it can be tracked there.

Done:

2 Likes

Hi all,
when I set the notification color for Signal to green and I am charging my phone (between 15 and 90% -> yellow color), then the notification color for Signal is red (green + yellow?). Has anybody the same issue?

Yes, color is “a bit off while charging”, but also non charging it looks like it’s not completely honoring the settings, which might also be caused by hardware limitation, as i always observe some " cycling " while composing a color

I’m running LOS 17.1 (version 1st Feb 2020) on my FP3+. Last week and this week I’m having a problem with the Updater. I download the new LOS update in the Updater, but when I click “Install”, the Updater crashes and I get a notification that the app has been repeatedly terminated (“Updater wird wiederholt beendet”). I have no clue what caused this, because I didn’t change any settings or similar stuff.

I have just updated and had no problems. (from Feb. 1 to Feb. 15)

  • Is it the first time you update after installation?
  • What version are you using now and to what version do you try to update?
  • Have you tried to re-download the file?
  • Have you tried running it after a restart?

Though restarting hasn’t shown an effect before, it did now and everything works well again. Thanks.

Hi all,

First of all I also want to thank all the Devs (especially @dk1978 ) here for providing LineageOS for the FP3/FP3+. Your efforts are greatly appreciated!

I am also using a FP3, still with one of the first 16.0 unofficial image. Because I am planning to update to LineageOS 17.1 from the official LineageOS site soon I have a question regarding the firmware updates (modem/baseband/etc.) for the Fairphone 3.

Parallel to the update to LineageOS 17.1 I also want to update the firmware of the mentioned hardware components. If I am correct the LineageOS images will not update the firmware of the modem/baseband etc. Is this correct?

So is it somehow possible to extract the needed firmware files from the current Fairphone OS and flash them manually? Would it be wise to update the firmware or should I only doing this in case of problems?

Thanks a lot in advance for any help!

I have issues with increased battery drain, too. But to verify it is the same issue like yours, what should I do?

I am happily running the LOS 17.1 for microG. Thank you very much, @dk1978 ! This is really great :slight_smile:

Unfortunately, I have a problem that is quite serious. However, I do not know how to provide meaningful input on it. Would logs be helpful, and if so: which ones?
The problem: it has happened three times now that the phone just turns off in the middle of a call. I also don’t know if there is a warning in the sense of “phone is shutting down” or something like that on the screen, because I have it on my ear :wink: I also couldn’t find any common element between the three incidents, apart from the fact that I was on the phone (which of course doesn’t mean there isn’t one). The battery was not near zero, I didn’t receive an email, signal message or something at the moment it shut down. I haven’t had this problem with stock A9, stock A10 or /e/.

I am afraid this is nothing new and affects all OSes. There is an entire official Fairphone blog dedicated to the topic. I am hoping that an update of phone firmware (likely one of the modem or dsp partitions) will be able to fix this for us as well - but at the moment I have no idea as to what exactly causes the problem.

Hi and welcome to the forum!
You are correct, the LineageOS images contain partition images for system, boot, vendor, vbmeta, and dtbo. You can extract other partitions such as modem from stock OTA zips, provided you install the necessary tools and flash them yourself with fastboot. I do not believe this is harmful in any way, as the code on these partitions is suitably decoupled from the Android OS and partially runs on dedicated processors at runtime.
At the moment this may be an option to finally resolve the nasty random reboot during calls issue.
Please do backups of your data when you go from 16.0 to 17.1.

Thanks for your quick reply!
I am aware of the blog post, but I was of the opinion that my issue was a little different, for two reasons:

  1. It never happened to me before the installation of 17.1 (microG-version) although my phone is more than one year old
  2. Fairphone talks about random reboots. As far as I can tell, my phone does not reboot. It turns off and I have to press the power button for a veeeeeeery long time to wake it up again. To be honest, I never tried to wait for 60 seconds or so whether the phone turns on again by itself, I always pressed the power button after 20 seconds or so. What I noticed: in the call logs the last call during which the phone turned off does not show up, it seems to be not registered/stored.

But if you think that this is the same issue as in the blog post, I will just wait and hope that FP will sort this problem out…

Some good souls did this for FP2:

Maybe it can be adapted for the FP3 too?

Hi again,

thank you @dk1978 and @maba007 for you quick reply and your suggestions.

I checked the FP2 modem files, the Stock OTA zip for the FP3 and compared both. If I ignore the mentioned images by dk1978 (+ the userdata.img) the remaining .img, .bin and mbn files are:

(In the FP2 modem zip file, sdi.mbn is missing in the FP3 OTA zip)
emmc_appsboot.mbn
NON-HLOS.bin
rpm.mbn
sbl1.mbn
splash.img
tz.mbn

(Additional found in the FP3 OTA zip file)
adspso.bin
cmnlib_30.mbn
cmnlib64_30.mbn
config.bin
devcfg.mbn
FP3_flashall_mac.bin
frp.bin
km4.mbn
lksecapp.mbn
mdtp.img
product.img

Unfortunaly I cannot connect every file to a specific function and if it is really necessary or possible to update them. If I am correct the file “emmc_appsboot.mbn” is for the bootloader and “NON-HLOS.bin” for the LTE modem and maybe also for WLAN. But I am not sure about the functions of all other image files as I cannot find a reliable information about them in the internet. So my guess in the moment is that the six first listed images are important for the FP3 firmware update.

Maybe someone can check my assumption or has maybe a clue what the purpose of the unknown files are.

Thanks a lot in advance!

Tried that - No buneo

XXXX-iMac ~ % cd /Users/imac/Desktop/platform-tools
imac@5Ks-iMac platform-tools % ./fastboot devices
XXXXXXXXX - fastboot
XXXX-iMac platform-tools % ./fastboot flash recovery lineage-17.1-20210208-recovery-FP3.img
Sending ‘recovery’ (65536 KB) OKAY [ 1.716s]
Writing ‘recovery’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed
XXXX-iMac platform-tools %

According to the documentation it should be

XXXX-iMac platform-tools % ./fastboot flash boot lineage-17.1-20210208-recovery-FP3.img

Edit: but it looks like you already tried that

This has been more promising TWRP booted using terminal was able to wipe all data as per alpha steps ( Dalvik /ART Cache and System, does not seem to want to side load the 17.1 zip file so going to try the 16.0 see if that works ( will update this post )