English

Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

I just quit out of terminal and reestablish the directory and it worked partially but I got this…

XXXX:platform-tools imac$ ./fastboot flash recovery lineage-17.1-20210208-recovery-FP3.img
Sending ‘recovery’ (65536 KB) OKAY [ 1.706s]
Writing ‘recovery’ FAILED (remote: ‘partition table doesn’t exist’)
fastboot: error: Command failed

Maybe the alpha documentation isn’t up to par any longer… Might be easier to follow the instructions from the LOS wiki (in doubt see post # 1)

Where did you get this command from? I don’t see it in the guide you linked and it is just wrong.

1 Like

check the file for corruptions. i had the same issues on another device and the hint on that install guide was to rename the image file to something short, like recovery.img.

Good Evening,

The line you are questioning was my attempt at improvisation as I could not get the Alpha or offical Wiki guide to work.

I’ve gone back to the offical Wiki which is here Install LineageOS on FP3 | LineageOS Wiki and I’m stuck here.

See attempts below.

XXX:platform-tools imac$ fastboot devices
-bash: fastboot: command not found

XXX:platform-tools imac$ ./fastboot devices
AXXXXXXXXX fastboot

XXX:platform-tools imac$ ./fastboot flash boot recovery_lineage-17.1-20210208-recovery-FP3.img
fastboot: error: cannot load ‘recovery_lineage-17.1-20210208-recovery-FP3.img’: No such file or directory

XXX:platform-tools imac$ ./fastboot flash boot lineage-17.1-20210208-recovery-FP3.img
fastboot: error: Couldn’t parse partition size ‘0x’.

The tutorial which you mentioned above is written for Minimal ADB and Fastboot and not for plattform tools. Since this tool is only available for Windows, you have to use the original Android SDK Platform-Tools. The procedure should be more or less the same, although the place where you can put the plattform-tools folder might differ. And the command line tool on macOS is - of course - also a different one :wink:
I’m still planning to expand the tutorial for plattform-tools and thus for other operating systems like Linux and macOS…

You obviously don’t have the recovery in this directory. Only the full lineage. Might help if you show us the contents of your actual directory: ls

@lklaus here’s the file directory

@HolosericaCaligo thank you, I’ll remove the Platform Tools version I’m using and use the Android SDK Platform tools

Well,m looks like the “recovery_” in front of this filename is too much, the file name starts with lineage…

regarding my problems with video conference, looks like the mediaserver is crashing. Added more info in the lineage os tracker issue I opened.
Paging @dk1978 , but be assured it’s only for letting you know, I’m not expecting a reaction as long as you’re still busy with your personal needs!

Yep if you look at the line below the line your quoting you will see I did both… as I was cross referencing two different guides to see if either worked in this particular instance. Neither did…thank you for following up though :slight_smile:

Actually, no. First, you flashed recovery, then you flashed boot…
But, according to the LOS wiki, you’re supposed to flash boot.
So, this should work, if your image is correct.
I’m not sure whether you’re supposed to flash to boot_a or boot_b, though, as I always use a different approach: I temporarily boot twrp: fastboot boot twrp.img (from twrp.me)

Thank you - I’ll try twrp.img :slight_smile:

Since using the update from Jan 27 (microG), I see an increased battery drain by the cellular network standby process (> 33%), despite being connected to WiFi. I disabled the parallel connection option in the developer menu, but no avail. Does anybody run into the same issue or know how to solve that?

Hi community. First of all I want to thank all the Devs here for contributing all the good stuff what makes my FP3+ such a great device.
I hope I’m addressing my “issue” in the proper channel (I don’t really know if it’s a feature request or a bug):

I’m running my FP3+ with LineageOS 17.1 and OpenGapps Nano. When connection the FP3+ via Bluetooth with my car the car does not show the signal quality of the connected device. It also tells me, that there is no service available. Nevertheless I can make an receive calls through the car system what is really strange. I tried to switch to the different Bluetooth AVRCP versions to fix this behavior (1.4 - 1.6) with no success.

BUT: When adding a second SIM into Slot 2 everything looks as expected. My car shows the signal quality and the provider information of SIM in Slot 1 when connected via Bluetooth. I tried this in two other vehicles from colleagues and it is exactly the same behavior.

My conclusion is that the LineageOS 17.1 Bluetooth stack is sending the connection status of SIM 2 if only one SIM is inserted into the phone (SIM 1 slot) which gives a misleading information to car systems. Luckily telephony works. It would be great if this could be fixed.

1 Like

Hi aes0p and welcome to the forum,
I would recommend you post an issue on the LineageOS so it can be tracked there.

Done:

2 Likes

Hi all,
when I set the notification color for Signal to green and I am charging my phone (between 15 and 90% -> yellow color), then the notification color for Signal is red (green + yellow?). Has anybody the same issue?

Yes, color is “a bit off while charging”, but also non charging it looks like it’s not completely honoring the settings, which might also be caused by hardware limitation, as i always observe some " cycling " while composing a color

I’m running LOS 17.1 (version 1st Feb 2020) on my FP3+. Last week and this week I’m having a problem with the Updater. I download the new LOS update in the Updater, but when I click “Install”, the Updater crashes and I get a notification that the app has been repeatedly terminated (“Updater wird wiederholt beendet”). I have no clue what caused this, because I didn’t change any settings or similar stuff.